Subject: [scim] Interop results

From: Ian Glazer <[email-masked]>
Date: Mon, 6 Jun 2016 11:19:33 -0500

All -

I have placed my interop results deck in the Results folder -
https://drive.google.com/open?id=1MENZNkdhZdwTo-LvuDs6GNifaK85omitBDTFHvCO1pI

But for those of you having problems with access, I have also attached it.

Great session this morning everyone. I look forward to tackling the
comments we got from everyone.

i

-- 
Ian Glazer
Senior Director, Identity
+1 202 255 3166
@iglazer <https://twitter.com/iglazer>

---

From: Leif Johansson <[email-masked]>
Date: Thu, 16 Jun 2016 22:22:13 +0200

On 2016-06-06 18:19, Ian Glazer wrote:
> All -
> 
> I have placed my interop results deck in the Results folder
> - https://drive.google.com/open?id=1MENZNkdhZdwTo-LvuDs6GNifaK85omitBDTFHvCO1pI
> 

Is there enough meat here to put together an implementation report in
the sense of RFC 5657? I am also curious if there is enough energy
and implementation experience to turn out a "bis" draft, correcting
bugs and start the draft standard process?

	Cheers Leif

---

From: Phil Hunt <[email-masked]>
Date: Thu, 16 Jun 2016 13:28:55 -0700

I don’t think we need a bis draft. I believe we’re talking about some “squishy” points that require some errata clarification.

Some of these will also need to be reviewed in the context of: does the issue matter for interoperability?  Some “squishy” areas are intentional giving implementers freedom.

Phil

@independentid
www.independentid.com <http://www.independentid.com/>[email-masked] <mailto:[email-masked]>

> On Jun 16, 2016, at 1:22 PM, Leif Johansson <[email-masked]> wrote:
> 
> _______________________________________________
> scim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/scim

---

From: Ian Glazer <[email-masked]>
Date: Fri, 17 Jun 2016 09:54:20 -0400

Sorry I missed the meeting yesterday; I do hope we can resend the meeting
invite.

I think the squishy items include:
* PATCH implementation practices
* Appropriate response when GET'ing a resource but providing a filter which
wouldn't return the resource

However, the more challenging areas that aren't covered by extensions such
as Soft Delete are:
* Adding cardinality to Schema
* Enriching lifecycle state information more than just isActive
* Creating an MVP endpoint

On Thu, Jun 16, 2016 at 4:28 PM, Phil Hunt <[email-masked]> wrote:

> I don’t think we need a bis draft. I believe we’re talking about some
> “squishy” points that require some errata clarification.
>
> Some of these will also need to be reviewed in the context of: does the
> issue matter for interoperability?  Some “squishy” areas are intentional
> giving implementers freedom.
>
> Phil
>
> @independentid
> www.independentid.com
> [email-masked]
>
>
>
>
>
> -

---

From: "Phil Hunt (IDM)" <[email-masked]>
Date: Fri, 17 Jun 2016 08:35:13 -0700

MVP?

Phil

> On Jun 17, 2016, at 06:54, Ian Glazer <[email-masked]> wrote:
> 
> Sorry I missed the meeting yesterday; I do hope we can resend the meeting invite.
> 
> * Appropriate response when GET'ing a resource but providing a filter which wouldn't return the resource
> 
> However, the more challenging areas that aren't covered by extensions such as Soft Delete are:
> @iglazer

---

From: Kelly Grizzle <[email-masked]>
Date: Fri, 17 Jun 2016 15:48:50 +0000

The idea is to create a SCIM profile (or profiles) that has the bare minimum needed based on use case (eg – provisioning vs directory access).  For example, this might eliminate bulk and some other more complex features for servers that want to just hit the low bar.

From: scim [mailto:[email-masked]] On Behalf Of Phil Hunt (IDM)
Sent: Friday, June 17, 2016 10:35 AM
To: Ian Glazer <[email-masked]>
Cc: Leif Johansson <[email-masked]>; [email-masked] WG <[email-masked]>
Subject: Re: [scim] Interop results

MVP?

Phil

On Jun 17, 2016, at 06:54, Ian Glazer <[email-masked]<mailto:[email-masked]>> wrote:
Sorry I missed the meeting yesterday; I do hope we can resend the meeting invite.

On Thu, Jun 16, 2016 at 4:28 PM, Phil Hunt <[email-masked]<mailto:[email-masked]>> wrote:
I don’t think we need a bis draft. I believe we’re talking about some “squishy” points that require some errata clarification.

Phil

@independentid
www.independentid.com<http://www.independentid.com>
[email-masked]<mailto:[email-masked]>

On Jun 16, 2016, at 1:22 PM, Leif Johansson <[email-masked]<mailto:[email-masked]>> wrote:

All -

Cheers Leif

_______________________________________________
scim mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/scim

_______________________________________________
scim mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/scim

--
Ian Glazer
Senior Director, Identity
+1 202 255 3166
@iglazer<https://twitter.com/iglazer>
_______________________________________________
scim mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/scim

---

From: Shalini Gupta <[email-masked]>
Date: Thu, 30 Jun 2016 20:25:07 +0530

Sorry, could not join the last meeting as I was traveling back to India.
Are we meeting today? Can somebody please forward the invite..

There are other items as well which I also mentioned in the CIS Interop,
that we should address in the SCIM spec:

   - Adding scim version in ServiceProviderConfig
   - Dealing with data transfer on deletes
   - Crisply defining roles and entitlements
   - Adding cardinality for multivalued attributes
   - Issues around delete
   - Handling license assignments

-- 
Regards,
Shalini

---

From: "Phil Hunt (IDM)" <[email-masked]>
Date: Thu, 30 Jun 2016 09:24:54 -0700

Morteza, Leif?

I am available for the call. 

Some of these items are enhancements and should just go on the list as possible new future drafts. 

We still need to follow up on interop items that should be addressed as errata. 

I have to confess, versioning is a big problem in the rest community. When an api is proprietary(ie specific) it does not matter much. Standard profiles of http like scim do have the issue of differentiating between protocol, schema, and implementation or product versioning. For scim, the path version reflects the protocol (ie 2) and schema versioning is in the schema uri. 

Implementers are free to specify an additional attribute in service provider config though we have not made this standard. I do not think this matters much since there no interop issues on product versions. 

Phil

> On Jun 30, 2016, at 7:55 AM, Shalini Gupta <[email-masked]> wrote:
> 
> There are other items as well which I also mentioned in the CIS Interop, that we should address in the SCIM spec:
> Adding scim version in ServiceProviderConfig
> Dealing with data transfer on deletes
> Crisply defining roles and entitlements
> Adding cardinality for multivalued attributes
> Issues around delete
> Handling license assignments
>

---

From: Phil Hunt <[email-masked]>
Date: Thu, 30 Jun 2016 10:46:51 -0700

Here is the information I have for today’s call:

External Organizer: Morteza Ansari
Organizer: Phil Idm Jd Hunt
----------------------

JOIN WEBEX MEETING
https://go.webex.com/go/j.php?MTID=m3841121f45ae983ce09f4869e8d70012
Meeting number: 345 510 827
Meeting password: scim

JOIN FROM A VIDEO CONFERENCING SYSTEM OR APPLICATION
Dial sip:[email-masked]

JOIN BY PHONE
1-877-668-4488 US Toll Free 
+1-415-655-0000 US Toll
Access code: 345 510 827

Global call-in numbers:
https://go.webex.com/go/globalcallin.php?serviceType=MC&ED=181760987&tollFree=1

Toll-free dialing restrictions: 
https://www.webex.com/pdf/tollfree_restrictions.pdf

Can't join the meeting? Contact support here:
https://go.webex.com/go/mc

Phil

@independentid

> On Jun 30, 2016, at 9:24 AM, Phil Hunt (IDM) <[email-masked]> wrote:
> 
> Morteza, Leif?
> 
> On Jun 30, 2016, at 7:55 AM, Shalini Gupta <[email-masked] <mailto:[email-masked]>> wrote:
> 
>> On Fri, Jun 17, 2016 at 7:24 PM, Ian Glazer <[email-masked] <mailto:[email-masked]>> wrote:
>> On Thu, Jun 16, 2016 at 4:28 PM, Phil Hunt <[email-masked] <mailto:[email-masked]>> wrote:
>>> On Jun 16, 2016, at 1:22 PM, Leif Johansson <[email-masked] <mailto:[email-masked]>> wrote:
>>> 
>>>> - https://drive.google.com/open?id=1MENZNkdhZdwTo-LvuDs6GNifaK85omitBDTFHvCO1pI <https://drive.google.com/open?id=1MENZNkdhZdwTo-LvuDs6GNifaK85omitBDTFHvCO1pI>
>>>> 
>>> [email-masked] <mailto:[email-masked]>
>>> https://www.ietf.org/mailman/listinfo/scim <https://www.ietf.org/mailman/listinfo/scim>
>> 
>> 
>> [email-masked] <mailto:[email-masked]>
>> https://www.ietf.org/mailman/listinfo/scim <https://www.ietf.org/mailman/listinfo/scim>
>> 
>> 
>> 
>> 
>> -- 
>> Ian Glazer
>> +1 202 255 3166 <tel:%2B1%20202%20255%203166>
>> [email-masked] <mailto:[email-masked]>
>> https://www.ietf.org/mailman/listinfo/scim <https://www.ietf.org/mailman/listinfo/scim>
>> 
>> 
>> 
>> 
>> -- 
>> Regards,
>> Shalini
>> [email-masked] <mailto:[email-masked]>
>> https://www.ietf.org/mailman/listinfo/scim <https://www.ietf.org/mailman/listinfo/scim>

---

From: Ian Glazer <[email-masked]>
Date: Thu, 30 Jun 2016 10:51:42 -0700

Unfortunately, I cannot make the call today. But I'd still like to keep
pushing forward with the results from the interop.

On Thu, Jun 30, 2016 at 10:46 AM, Phil Hunt <[email-masked]> wrote:

> I have to confess, versioning is a big problem in the rest community. When
> an api is proprietary(ie specific) it does not matter much. Standard
> profiles of http like scim do have the issue of differentiating between
> protocol, schema, and implementation or product versioning. For scim, the
> path version reflects the protocol (ie 2) and schema versioning is in the
> schema uri.
>
> Implementers are free to specify an additional attribute in service
> provider config though we have not made this standard. I do not think this
> matters much since there no interop issues on product versions.
>
> Phil
>

---

From: Phil Hunt <[email-masked]>
Date: Thu, 30 Jun 2016 11:12:01 -0700

I connected for the call. Unfortunately only one other arrival. We cancelled the call.

May I suggest we discuss an agenda and book a new timeslot well in advance of the next call?

In particular we should probably have a specific call on interop errata items from the CIS interop event.

For those wanting to propose new items to work on, it is probably fastest to just put out a separate email thread on the list for each item.  The more text (and even an individual draft) you can provide the better.  Note that we also have a new draft on polling from Microsoft and the ID-Event items we can discuss at another meeting.

Thanks everyone!

Phil

@independentid

> On Jun 30, 2016, at 10:51 AM, Ian Glazer <[email-masked]> wrote:
> 
> Unfortunately, I cannot make the call today. But I'd still like to keep pushing forward with the results from the interop.
> 
> On Thu, Jun 30, 2016 at 10:46 AM, Phil Hunt <[email-masked] <mailto:[email-masked]>> wrote:
> https://go.webex.com/go/j.php?MTID=m3841121f45ae983ce09f4869e8d70012 <https://go.webex.com/go/j.php?MTID=m3841121f45ae983ce09f4869e8d70012>
> Dial sip:[email-masked] <>
> 
> 
> JOIN BY PHONE
> 1-877-668-4488 <tel:1-877-668-4488> US Toll Free 
> +1-415-655-0000 <tel:%2B1-415-655-0000> US Toll
> Access code: 345 510 827
> 
> Global call-in numbers:
> https://go.webex.com/go/globalcallin.php?serviceType=MC&ED=181760987&tollFree=1 <https://go.webex.com/go/globalcallin.php?serviceType=MC&ED=181760987&tollFree=1>
> 
> https://www.webex.com/pdf/tollfree_restrictions.pdf <https://www.webex.com/pdf/tollfree_restrictions.pdf>
> 
> 
> 
> https://go.webex.com/go/mc <https://go.webex.com/go/mc>
> 
> Phil
> 
> @independentid
>> On Jun 30, 2016, at 9:24 AM, Phil Hunt (IDM) <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> Morteza, Leif?
>>