Subject: Re: [scim] Interop results

From: Kelly Grizzle <[email-masked]>
Date: Fri, 1 Jul 2016 16:55:22 +0000

Sorry that I missed.  Morteza, can we get a solid invite for the next meeting so that everyone can plan ahead to attend?

From: scim [mailto:[email-masked]] On Behalf Of Ian Glazer
Sent: Thursday, June 30, 2016 12:52 PM
To: Phil Hunt <[email-masked]>
Cc: Shalini Gupta <[email-masked]>; [email-masked] WG <[email-masked]>
Subject: Re: [scim] Interop results

Unfortunately, I cannot make the call today. But I'd still like to keep pushing forward with the results from the interop.

On Thu, Jun 30, 2016 at 10:46 AM, Phil Hunt <[email-masked]<mailto:[email-masked]>> wrote:
Here is the information I have for today’s call:

External Organizer: Morteza Ansari
Organizer: Phil Idm Jd Hunt
----------------------

JOIN WEBEX MEETING
https://go.webex.com/go/j.php?MTID=m3841121f45ae983ce09f4869e8d70012
Meeting number: 345 510 827
Meeting password: scim

JOIN FROM A VIDEO CONFERENCING SYSTEM OR APPLICATION
Dial sip:[email-masked]

JOIN BY PHONE
1-877-668-4488<tel:1-877-668-4488> US Toll Free
+1-415-655-0000<tel:%2B1-415-655-0000> US Toll
Access code: 345 510 827

Global call-in numbers:
https://go.webex.com/go/globalcallin.php?serviceType=MC&ED=181760987&tollFree=1

Toll-free dialing restrictions:
https://www.webex.com/pdf/tollfree_restrictions.pdf

Can't join the meeting? Contact support here:
https://go.webex.com/go/mc

Phil

@independentid
www.independentid.com<http://www.independentid.com>
[email-masked]<mailto:[email-masked]>

On Jun 30, 2016, at 9:24 AM, Phil Hunt (IDM) <[email-masked]<mailto:[email-masked]>> wrote:

Morteza, Leif?

I am available for the call.

Some of these items are enhancements and should just go on the list as possible new future drafts.

We still need to follow up on interop items that should be addressed as errata.

I have to confess, versioning is a big problem in the rest community. When an api is proprietary(ie specific) it does not matter much. Standard profiles of http like scim do have the issue of differentiating between protocol, schema, and implementation or product versioning. For scim, the path version reflects the protocol (ie 2) and schema versioning is in the schema uri.

Implementers are free to specify an additional attribute in service provider config though we have not made this standard. I do not think this matters much since there no interop issues on product versions.

Phil

On Jun 30, 2016, at 7:55 AM, Shalini Gupta <[email-masked]<mailto:[email-masked]>> wrote:
Sorry, could not join the last meeting as I was traveling back to India.
Are we meeting today? Can somebody please forward the invite..

There are other items as well which I also mentioned in the CIS Interop, that we should address in the SCIM spec:

  *   Adding scim version in ServiceProviderConfig
  *   Dealing with data transfer on deletes
  *   Crisply defining roles and entitlements
  *   Adding cardinality for multivalued attributes
  *   Issues around delete
  *   Handling license assignments

On Fri, Jun 17, 2016 at 7:24 PM, Ian Glazer <[email-masked]<mailto:[email-masked]>> wrote:
Sorry I missed the meeting yesterday; I do hope we can resend the meeting invite.

I think the squishy items include:
* PATCH implementation practices
* Appropriate response when GET'ing a resource but providing a filter which wouldn't return the resource

However, the more challenging areas that aren't covered by extensions such as Soft Delete are:
* Adding cardinality to Schema
* Enriching lifecycle state information more than just isActive
* Creating an MVP endpoint

On Thu, Jun 16, 2016 at 4:28 PM, Phil Hunt <[email-masked]<mailto:[email-masked]>> wrote:
I don’t think we need a bis draft. I believe we’re talking about some “squishy” points that require some errata clarification.

Some of these will also need to be reviewed in the context of: does the issue matter for interoperability?  Some “squishy” areas are intentional giving implementers freedom.

Phil

@independentid
www.independentid.com<http://www.independentid.com/>
[email-masked]<mailto:[email-masked]>

On Jun 16, 2016, at 1:22 PM, Leif Johansson <[email-masked]<mailto:[email-masked]>> wrote:

On 2016-06-06 18:19, Ian Glazer wrote:

All -

I have placed my interop results deck in the Results folder
- https://drive.google.com/open?id=1MENZNkdhZdwTo-LvuDs6GNifaK85omitBDTFHvCO1pI

But for those of you having problems with access, I have also attached it.

Great session this morning everyone. I look forward to tackling the
comments we got from everyone.

Is there enough meat here to put together an implementation report in
the sense of RFC 5657? I am also curious if there is enough energy
and implementation experience to turn out a "bis" draft, correcting
bugs and start the draft standard process?

Cheers Leif

_______________________________________________
scim mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/scim

_______________________________________________
scim mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/scim

--
Ian Glazer
Senior Director, Identity
+1 202 255 3166<tel:%2B1%20202%20255%203166>
@iglazer<https://twitter.com/iglazer>

_______________________________________________
scim mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/scim

--
Regards,
Shalini
_______________________________________________
scim mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/scim
_______________________________________________
scim mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/scim

--
Ian Glazer
Senior Director, Identity
+1 202 255 3166
@iglazer<https://twitter.com/iglazer>

---

From: Leif Johansson <[email-masked]>
Date: Fri, 1 Jul 2016 22:37:01 +0200

On 2016-07-01 18:55, Kelly Grizzle wrote:
> Sorry that I missed.  Morteza, can we get a solid invite for the next
> meeting so that everyone can plan ahead to attend?
> 
>  

Shouldn't we just talk about this in Berlin?

> 
>  
> 
> *From:*scim [mailto:[email-masked]] *On Behalf Of *Ian Glazer
> *Sent:* Thursday, June 30, 2016 12:52 PM
> *To:* Phil Hunt <[email-masked]>
> *Cc:* Shalini Gupta <[email-masked]>; [email-masked] WG
> <[email-masked]>
> *Subject:* Re: [scim] Interop results
> 
>  
> 
> Unfortunately, I cannot make the call today. But I'd still like to keep
> pushing forward with the results from the interop.
> 
>  
> 
>     1-877-668-4488 <tel:1-877-668-4488> US Toll Free 
> 
>     +1-415-655-0000 <tel:%2B1-415-655-0000> US Toll
> 
>     Access code: 345 510 827
> 
>      
> 
>     Global call-in numbers:
> 
>     www.independentid.com <http://www.independentid.com>
> 
>     [email-masked] <mailto:[email-masked]>
> 
>      
> 
>      
> 
>      
> 
>      
> 
>         On Jun 30, 2016, at 9:24 AM, Phil Hunt (IDM)
>         <[email-masked] <mailto:[email-masked]>> wrote:
> 
>          
> 
>         Morteza, Leif?
> 
>          
> 
>         I have to confess, versioning is a big problem in the rest
>         community. When an api is proprietary(ie specific) it does not
>         matter much. Standard profiles of http like scim do have the
>         issue of differentiating between protocol, schema, and
>         implementation or product versioning. For scim, the path version
>         reflects the protocol (ie 2) and schema versioning is in the
>         schema uri. 
> 
>          
> 
>         Implementers are free to specify an additional attribute in
>         service provider config though we have not made this standard. I
>         do not think this matters much since there no interop issues on
>         product versions. 
> 
>          
> 
>         Phil
> 
> 
>         On Jun 30, 2016, at 7:55 AM, Shalini Gupta
>         <[email-masked] <mailto:[email-masked]>> wrote:
> 
>             There are other items as well which I also mentioned in the
>             CIS Interop, that we should address in the SCIM spec:
> 
>             On Fri, Jun 17, 2016 at 7:24 PM, Ian Glazer
>             <[email-masked] <mailto:[email-masked]>> wrote:
> 
>                 * Appropriate response when GET'ing a resource but
>                 providing a filter which wouldn't return the resource
> 
>                  
> 
>                 On Thu, Jun 16, 2016 at 4:28 PM, Phil Hunt
>                 <[email-masked] <mailto:[email-masked]>> wrote:
> 
>                     I don’t think we need a bis draft. I believe we’re
>                     talking about some “squishy” points that require
>                     some errata clarification.
> 
>                      
> 
>                     Some of these will also need to be reviewed in the
>                     context of: does the issue matter for
>                     interoperability?  Some “squishy” areas are
>                     intentional giving implementers freedom.
> 
>                      
> 
>                     Phil
> 
>                      
> 
>                     @independentid
> 
>                     www.independentid.com <http://www.independentid.com/>
> 
>                     [email-masked] <mailto:[email-masked]>
> 
>                      
> 
>                      
> 
>                      
> 
>                      
> 
>                         On Jun 16, 2016, at 1:22 PM, Leif Johansson
>                         <[email-masked] <mailto:[email-masked]>> wrote:
> 
>                          
> 
>                             -
>                             https://drive.google.com/open?id=1MENZNkdhZdwTo-LvuDs6GNifaK85omitBDTFHvCO1pI
> 
>                         [email-masked] <mailto:[email-masked]>
>                     [email-masked] <mailto:[email-masked]>
>                 +1 202 255 3166 <tel:%2B1%20202%20255%203166>
> 
>                 @iglazer <https://twitter.com/iglazer>
> 
> 
>                 [email-masked] <mailto:[email-masked]>
>             [email-masked] <mailto:[email-masked]>
>         [email-masked] <mailto:[email-masked]>
> @iglazer <https://twitter.com/iglazer>
> 
> 
> 
> [email-masked]

---

From: "Phil Hunt (IDM)" <[email-masked]>
Date: Fri, 1 Jul 2016 15:18:16 -0700

Unfortunately, I think many won't make it to Berlin. Myself included. :-(

Phil

> On Jul 1, 2016, at 1:37 PM, Leif Johansson <[email-masked]> wrote:
>

---

From: Leif Johansson <[email-masked]>
Date: Sun, 3 Jul 2016 22:27:29 +0200

> Unfortunately, I think many won't make it to Berlin. Myself included. :-(

OK then we need a call.

Just to be clear: are we talking about going for proposed standard after
a bis-rev of the RFCs and an interop report chaser?

	Cheers Leif

---

From: "Phil Hunt (IDM)" <[email-masked]>
Date: Sun, 3 Jul 2016 16:08:01 -0700

I do not think the changes warrant a bis rev. We are just talking errata to clarify some squishy points and new drafts entirely for new functionality. 

Phil

> On Jul 3, 2016, at 1:27 PM, Leif Johansson <[email-masked]> wrote:
>