Subject: [scim] PATCH Response Status

From: Shelley <[email-masked]>
Date: Mon, 18 Jul 2016 10:45:04 -0500

The SCIM specification indicates that a server may return *either *a 200 or
204 for successful PATCH requests, but *must *return 200 for PATCH requests
with the "attributes" parameter [1,2].

Our team's SCIM service provider implementation is currently deciding which
status code is the most appropriate to return. A 200 would provide the most
complete representation available and would provide consistency regardless
of the absence/presence of the "attributes" parameter. However, one of the
most significant benefits of PATCH is the performance improvements. For
example, PATCH can prevent consumers from dealing with extremely large
group resources (in many cases, groups have thousands or even
tens-of-thousands of members); and likewise, the resources required on the
server to process and/or return such large requests is significant. A 204
response could therefore have significant performance benefits.

What do other SCIM service providers return for successful PATCH requests?
Also, do SCIM consumers/clients properly handle the possibility for either
a 200 or 204 to be returned per the spec?

[1]
http://www.simplecloud.info/specs/draft-scim-api-01.html#edit-resource-with-patch
[2] https://tools.ietf.org/html/rfc7644#section-3.5.2

---

From: Phil Hunt <[email-masked]>
Date: Mon, 18 Jul 2016 10:23:41 -0700

Because of the issue you mention I would expect a lot are returning code 204.  The client can force the full response by including the attributes parameter. Note: of course a service provider might still refuse under its own access rules.

Just as servers are required to be robust, we can expect that clients should expect some variation from the servers on the response code and the content of the response (the server isn’t obliged to accept data as stated 100%).

Phil

@independentid
www.independentid.com <http://www.independentid.com/>[email-masked] <mailto:[email-masked]>

> On Jul 18, 2016, at 8:45 AM, Shelley <[email-masked]> wrote:
> 
> The SCIM specification indicates that a server may return either a 200 or 204 for successful PATCH requests, but must return 200 for PATCH requests with the "attributes" parameter [1,2].
> 
> Our team's SCIM service provider implementation is currently deciding which status code is the most appropriate to return. A 200 would provide the most complete representation available and would provide consistency regardless of the absence/presence of the "attributes" parameter. However, one of the most significant benefits of PATCH is the performance improvements. For example, PATCH can prevent consumers from dealing with extremely large group resources (in many cases, groups have thousands or even tens-of-thousands of members); and likewise, the resources required on the server to process and/or return such large requests is significant. A 204 response could therefore have significant performance benefits.
> 
> What do other SCIM service providers return for successful PATCH requests? Also, do SCIM consumers/clients properly handle the possibility for either a 200 or 204 to be returned per the spec?
> 
> [1] http://www.simplecloud.info/specs/draft-scim-api-01.html#edit-resource-with-patch <http://www.simplecloud.info/specs/draft-scim-api-01.html#edit-resource-with-patch>
> [2] https://tools.ietf.org/html/rfc7644#section-3.5.2 <https://tools.ietf.org/html/rfc7644#section-3.5.2>
> _______________________________________________
> scim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/scim