Subject: [scim] Closing down the SCIM WG

From: Alexey Melnikov <[email-masked]>
Date: Mon, 18 Jul 2016 08:54:34 +0100

Hi,
As per earlier email from Leif, I am going to close the SCIM WG. The
mailing list will remain open.

If, in the future, people want to work on SCIM extensions or work on
-bis documents, creating a new WG would be an option.

Best Regards,
Alexey

---

From: Phil Hunt <[email-masked]>
Date: Mon, 18 Jul 2016 10:40:39 -0700

I think we need to talk about re-chartering if the group has re-gained interest since the recent interop at the Cloud Identity Summit in New Orleans.

A number of items people have requested:

* Refinements and errata based on the recent informal interop 
* Many requested enhancements (do people have strong desires?)
    - New resource types (e.g. organizations)
    - Polling (e.g. for replication)
    - Identity Events
    - Soft Delete
    - Account reset semantics
    - Extended meta-data (verfied, expired meta attributes) for complex attributes
    - OAuth Authorization Scope proposal (will be tabling soon)
    - several others

Regarding Identity Events (some work that may come back to the SCIM WG):
The identity events work may be re-organizing a bit.  There is informal consensus on the id-events mailing list to ask for AD sponsorship (has not been requested yet) of the current ID Event Token draft.  But a few do not want to talk about delivery or transmission - they want per-area custom REST spec for each of: SCIM, OAuth Token Revocation, OIDC Logout, and RISC (not to mention HEART and others).  If this happens SCIM needs a way to deliver messages that ensures:
* Delivery of multiple messages at a time
* Detection of lost events
* A recovery mechanism.
The proposal I’ve work with Craig McMurtry on is to combine the events distribution draft with his SCIM Polling draft to achieve this.  The problem?  Should this work be done under SCIM or under a new ID-Events working group?

As we learned with SCIM, the chief problem with RESTful services and interop is how to handle error conditions.  Aside:  Corner cases and error conditions are actually driving recent requests to revise the SCIM protocol to provide even more specific details. This is interesting feedback since at the time of publication, I’d received several comments that we went way too far overboard in specifying SCIM. The feedback now is that SCIM protocol is a bit under-defined. 

It is for this reason that pursuing separate REST protocols for each content area seems wasteful and costly to build as they will have to each develop a protocol spec in detail.

So to sum up, there appears to be a lot of requests. It is not clear how many are willing to put in the time.

Phil

@independentid
www.independentid.com <http://www.independentid.com/>[email-masked] <mailto:[email-masked]>

> On Jul 18, 2016, at 12:54 AM, Alexey Melnikov <[email-masked]> wrote:
> 
> Hi,
> _______________________________________________
> scim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/scim

---

From: Leif Johansson <[email-masked]>
Date: Mon, 18 Jul 2016 20:03:42 +0200

On 2016-07-18 19:40, Phil Hunt wrote:
> I think we need to talk about re-chartering if the group has re-gained
> interest since the recent interop at the Cloud Identity Summit in New
> Orleans.
> 

You won't get the ADs to recharter based on this unless you can show
activity around I-Ds.

So far we've been unable to show such activity.

If we crank out some drafts and a couple of "I have reviewed this
draft" emails we will probably find the ADs amenable to a SCIMext WG
and no time will be lost.

	Cheers Leif