Subject: Re: [scim] Does SCIM 2.0 have a compliance test suite?

From: Gayan Gunawardana <[email-masked]>
Date: Sat, 11 Mar 2017 11:10:06 +0530

On Tue, Feb 28, 2017 at 10:17 PM, Samuel Erdtman <[email-masked]> wrote:

> The SCIM 1.1 tests where made by me and Erik Wahlström.
>
> The code can be found here <https://github.com/erwah/scimproxy> and here
> <https://github.com/erdtman/simplecloud.info>
>
Thanks Samuel and Erik.
It would be great if you can provide brief idea about above two
repositories and how test suit has been organized.

>
>
> Don´t think you should rely to much on the structure setup there.
>
Yes but will be really helpful to just get an abstract idea.

>
> //Samuel
>
> On Tue, Feb 7, 2017 at 9:15 AM, Darshana Gunawardana <
> [email-masked]> wrote:
>
>> Hi Samuel,
>>
>> Thanks for the response..!
>>
>> My colleges from WSO2 are in the process of implementing SCIM 2.0 server
>> and currently people working on improving the test coverage on that.
>>
>> If there is no work done on this, we can check on creating common SCIM
>> 2.0 suite and contributing back to the community. Wanted to check whether
>> it would be useful to implement common SCIM 2.0 suite thing.
>>
>> If this is something useful to have, we can check on possible ways of
>> getting interested persons...
>>
>> And can I know references on the implementations on the test suite done
>> on SCIM 1.1? So I can get an idea on the current design and effort needed
>> to implement in that way.
>>
>> Thanks,
>> Darshana
>>
>> On Tue, Feb 7, 2017 at 1:06 PM, Samuel Erdtman <[email-masked]> wrote:
>>
>>> There is currently no such tool as far as I know.
>>>
>>> That it says ongoing is a bit too optimistic, there is no ongoing work
>>> as far as I know.
>>>
>>> You are not the only one asking for this so maybe a few persons could do
>>> some cooperation and create something.
>>>
>>>
>>> On Tue, 7 Feb 2017 at 07:37, Darshana Gunawardana <[email-masked]>
>>> wrote:
>>>
>>>> Hi,
>>>>
>>>> Is there a test tool that can used to check compliance with the SCIM
>>>> 2.0 specification?
>>>>
>>>> The site [1] specifies that there is an ongoing effort. Is this an open
>>>> source effort where someone interested can try prototype versions and
>>>> contribute for the development?
>>>>
>>>> [1] http://www.simplecloud.info/
>>>> [2] "Work on SCIM 2.0 tests is under development and there are
>>>> currently no support for the enterprise extension"
>>>>
>>>> Thanks,
>>>> --
>>>> With Regards,
>>>>
>>>> Darshana Gunawardana,
>>>> Alumni : Dept. of Computer Science & Engineering,
>>>> University of Moratuwa,
>>>> Sri Lanka
>>>> _______________________________________________
>>>> scim mailing list
>>>> [email-masked]
>>>> https://www.ietf.org/mailman/listinfo/scim
>>>>
>>>
>>
>>
>> --
>> With Regards,
>>
>> Darshana Gunawardana,
>> Alumni : Dept. of Computer Science & Engineering,
>> University of Moratuwa,
>> Sri Lanka
>>
>
>
> _______________________________________________
> scim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/scim
>
>

-- 
Gayan Gunawardana
Software Engineer; WSO2 Inc.; http://wso2.com/
Email: [email-masked]
Mobile: +94 (71) 8020933

---

From: Darshana Gunawardana <[email-masked]>
Date: Fri, 17 Mar 2017 00:19:30 +0530

Hi folks,

Thanks all for your responses.

On Wed, Mar 1, 2017 at 1:05 AM, Phil Hunt <[email-masked]> wrote:

> There has been discussion about having OpenID Foundation host some tests.
> However, so far, nobody has volunteered to write the tests or fund their
> support.  If we can generate interest, maybe we can make it happen.
>

A few of us at WSO2 thought about a suitable way to generate interest on
this.

WSO2 has been a mentor organization for GSoC for the last three years and
also accepted for the same on this year as well. So we have come up with a
GSoC project proposal on the topic "SCIM 2.0 compliance test suite". You
can find more details of the project proposal on the below link.

https://docs.wso2.com/display/GSoC/Project+Proposals+for+
2017#ProjectProposalsfor2017-Proposal21:[IS]SCIM2.0compliancetestsuite

Any suggestions on the project proposal are highly appreciated.

The good news is, we already have one interested applicant on this
project!!!

Hopefully we will have more applicants.. and a decent student proposal to
proceed with..

Thanks,
Darshana

>
> Note: The IETF does not seem to handle inter-op test suites and
> certifications.  At least not in my experience.
>
> Phil
>
> Oracle Corporation, Identity Cloud Services & Identity Standards
> @independentid
> www.independentid.com
> [email-masked]
>
>
>
>
>
>
>
> On Feb 7, 2017, at 12:15 AM, Darshana Gunawardana <[email-masked]>
> wrote:
>
> Hi Samuel,
>
> If there is no work done on this, we can check on creating common SCIM 2.0
> suite and contributing back to the community. Wanted to check whether it
> would be useful to implement common SCIM 2.0 suite thing.
>
> And can I know references on the implementations on the test suite done on
> SCIM 1.1? So I can get an idea on the current design and effort needed to
> implement in that way.
>
> Thanks,
> Darshana
>
>> That it says ongoing is a bit too optimistic, there is no ongoing work as
>> far as I know.
>>
>>> Is there a test tool that can used to check compliance with the SCIM 2.0
>>> specification?
>>>
>>> [2] "Work on SCIM 2.0 tests is under development and there are currently
>>> no support for the enterprise extension"
>>>
>>> Thanks,
>>> --
>>> With Regards,
>>>
>>> Darshana Gunawardana,

-- 
With Regards,

Darshana Gunawardana,