Subject: Re: [scim] Does SCIM 2.0 have a compliance test suite?

From: Darshana Gunawardana <[email-masked]>
Date: Tue, 12 Sep 2017 08:02:36 +0530

Hi all,

Giving you an update about on the topic.

We were able to get a GSoC project slot for the above proposal and the
elected student -Vindula who cc'ed here- was able to come up with a
promising implementation on the project.

   - GSoC Project URL:
   https://summerofcode.withgoogle.com/projects/#6261985816608768
   - VIndula's blog on the project:
   https://medium.com/@vindulajayawardana/scim-2-0-compliance-test-suite-737fd4ace3cc
   - Source Repo:
   https://github.com/wso2-incubator/scim2-compliance-test-suite
   - Hosted Demo: https://compliance-scim2.wso2apps.com/scimproxycompliance/

With the increasing adoption of the SCIM 2.0, this test suite will be a
strong initial step to validate interoperability, yet i'm sure there is
much room to improve. So,
> Try the hosted demo
> If you see have any suggestion to improve, open a git issue on the source
repo <https://github.com/wso2-incubator/scim2-compliance-test-suite>
> If you know the fix, send a PR..

Any kind of feedback would be highly appreciated.

Thanks,

On Fri, Mar 17, 2017 at 12:19 AM, Darshana Gunawardana <
[email-masked]> wrote:

> Hi folks,
>
> Thanks all for your responses.
>
> On Wed, Mar 1, 2017 at 1:05 AM, Phil Hunt <[email-masked]> wrote:
>
>> There has been discussion about having OpenID Foundation host some tests.
>> However, so far, nobody has volunteered to write the tests or fund their
>> support.  If we can generate interest, maybe we can make it happen.
>>
>
> A few of us at WSO2 thought about a suitable way to generate interest on
> this.
>
> WSO2 has been a mentor organization for GSoC for the last three years and
> also accepted for the same on this year as well. So we have come up with a
> GSoC project proposal on the topic "SCIM 2.0 compliance test suite". You
> can find more details of the project proposal on the below link.
>
> https://docs.wso2.com/display/GSoC/Project+Proposals+for+201
> 7#ProjectProposalsfor2017-Proposal21:[IS]SCIM2.0compliancetestsuite
>
> Any suggestions on the project proposal are highly appreciated.
>
> The good news is, we already have one interested applicant on this
> project!!!
>
> Hopefully we will have more applicants.. and a decent student proposal to
> proceed with..
>
> Thanks,
> Darshana
>
>
>>
>> Note: The IETF does not seem to handle inter-op test suites and
>> certifications.  At least not in my experience.
>>
>> Phil
>>
>> Oracle Corporation, Identity Cloud Services & Identity Standards
>> @independentid
>> www.independentid.com
>> [email-masked]
>>
>>
>>
>>
>>
>>
>>
>> On Feb 7, 2017, at 12:15 AM, Darshana Gunawardana <[email-masked]>
>> wrote:
>>
>> Hi Samuel,
>>
>> Thanks for the response..!
>>
>> My colleges from WSO2 are in the process of implementing SCIM 2.0 server
>> and currently people working on improving the test coverage on that.
>>
>> If there is no work done on this, we can check on creating common SCIM
>> 2.0 suite and contributing back to the community. Wanted to check whether
>> it would be useful to implement common SCIM 2.0 suite thing.
>>
>> If this is something useful to have, we can check on possible ways of
>> getting interested persons...
>>
>> And can I know references on the implementations on the test suite done
>> on SCIM 1.1? So I can get an idea on the current design and effort needed
>> to implement in that way.
>>
>> Thanks,
>> Darshana
>>
>> On Tue, Feb 7, 2017 at 1:06 PM, Samuel Erdtman <[email-masked]> wrote:
>>
>>> There is currently no such tool as far as I know.
>>>
>>> That it says ongoing is a bit too optimistic, there is no ongoing work
>>> as far as I know.
>>>
>>> You are not the only one asking for this so maybe a few persons could do
>>> some cooperation and create something.
>>>
>>>
>>> On Tue, 7 Feb 2017 at 07:37, Darshana Gunawardana <[email-masked]>
>>> wrote:
>>>
>>>> Hi,
>>>>
>>>> Is there a test tool that can used to check compliance with the SCIM
>>>> 2.0 specification?
>>>>
>>>> The site [1] specifies that there is an ongoing effort. Is this an open
>>>> source effort where someone interested can try prototype versions and
>>>> contribute for the development?
>>>>
>>>> [1] http://www.simplecloud.info/
>>>> [2] "Work on SCIM 2.0 tests is under development and there are
>>>> currently no support for the enterprise extension"
>>>>
>>>> Thanks,
>>>> --
>>>> With Regards,
>>>>
>>>> Darshana Gunawardana,
>>>> Alumni : Dept. of Computer Science & Engineering,
>>>> University of Moratuwa,
>>>> Sri Lanka
>>>> _______________________________________________
>>>> scim mailing list
>>>> [email-masked]
>>>> https://www.ietf.org/mailman/listinfo/scim
>>>>
>>>
>>
>>
>> --
>> With Regards,
>>
>> Darshana Gunawardana,
>> Alumni : Dept. of Computer Science & Engineering,
>> University of Moratuwa,
>> Sri Lanka
>> _______________________________________________
>> scim mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/scim
>>
>>
>>
>
>
> --
> With Regards,
>
> Darshana Gunawardana,
> Alumni : Dept. of Computer Science & Engineering,
> University of Moratuwa,
> Sri Lanka
>

-- 
With Regards,

Darshana Gunawardana,
Alumni : Dept. of Computer Science & Engineering,
University of Moratuwa,
Sri Lanka

---

From: Samuel Erdtman <[email-masked]>
Date: Mon, 18 Sep 2017 11:05:41 +0200

As the main updater of simplecloud.info I think this is an awesome
initiative.

I will try to find some time to look it through to see if your work could
easily be incorporated in simplecloud.info (it might take a few weeks
before I have managed to do this)

Cheers
//Samuel

On Tue, Sep 12, 2017 at 4:32 AM, Darshana Gunawardana <[email-masked]

>    - GSoC Project URL: https://summerofcode.withgoogle.com/projects/#
>    6261985816608768
>    - VIndula's blog on the project: https://medium.com/@
>    vindulajayawardana/scim-2-0-compliance-test-suite-737fd4ace3cc
>    <https://medium.com/@vindulajayawardana/scim-2-0-compliance-test-suite-737fd4ace3cc>
>    - Source Repo: https://github.com/wso2-incubator/scim2-compliance-
>    test-suite
>>> There has been discussion about having OpenID Foundation host some
>>> tests. However, so far, nobody has volunteered to write the tests or fund
>>> their support.  If we can generate interest, maybe we can make it happen.
>>>
>>
>>>> You are not the only one asking for this so maybe a few persons could
>>>> do some cooperation and create something.
>>>>
>>>>
>>>> On Tue, 7 Feb 2017 at 07:37, Darshana Gunawardana <
>>>>> The site [1] specifies that there is an ongoing effort. Is this an
>>>>> open source effort where someone interested can try prototype versions and

---

From: Samuel Erdtman <[email-masked]>
Date: Fri, 29 Sep 2017 10:56:15 +0200

Hi,

I have had an initial look at the project.

Correct me if I´m wrong but it is a copy of the simplecloud.info repo with
the compliance 2.0 added in parallel. a fork would have been even easier
but I think this could work too.

Have you tried to run the project in heroku? does all the dependencies etc.
work in that environment?

I tried to test the hosted demo but got a 404
https://compliance-scim2.wso2apps.com/scimproxycompliance/

The path forward that I would prefer would be to get an initial PR to
simplecloud.info repo (https://github.com/erdtman/simplecloud.info/) with
the added code (preferable not to master).

Not necessarily making it visible, I can do that once I have merged the PR.

Best regards
//Samuel