Subject: [scim] Is it possible to use primitive types with SCIM addresses claim?

From: Sathya Bandara <[email-masked]>
Date: Wed, 18 Apr 2018 18:38:41 +0530

Hi,

As per the SCIM core schema specification [1], addresses claim definition
is as follows.

addresses
>       A physical mailing address for this user.  Canonical type values
>       of "work", "home", and "other".  This attribute is a complex type
>       with the following sub-attributes.  All sub-attributes are
>       OPTIONAL.
>
> In a scenario where all the sub-attributes can be empty as per above
definition, can we use primitive attribute types (string values) as the
claim-values for this claim. E.g. -  *addresses: ["address1", "address2"]*

Would be grateful if you could clarify whether this is possible.

[1] https://tools.ietf.org/html/rfc7643#section-4.1.2

Best regards,
Sathya

-- 
Sathya Bandara
Software Engineer
WSO2 Inc. http://wso2.com
Mobile: (+94) 715 360 421 <+94%2071%20411%205032>

<+94%2071%20411%205032>

---

From: Kelly Grizzle <[email-masked]>
Date: Wed, 18 Apr 2018 13:47:38 +0000

This is likely to break other clients/servers that expect a multi-valued complex object.  I would suggest using a schema extension that has a list of primitives.  Another option would be to use the standard addresses field, but only include the “formatted” sub-attribute.

From: scim <[email-masked]> On Behalf Of Sathya Bandara
Sent: Wednesday, April 18, 2018 8:09 AM
To: [email-masked]
Subject: [scim] Is it possible to use primitive types with SCIM addresses claim?

Hi,
As per the SCIM core schema specification [1], addresses claim definition is as follows.

addresses

      OPTIONAL.
In a scenario where all the sub-attributes can be empty as per above definition, can we use primitive attribute types (string values) as the claim-values for this claim. E.g. -  addresses: ["address1", "address2"]
Would be grateful if you could clarify whether this is possible.

--
Sathya Bandara
Software Engineer
WSO2 Inc. http://wso2.com
Mobile: (+94) 715 360 421<tel:+94%2071%20411%205032>
[http://c.content.wso2.com/signatures/wso2-signature-general.png]

---

From: Sathya Bandara <[email-masked]>
Date: Wed, 18 Apr 2018 15:44:45 +0000

Hi Kelly,

Thanks for the quick response.
So if we allow primitive types as well, in addition to complex types for
the addresses claim from server side, would it violate the schema?

On Wed, Apr 18, 2018, 7:17 PM Kelly Grizzle <[email-masked]>
wrote:

> This is likely to break other clients/servers that expect a multi-valued
> complex object.  I would suggest using a schema extension that has a list
> of primitives.  Another option would be to use the standard addresses
> field, but only include the “formatted” sub-attribute.
>
>
>
>
>
> *From:* scim <[email-masked]> *On Behalf Of * Sathya Bandara
> *Sent:* Wednesday, April 18, 2018 8:09 AM
> *To:* [email-masked]
> *Subject:* [scim] Is it possible to use primitive types with SCIM
> addresses claim?
>
>
>
> Hi,
>

---

From: Phil Hunt <[email-masked]>
Date: Wed, 18 Apr 2018 09:36:17 -0700

Yes. The expectation is for some consistency in presentation across implementations.

So if you are mapping LDAP data, you have to parse the address value into the sub-attributes for addresses in SCIM.

Phil

Oracle Corporation, Identity Cloud Services Architect
@independentid
www.independentid.com <http://www.independentid.com/>[email-masked] <mailto:[email-masked]>

> On Apr 18, 2018, at 8:44 AM, Sathya Bandara <[email-masked]> wrote:
> 
> Hi Kelly,
> 
> So if we allow primitive types as well, in addition to complex types for the addresses claim from server side, would it violate the schema?
> 
> 
> On Wed, Apr 18, 2018, 7:17 PM Kelly Grizzle <[email-masked] <mailto:[email-masked]>> wrote:
> From: scim <[email-masked] <mailto:[email-masked]>> On Behalf Of Sathya Bandara
> To: [email-masked] <mailto:[email-masked]>
> In a scenario where all the sub-attributes can be empty as per above definition, can we use primitive attribute types (string values) as the claim-values for this claim. E..g. -  addresses: ["address1", "address2"]
> 
> [1] https://tools.ietf.org/html/rfc7643#section-4.1..2
>  <https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_rfc7643-23section-2D4.1.2&d=DwMFaQ&c=RoP1YumCXCgaWHvlZYR8PZh8Bv7qIrMUB65eapI_JnE&r=na5FVzBTWmanqWNy4DpctyXPpuYqPkAI1aLcLN4KZNA&m=BiPVo8BLSRchQq0X5X8fTO2Sc7XlO9d4vnvrMJ9immA&s=7e1irqMvgYOZIoQ9yOV21JO5A5HG_dDXUI-Udjpo5NI&e=>
> Best regards,
> 
> Sathya
> 
> 
> -- 
> 
> Sathya Bandara
> Software Engineer
> WSO2 Inc. http://wso2.com <https://urldefense.proofpoint.com/v2/url?u=http-3A__wso2.com&d=DwMFaQ&c=RoP1YumCXCgaWHvlZYR8PZh8Bv7qIrMUB65eapI_JnE&r=na5FVzBTWmanqWNy4DpctyXPpuYqPkAI1aLcLN4KZNA&m=BiPVo8BLSRchQq0X5X8fTO2Sc7XlO9d4vnvrMJ9immA&s=IFRilCcF6Ve_ZSRufegaA_-VJ9NtyRqavRA7ymgOQjo&e=>
> Mobile: (+94) 715 360 421 <tel:+94%2071%20411%205032>
> 
> 
> _______________________________________________
> scim mailing list
> [email-masked]
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_scim&d=DwICAg&c=RoP1YumCXCgaWHvlZYR8PZh8Bv7qIrMUB65eapI_JnE&r=na5FVzBTWmanqWNy4DpctyXPpuYqPkAI1aLcLN4KZNA&m=BiPVo8BLSRchQq0X5X8fTO2Sc7XlO9d4vnvrMJ9immA&s=MGbT_IyCqPu-X2yNNe4Oge4LN28CoFDhjAa2pKZvFAE&e= <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_scim&d=DwICAg&c=RoP1YumCXCgaWHvlZYR8PZh8Bv7qIrMUB65eapI_JnE&r=na5FVzBTWmanqWNy4DpctyXPpuYqPkAI1aLcLN4KZNA&m=BiPVo8BLSRchQq0X5X8fTO2Sc7XlO9d4vnvrMJ9immA&s=MGbT_IyCqPu-X2yNNe4Oge4LN28CoFDhjAa2pKZvFAE&e=>

---

From: Phil Hunt <[email-masked]>
Date: Wed, 18 Apr 2018 09:44:44 -0700

To clarify that was “yes” as in it would violate the schema.

Phil

> On Apr 18, 2018, at 9:36 AM, Phil Hunt <[email-masked]> wrote:
> 
> www.independentid.com <https://urldefense.proofpoint.com/v2/url?u=http-3A__www.independentid.com&d=DwMFaQ&c=RoP1YumCXCgaWHvlZYR8PZh8Bv7qIrMUB65eapI_JnE&r=na5FVzBTWmanqWNy4DpctyXPpuYqPkAI1aLcLN4KZNA&m=K6UEQCIxf3e1RlkBwJAmc0so58P9Li0dZnNgGTcSUQ4&s=rScN-d7CjGqHWE0iYfsWh8-NKNBq5Lrm4ooaVr3DQU4&e=>[email-masked] <mailto:[email-masked]>
> 
>> On Apr 18, 2018, at 8:44 AM, Sathya Bandara <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> Hi Kelly,
>> 
>> [email-masked] <mailto:[email-masked]>
>> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf..org_mailman_listinfo_scim&d=DwICAg&c=RoP1YumCXCgaWHvlZYR8PZh8Bv7qIrMUB65eapI_JnE&r=na5FVzBTWmanqWNy4DpctyXPpuYqPkAI1aLcLN4KZNA&m=BiPVo8BLSRchQq0X5X8fTO2Sc7XlO9d4vnvrMJ9immA&s=MGbT_IyCqPu-X2yNNe4Oge4LN28CoFDhjAa2pKZvFAE&e= <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_scim&d=DwICAg&c=RoP1YumCXCgaWHvlZYR8PZh8Bv7qIrMUB65eapI_JnE&r=na5FVzBTWmanqWNy4DpctyXPpuYqPkAI1aLcLN4KZNA&m=BiPVo8BLSRchQq0X5X8fTO2Sc7XlO9d4vnvrMJ9immA&s=MGbT_IyCqPu-X2yNNe4Oge4LN28CoFDhjAa2pKZvFAE&e=>
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_scim&d=DwICAg&c=RoP1YumCXCgaWHvlZYR8PZh8Bv7qIrMUB65eapI_JnE&r=na5FVzBTWmanqWNy4DpctyXPpuYqPkAI1aLcLN4KZNA&m=K6UEQCIxf3e1RlkBwJAmc0so58P9Li0dZnNgGTcSUQ4&s=P7pirz7KGVgCVDLb0ds_tElr0yrM921L8jtIVtrue8k&e=

---

From: Sathya Bandara <[email-masked]>
Date: Wed, 18 Apr 2018 17:24:42 +0000

Thank you Phil, for the clarification.

Best regards,
Sathya

On Wed, Apr 18, 2018, 10:14 PM Phil Hunt <[email-masked]> wrote:

> www.independentid.com
> [email-masked]
> So if you are mapping LDAP data, you have to parse the address value into
> the sub-attributes for addresses in SCIM.
>
> Phil
>
> www.independentid.com
> <https://urldefense.proofpoint.com/v2/url?u=http-3A__www.independentid.com&d=DwMFaQ&c=RoP1YumCXCgaWHvlZYR8PZh8Bv7qIrMUB65eapI_JnE&r=na5FVzBTWmanqWNy4DpctyXPpuYqPkAI1aLcLN4KZNA&m=K6UEQCIxf3e1RlkBwJAmc0so58P9Li0dZnNgGTcSUQ4&s=rScN-d7CjGqHWE0iYfsWh8-NKNBq5Lrm4ooaVr3DQU4&e=>
> [email-masked]
>
>> *From:* scim <[email-masked]> *On Behalf Of *Sathya Bandara
>> claim-values for this claim. E..g. -  *addresses: ["address1",
>> "address2"]*
>>
>> <https://urldefense.proofpoint.com/v2/url?u=http-3A__wso2.com&d=DwMFaQ&c=RoP1YumCXCgaWHvlZYR8PZh8Bv7qIrMUB65eapI_JnE&r=na5FVzBTWmanqWNy4DpctyXPpuYqPkAI1aLcLN4KZNA&m=BiPVo8BLSRchQq0X5X8fTO2Sc7XlO9d4vnvrMJ9immA&s=IFRilCcF6Ve_ZSRufegaA_-VJ9NtyRqavRA7ymgOQjo&e=>
>>
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf..org_mailman_listinfo_scim&d=DwICAg&c=RoP1YumCXCgaWHvlZYR8PZh8Bv7qIrMUB65eapI_JnE&r=na5FVzBTWmanqWNy4DpctyXPpuYqPkAI1aLcLN4KZNA&m=BiPVo8BLSRchQq0X5X8fTO2Sc7XlO9d4vnvrMJ9immA&s=MGbT_IyCqPu-X2yNNe4Oge4LN28CoFDhjAa2pKZvFAE&e=
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_scim&d=DwICAg&c=RoP1YumCXCgaWHvlZYR8PZh8Bv7qIrMUB65eapI_JnE&r=na5FVzBTWmanqWNy4DpctyXPpuYqPkAI1aLcLN4KZNA&m=BiPVo8BLSRchQq0X5X8fTO2Sc7XlO9d4vnvrMJ9immA&s=MGbT_IyCqPu-X2yNNe4Oge4LN28CoFDhjAa2pKZvFAE&e=>
>
>