Subject: [scim] Query parameter to include attributes in result that are not returned by default

From: Aleksey Chernoraenko <[email-masked]>
Date: Wed, 10 Apr 2019 11:38:08 -0500

Greetings,

"attributes" and "excludedAttributes" query parameters as described in
3.4.3. section of rfc7644 allow to support at least two scenarios

1) when requestor wants to exclude attributes that are returned by
default (e.g. expensive, or "not interested in" ones, etc)

2) when requestor wants to get a specific set of attributes and by
that overrides defaults

but it looks like another valuable scenario is missing:
3) when requestor wants to include attributes that are not returned by
default ("returned" schema attribute would be "request" for such
attributes) without discarding the defaults of other attributes.

Would introducing "includedAttributes" parameter be a good idea?
Any thoughts?

Thanks,
Alexei

---

From: Phil Hunt <[email-masked]>
Date: Wed, 10 Apr 2019 12:55:38 -0700

Aleksey,

As far as changing the protocol, the spec is published and cannot be altered (see IETF publication process) unless a new WG is chartered to begin working on new SCIM RFCs.

In practice, people specify a list of all the attributes they want which may include attributes not normally returned by default. 

Also, this certainly something a client tool could do to make the user experience better. However, in the protocol, the client would have to list all the attributes wanted to get what you want.

Regards,

Phil Hunt 

> On Apr 10, 2019, at 9:38 AM, Aleksey Chernoraenko <[email-masked]> wrote:
> 
> Greetings,
> 
> _______________________________________________
> scim mailing list
> [email-masked]
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_scim&d=DwICAg&c=RoP1YumCXCgaWHvlZYR8PZh8Bv7qIrMUB65eapI_JnE&r=na5FVzBTWmanqWNy4DpctyXPpuYqPkAI1aLcLN4KZNA&m=fqza63xS12PGFgfuW40qHtTxmp6SJbP0J638fkUMCZg&s=EhCjhUQmDOX1KUIULcX-RWc4Fr0RuvZm015XdO6e1fc&e=