Subject: [scim] Filter evaluation for multi-valued complex attributes

From: Aleksey Chernoraenko <[email-masked]>
Date: Fri, 19 Apr 2019 10:03:45 -0500

Greetings,

Could you please clarify filter evaluation for multi-valued complex attributes?

"Filtering" section (3.4.2.2.) in rfc7644 demonstrates the following
example for "emails" (which is I assume is multi-valued complex
attribute):

1) filter=userType ne "Employee" and not (emails co "example.com" or
emails.value co "example.org")

2) filter=userType eq "Employee" and (emails.type eq "work")

Is it correct that the following expressions are valid, equal, and
should be evaluated to the same result:

a) emails[value co "example.com"]
b) emails.value co "example.com"
c) emails co "example.com"

b) and c) options are basically shortcuts for a) ?
c) is valid because "value" is a default attribute for "email" ?

Thanks,
Alexei

---

From: Phil Hunt <[email-masked]>
Date: Fri, 19 Apr 2019 16:41:43 -0700

Yes, they are the same for a simple filter against one sub attribute. 

The square brackets make sure the filter terms are applied against the same value record of the CMVA.  Eg [type eq “work” and value co “example”] processes differently than (emails.type eq “work” and emails.value co “example”).

Phil

> On Apr 19, 2019, at 8:03 AM, Aleksey Chernoraenko <[email-masked]> wrote:
> 
> Greetings,
> 
> _______________________________________________
> scim mailing list
> [email-masked]
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_scim&d=DwICAg&c=RoP1YumCXCgaWHvlZYR8PZh8Bv7qIrMUB65eapI_JnE&r=na5FVzBTWmanqWNy4DpctyXPpuYqPkAI1aLcLN4KZNA&m=vTNKWgajF8MWgt4tfGeeCs7VAdsruY5hM9-7IIV-vDI&s=z8UV9HeKJNemdy6_GzHO7foXe70cvn6GczzA0C9RM4c&e=