Subject: [scim] SCIM Soft Delete

From: Shelley <[email-masked]>
Date: Tue, 14 Jan 2020 09:10:38 -0600

What is the status of the SCIM Soft Delete extension draft?

https://datatracker.ietf.org/doc/draft-ansari-scim-soft-delete/

Are there any plans to resurrect and finalize this extension?

---

From: Phil Hunt <[email-masked]>
Date: Tue, 14 Jan 2020 07:39:39 -0800

I believe there are at least 3 ID drafts proposals for different extensions. 

There would have to be enough interest expressed to re-charter the WG to meet again or get an area director sponsorship. 

Phil

> On Jan 14, 2020, at 7:10 AM, Shelley <[email-masked]> wrote:
> 
> _______________________________________________
> scim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/scim

---

From: Phil Hunt <[email-masked]>
Date: Tue, 14 Jan 2020 07:39:39 -0800

Phil

---

From: Matt Domsch <[email-masked]>
Date: Tue, 14 Jan 2020 16:55:49 +0000

I’m aware of at least these work items that together would warrant rechartering the SCIM WG:

•  draft-hunt-scim-mv-paging-00 - SCIM Protocol: Multi-Value Paging Extension<https://datatracker.ietf.org/doc/draft-hunt-scim-mv-paging/>
•  draft-wahl-scim-profile-00 - SCIM Profile for Provisioning Users Into Relying Party Applications<https://tools.ietf.org/html/draft-wahl-scim-profile-00>
• draft-grizzle-scim-pam-ext-01 - SCIM Extension for Privileged Access Management<https://datatracker.ietf.org/doc/draft-grizzle-scim-pam-ext/> and spec GitHub - kelly-grizzle-sp/scim-pam: A System for Cross-Domain Identity Management (SCIM) extension that supports Privile…<https://github.com/kelly-grizzle-sp/scim-pam> (Kelly Grizzle<https://harbor.sailpoint.com/people/kelly.grizzle>).
• draft-ansari-scim-soft-delete-00 - SCIM Soft Delete<https://datatracker.ietf.org/doc/draft-ansari-scim-soft-delete/>
•  SCIM HR User Schema (No ID yet). This would be an additional schema, done as an extension much as Enterprise User Schema is an extension. Expected participants are SailPoint, ADP, and we will want to recruit Workday and other HR systems-of-record to join the effort.

I’d support and gladly be involved in the rechartering effort.

Thanks,
Matt

Matt Domsch
VP, Lead Corporate Architect
[email-masked]<mailto:[email-masked]>
mobile: 512-981-6486
www.sailpoint.com<http://www.sailpoint.com/>

---

From: "Matt Peterson (mpeterso)" <[email-masked]>
Date: Tue, 14 Jan 2020 17:50:16 +0000

And this one:

https://tools.ietf.org/html/draft-peterson-scim-cursor-pagination-00

--
Matt Peterson
Distinguished Engineer
One Identity, Inc.

From: scim <[email-masked]> On Behalf Of Matt Domsch
Sent: Tuesday, January 14, 2020 9:56 AM
To: Phil Hunt <phil.hunt=[email-masked]>; Shelley <[email-masked]>
Cc: [email-masked]
Subject: Re: [scim] SCIM Soft Delete

CAUTION: This email originated from outside of the organization. Do not follow guidance, click links, or open attachments unless you recognize the sender and know the content is safe.

•  draft-hunt-scim-mv-paging-00 - SCIM Protocol: Multi-Value Paging Extension<https://nam05.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-hunt-scim-mv-paging%2F&data=02%7C01%7Cmatt.peterson%40oneidentity.com%7Cb008dff8472147062d4e08d79912a417%7C91c369b51c9e439c989c1867ec606603%7C0%7C1%7C637146177671253905&sdata=eb0Rtwue8w%2F3ZBZv4182VGdYO5Qxv9j2NebV%2BEhy1JI%3D&reserved=0>
•  draft-wahl-scim-profile-00 - SCIM Profile for Provisioning Users Into Relying Party Applications<https://nam05.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-wahl-scim-profile-00&data=02%7C01%7Cmatt.peterson%40oneidentity.com%7Cb008dff8472147062d4e08d79912a417%7C91c369b51c9e439c989c1867ec606603%7C0%7C1%7C637146177671263898&sdata=11Pt%2BiEFkAlBrfAD7QEq0pAfw0QLjZhrvBqiQ6tYb9Q%3D&reserved=0>
• draft-grizzle-scim-pam-ext-01 - SCIM Extension for Privileged Access Management<https://nam05.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-grizzle-scim-pam-ext%2F&data=02%7C01%7Cmatt.peterson%40oneidentity.com%7Cb008dff8472147062d4e08d79912a417%7C91c369b51c9e439c989c1867ec606603%7C0%7C1%7C637146177671268899&sdata=6quqc27P%2BXHf%2BHdJxKEU7zBC6aNuDK6%2Fept6EDDNzvY%3D&reserved=0> and spec GitHub - kelly-grizzle-sp/scim-pam: A System for Cross-Domain Identity Management (SCIM) extension that supports Privile…<https://nam05.safelinks.protection.outlook.com/?url=https%3A%2F%2Fgithub.com%2Fkelly-grizzle-sp%2Fscim-pam&data=02%7C01%7Cmatt.peterson%40oneidentity.com%7Cb008dff8472147062d4e08d79912a417%7C91c369b51c9e439c989c1867ec606603%7C0%7C1%7C637146177671273897&sdata=QnvmWZ0Xv5PHNLakcBmhegK5Agqp5Xfpy3cWNVn5beM%3D&reserved=0> (Kelly Grizzle<https://nam05.safelinks.protection.outlook.com/?url=https%3A%2F%2Fharbor.sailpoint.com%2Fpeople%2Fkelly.grizzle&data=02%7C01%7Cmatt.peterson%40oneidentity.com%7Cb008dff8472147062d4e08d79912a417%7C91c369b51c9e439c989c1867ec606603%7C0%7C1%7C637146177671283893&sdata=%2FzT6pWNUvkFzG0Zt3iUAKZ4ChopotkhAaTH45174AII%3D&reserved=0>).
• draft-ansari-scim-soft-delete-00 - SCIM Soft Delete<https://nam05.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ansari-scim-soft-delete%2F&data=02%7C01%7Cmatt.peterson%40oneidentity.com%7Cb008dff8472147062d4e08d79912a417%7C91c369b51c9e439c989c1867ec606603%7C0%7C1%7C637146177671288891&sdata=KXjl00SyntwSrYcjHbCWlJrcx1AsFRx7Fkc1Op4yenM%3D&reserved=0>
•  SCIM HR User Schema (No ID yet). This would be an additional schema, done as an extension much as Enterprise User Schema is an extension. Expected participants are SailPoint, ADP, and we will want to recruit Workday and other HR systems-of-record to join the effort.

Thanks,
Matt

Matt Domsch
VP, Lead Corporate Architect
[email-masked]<mailto:[email-masked]>
mobile: 512-981-6486
www.sailpoint.com<https://nam05.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.sailpoint.com%2F&data=02%7C01%7Cmatt.peterson%40oneidentity.com%7Cb008dff8472147062d4e08d79912a417%7C91c369b51c9e439c989c1867ec606603%7C0%7C1%7C637146177671293888&sdata=RTJ1KXrIzem%2BeiiNvLDTjdSmuxUGnVdA7tkm3hClkmk%3D&reserved=0>

---

From: "Morteza Ansari (moransar)" <[email-masked]>
Date: Tue, 14 Jan 2020 23:04:34 +0000

I tried to get that work started a few times (between IETF and some discussions at IIW over the years) but never managed to get enough interest to pursue it. As far as I know there were never an alternate proposal or even broad agreement this is a problem worth solving. I still think that’s relevant work and worth pursuing as long as we have multiple interested parties.

Cheers,
Morteza

From: scim <[email-masked]> on behalf of Shelley <[email-masked]>
Date: Tuesday, January 14, 2020 at 7:12 AM
To: "[email-masked]" <[email-masked]>
Subject: [scim] SCIM Soft Delete