Subject: [sipcore] Do we really want to reopen the RAI re-org discussion? (was Re: Call for Consensus: Additional Working Group Items)

From: Adam Roach <[email-masked]>
Date: Thu, 16 Apr 2009 18:08:59 -0500

[as chair]

That's a completely different topic. I can't stop you from re-opening 
the discussion of how to handle SIP and SIPPING milestones that would 
otherwise be orphaned, but I will ask you to take it elsewhere. The 
place you would go to re-open the RAI re-org discussion is the RAI 
mailing list. I suspect many interested parties would view re-opening 
that particular topic to be unnecessarily disruptive.

/a

Eric Burger wrote:
> And Hadriel is saying they are not Core.
>
> On Apr 17, 2009, at 6:39 AM, Adam Roach wrote:
>
>> [as chair]
>>
>> Hadriel Kaplan wrote:
>>>> At 01:26 PM 4/16/2009, Adam Roach wrote:
>>>> Delivering request-URI and parameters to UAS via proxy    (PS)
>>>>    draft-rosenberg-sip-target-uri-delivery
>>>>    [adopted by SIP WG consensus after IETF 73, still waiting for new
>>>> version]
>>>>
>>>> SIP Events throttling mechanism    (PS)
>>>>    draft-niemi-sipping-event-throttle
>>>>    [SIPPING WG indicated desire to adopt in as SIP WG item at IETF 74] 
>>> My vote is to adopt neither in this WG.  Neither of them update nor 
>>> replace 3261-3265. 
>>
>> To be clear, the question we are asking is not "are these milestones 
>> okay" (that discussion has already concluded on the RAI list) -- it 
>> is "should we take on these specific documents to satisfy the these 
>> two milestones that are already part of the SIPCORE charter."
>>
>> /a
>> _______________________________________________
>> sipcore mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/sipcore

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Fri, 17 Apr 2009 01:29:06 +0200

Except that the milestones themselves were a decision of the ADs and did not get list discussion. In fact milestones were being added and deleted from the charters even on Monday evening (my time). The charters themselves were part of the RAI reorg discussions, but the milestones were not. So I do not see how a discussion of them can be a reopening. 

You can issue a direction about whether the appropriate place to discuss the SIPCORE milestones that they have been allocated is the the SIPCORE or RAI list, but it does not reopen a discussion.

I must admit I am a bit bemused by the allocation of the throttling one, because I do remember having a discussion some time back where I asked, if for some reason we were reissuing RFC 3265 would the throttling form part of it, and I was assured in no uncertain terms that it was a totally separate and independent extension. Now if the answer to that had been YES rather than NO, I could understand it being allocated to SIPCORE.

The target-uri one I do understand, because basically if RFC 3261 was ever reisssued, there is a strong view that History-Info would form part of that reissue. In my view target-uri is part of that scope. However more on that in a separate mail.

Keith

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Adam Roach
> Sent: Friday, April 17, 2009 12:09 AM
> To: Eric Burger
> Cc: SIPCORE; Hadriel Kaplan
> Subject: [sipcore] Do we really want to reopen the RAI re-org 
> discussion? (was Re: Call for Consensus: Additional Working 
> Group Items)
> 
> [as chair]
> 
> That's a completely different topic. I can't stop you from 
> re-opening the discussion of how to handle SIP and SIPPING 
> milestones that would otherwise be orphaned, but I will ask 
> you to take it elsewhere. The place you would go to re-open 
> the RAI re-org discussion is the RAI mailing list. I suspect 
> many interested parties would view re-opening that particular 
> topic to be unnecessarily disruptive.
> 
> /a
> 
> Eric Burger wrote:
> >>>>    [adopted by SIP WG consensus after IETF 73, still waiting for 
> >>>> new version]
> >>>>
> >>>>    [SIPPING WG indicated desire to adopt in as SIP WG 
> item at IETF 
> >>>> 74]

---

From: Adam Roach <[email-masked]>
Date: Thu, 16 Apr 2009 18:51:31 -0500

Keith:

I am referring to the following text, which appears in the proposed 
SIPCORE charter at least as early as February:

>   Although in general the WG will not work on extensions to SIP, it
>   may take on some previous work items from the SIP working group
>   to allow for a smooth transition. 

/a

DRAGE, Keith (Keith) wrote:
>>>>> My vote is to adopt neither in this WG.  Neither of them
>>>>>            
>> update nor
>>      
>>>>> replace 3261-3265.
>>>>>            
>>>> To be clear, the question we are asking is not "are these
>>>>          
>> milestones
>>      
>>>> okay" (that discussion has already concluded on the RAI
>>>>          
>> list) -- it
>>      
>>>> is "should we take on these specific documents to satisfy
>>>>          
>> the these
>>

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Fri, 17 Apr 2009 02:30:54 +0200

Said extract obviously does not apply to

http://tools.ietf.org/html/draft-niemi-sipping-event-throttle-08

Not that I am objecting, but the rationale does have a dirty great hole in it.

Its status from IETF 74 is that SIP and SIPPING in session 3 (where formally we were SIPPING) agreed to move forward on the document, but obviously were not empowered to make any decisions as to where it ended up. I vaguely remember previous offline discussions (from about 12 months ago) which said that if it went forward it would stay in SIPPING.

As I said, I could understand it landing in SIPCORE if it updated RFC 3265, but I had that discussion and was roundly beaten into submission.

Keith 

> From: Adam Roach [mailto:[email-masked]] 
> Sent: Friday, April 17, 2009 12:52 AM
> To: DRAGE, Keith (Keith)
> Cc: Eric Burger; SIPCORE; Hadriel Kaplan
> Subject: Re: [sipcore] Do we really want to reopen the RAI 
> re-org discussion? (was Re: Call for Consensus: Additional 
> Working Group Items)
> 
> Keith:
> 
> I am referring to the following text, which appears in the 
> proposed SIPCORE charter at least as early as February:
> 
> > Except that the milestones themselves were a decision of 
> the ADs and did not get list discussion. In fact milestones 
> were being added and deleted from the charters even on Monday 
> evening (my time). The charters themselves were part of the 
> RAI reorg discussions, but the milestones were not. So I do 
> not see how a discussion of them can be a reopening.
> >
> > You can issue a direction about whether the appropriate 
> place to discuss the SIPCORE milestones that they have been 
> allocated is the the SIPCORE or RAI list, but it does not 
> reopen a discussion.
> >
> > I must admit I am a bit bemused by the allocation of the 
> throttling one, because I do remember having a discussion 
> some time back where I asked, if for some reason we were 
> reissuing RFC 3265 would the throttling form part of it, and 
> I was assured in no uncertain terms that it was a totally 
> separate and independent extension. Now if the answer to that 
> had been YES rather than NO, I could understand it being 
> allocated to SIPCORE.
> >
> > The target-uri one I do understand, because basically if 
> RFC 3261 was ever reisssued, there is a strong view that 
> History-Info would form part of that reissue. In my view 
> target-uri is part of that scope. However more on that in a 
> separate mail.
> >
> > Keith
> >
> >
> >
> >
> >
> >    
> >> discussion? (was Re: Call for Consensus: Additional Working Group 
> >> Items)
> >>
> >> [as chair]
> >>
> re-opening