Subject: [sipcore] draft-barnes-sipcore-rfc4244bis hi-target backward compatibility

From: <[email-masked]>
Date: Wed, 17 Jun 2009 08:19:17 +0200

Dear all,
I saw that the hi-target is a mandatory parameter now.
How a can now assure backward compatibility to the "old" History header. Due to the fact that the old one is already implemented within some networks?

BR,

Roland

Deutsche Telekom Netzproduktion GmbH 
Zentrum Technik Einführung 
Roland Jesske 
Gateways, Protokolle, Konvergenz, TE32-1
Heinrich-Hertz-Str. 3-7, 64295 Darmstadt, 
Postfach, 64307 Darmstadt (Postanschrift) 
+496151 628 2766 (Tel)
+491718618445 (Mobile) 
E-Mail: [email-masked] 
http://www.telekom.de <http://www.telekom.de/>  

Registerrechtliche Unternehmensangaben: 
Deutsche Telekom Netzproduktion GmbH 
Aufsichtsrat: Timotheus Höttges (Vorsitzender) 
Geschäftsführung: Friedrich Fuß (Vorsitzender), Albert Matheis, Klaus Peren 
Handelsregister: Amtsgericht Bonn HRB 14190 
Sitz der Gesellschaft: Bonn 
USt-IdNr.: DE 814645262

---

From: "Christer Holmberg" <[email-masked]>
Date: Wed, 17 Jun 2009 09:12:16 +0200

Hi Roland,
 
I think the meaning is that new, 4244bis compliant entities, would insert hi-target. But, I agree with you that things must be backward compatible, so a missing parameter must not be seen as an error.
 
Regards,
 
Christer

________________________________

	From: [email-masked] [mailto:[email-masked]] 
	Sent: 17. kesäkuuta 2009 9:19
	To: [email-masked]; Christer Holmberg; [email-masked]; [email-masked]; [email-masked]
	Cc: [email-masked]
	Subject: [sipcore] draft-barnes-sipcore-rfc4244bis hi-target backward compatibility

	Dear all, 

	BR, 
	
	Roland 

	E-Mail: [email-masked] <mailto:[email-masked]>

---

From: "Francois Audet" <[email-masked]>
Date: Wed, 17 Jun 2009 10:50:21 -0500

All the HI entries will be marked in the new mechanism.
 
The old ones won't.
 
So entities that inspect them will be able to distinguish between them.

	From: [email-masked] [mailto:[email-masked]] 
	Sent: Tuesday, June 16, 2009 23:19
	To: Audet, Francois (SC100:3055); [email-masked]; [email-masked]; Barnes, Mary (RICH2:AR00); [email-masked]
	Cc: [email-masked]
	Subject: [sipcore] draft-barnes-sipcore-rfc4244bis hi-target backward compatibility

	Dear all, 

	BR, 
	
	Roland

---

From: "Francois Audet" <[email-masked]>
Date: Wed, 17 Jun 2009 10:51:26 -0500

Correct. 
 
I think we should add a section on backward compatibility.

	From: Christer Holmberg [mailto:[email-masked]] 
	Sent: Wednesday, June 17, 2009 00:12
	To: [email-masked]; Audet, Francois (SC100:3055); [email-masked]; Barnes, Mary (RICH2:AR00); [email-masked]
	Cc: [email-masked]
	Subject: RE: [sipcore] draft-barnes-sipcore-rfc4244bis hi-target backward compatibility

	Hi Roland,

	Regards,
	 
	Christer

		Dear all, 

		BR, 
		
		Roland

---

From: "Mary Barnes" <[email-masked]>
Date: Wed, 17 Jun 2009 10:59:20 -0500

Yes, we already need to add a section on the differences between 4244 and 4244bis, so we can include this as part of that section. 
 
Mary.

From: Audet, Francois (SC100:3055) 
Sent: Wednesday, June 17, 2009 10:51 AM
To: Christer Holmberg; [email-masked]; [email-masked]; Barnes, Mary (RICH2:AR00); [email-masked]
Cc: [email-masked]
Subject: RE: [sipcore] draft-barnes-sipcore-rfc4244bis hi-target backward compatibility

Correct. 

	Hi Roland,

	Regards,
	 
	Christer

		Dear all, 

		BR, 
		
		Roland