Subject: [sipcore] Milestone to revise RFC 3265

From: Gonzalo Camarillo <[email-masked]>
Date: Fri, 12 Jun 2009 13:02:58 +0300

Folks,

since the publication of RFC 3265, we have gotten significant experience 
deploying SIP-based notification systems. It has been proposed to revise 
RFC 3265 based on that experience. We have two questions for the WG:

1) should we add a milestone to our charter to revise RFC 3265?

2) if we add such a milestone, should we take the following draft as the 
initial WG item for the milestone?

http://tools.ietf.org/html/draft-roach-sipcore-rfc3265bis-00

Thanks,

Gonzalo
SIPCORE co-chair

---

From: Victor Pascual Ávila <[email-masked]>
Date: Fri, 12 Jun 2009 13:22:42 +0200

> 1) should we add a milestone to our charter to revise RFC 3265?

Yes

> http://tools.ietf.org/html/draft-roach-sipcore-rfc3265bis-00

Yes

Cheers,
-- 
Victor Pascual Ávila

---

From: Byron Campen <[email-masked]>
Date: Fri, 12 Jun 2009 08:56:09 -0500

Yes.

Best regards,
Byron Campen

> Folks,
>
> since the publication of RFC 3265, we have gotten significant  
> experience deploying SIP-based notification systems. It has been  
> proposed to revise RFC 3265 based on that experience. We have two  
> questions for the WG:
>
> 2) if we add such a milestone, should we take the following draft as  
> the initial WG item for the milestone?
>
> _______________________________________________
> sipcore mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sipcore

---

From: Paul Kyzivat <[email-masked]>
Date: Fri, 12 Jun 2009 10:28:43 -0400

Yes

---

From: Ben Campbell <[email-masked]>
Date: Fri, 12 Jun 2009 10:33:58 -0500

On Jun 12, 2009, at 5:02 AM, Gonzalo Camarillo wrote:

[...]

> 1) should we add a milestone to our charter to revise RFC 3265?

yes

> http://tools.ietf.org/html/draft-roach-sipcore-rfc3265bis-00

yes

[...]

Thanks!

Ben.

---

From: "Dale Worley" <[email-masked]>
Date: Fri, 12 Jun 2009 11:35:12 -0400

Yes.

Yes.

Dale

---

From: Dean Willis <[email-masked]>
Date: Sat, 13 Jun 2009 13:48:23 -0500

> http://tools.ietf.org/html/draft-roach-sipcore-rfc3265bis-00

I believe that RFC 3265 should be revised, and that SIPCORE is the right
place to do it. Of course, I feel the same about 3261, 3262, 3263...

Adam's draft seems like a very good start.

--
Dean

---

From: Theo Zourzouvillys <[email-masked]>
Date: Sun, 14 Jun 2009 02:11:59 +0100

>> initial WG item for the milestone?

yes, and yes.

> place to do it. Of course, I feel the same about 3261, 3262, 3263...

and i do, too.

 ~ Theo

Sent from Albany, New York, United States

---

From: "Elwell, John" <[email-masked]>
Date: Wed, 17 Jun 2009 11:13:32 +0100

Yes to both.

John 

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Gonzalo Camarillo
> Sent: 12 June 2009 11:03
> To: SIPCORE
> Subject: [sipcore] Milestone to revise RFC 3265
> 
> Folks,
> 
> experience

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Fri, 19 Jun 2009 18:37:37 +0200

At the moment I have to answer NO to this consensus call for two reasons:

1)	Nothing in the proposal addresses the issue of why we are revising the RFC. Annex C of the initial draft contains a list of bugfixes that are addressed in the -00 version, but nothing in the request indicates whether that is the sole purpose of this revision, or whether other substantial changes, and more specifically enhancements can suddenly land on the WGs work programme once the work is adopted. So I would like to see statements that indicate the revision is to address issue problems with the existing RFC within the existing scope of operation, and if there are any enhancements intended then these are listed now and we obtain consensus on them.

2)	Nothing in the proposal addresses compatibility with the existing RFC. Dean is saying yes because he wants SIP 3.0. That is by definition incompatible with SIP 2.0 (the compatibility mechanism in this case is that if a response fails to appear for a 3.0 request the sender has to drop back to 2.0 operation). I am certainly not prepared to endorse a revision at this stage to produce a SIP 3.0 version of RFC 3265, and moreover, I require that where possible, the changes made are made in a fashion that maintains compatibility with implementations to the existing RFC 3265 (barring stuff that is completely broken of course).

I would note that I do not have a problem with a revision addressing issues currently listed in Annex C, so if we can revise the call to address my two point, I will be able to revise my answer to yes.

regards

Keith

> [mailto:[email-masked]] On Behalf Of Dean Willis
> Sent: Saturday, June 13, 2009 7:48 PM
> To: Gonzalo Camarillo
> Cc: SIPCORE
> Subject: Re: [sipcore] Milestone to revise RFC 3265
> 
> Gonzalo Camarillo wrote:
> > Folks,
> > 
> > proposed to revise RFC 3265 based on that experience. We 
> have two questions for the WG:
> > 
> I believe that RFC 3265 should be revised, and that SIPCORE 
> is the right place to do it. Of course, I feel the same about 
> 3261, 3262, 3263...
>

---

From: Gonzalo Camarillo <[email-masked]>
Date: Tue, 23 Jun 2009 10:33:19 +0300

Hi,

based on all the responses received, there is agreement that the WG 
should work on revising RFC 3265 and that this draft is a good starting 
point for that. Therefore, I will ask our ADs to add a milestone to 
revise RFC 3265 and the author of the draft to submit it as a SIPCORE WG 
item.

Keith brought up two good questions about the scope of this effort that 
we need to resolve (while he agrees on a limited-scope update that would 
preserve backwards compatibility, he would object to a wider scope). The 
first discussions on this topic need to deal with those questions in 
order to reach an agreement on the actual scope of this effort.

Thanks,

Gonzalo
SIPCORE cochair