Subject: [sipcore] rfc4424bis: what are these hi-target values for?

From: Hadriel Kaplan <[email-masked]>
Date: Sun, 12 Jul 2009 02:13:00 -0400

Howdy,
Another comment from the peanut gallery:
I think I've read all the emails on this draft now, as well as the drafts, and I still have no idea what value the hi-target params bring (the noop/predetermined/reg-uri/reg-uri-alias in draft-01, or the rc/cc/mp/rt in draft-02) besides interop issues.

I *think* I understand what we need: we need to know when the request was actually re-targeted to a different identity, vs. just routed to the original one; and we need to know/find the "original" request-URI for last target even if the request-URI in the SIP message we receive has been changed for other reasons (e.g., Registration resolution).

So then I look at these params, and it doesn't grok.  I have no idea what a UAS is supposed to do differently with these different values.  "Noop" made sense, in the sense that nothing changed and one wonders why a Proxy bothered cluttering up the History-Info list with gratuitous entries.  The param "mp" is the one that makes the most sense, because it's actually for when re-targeting occurs (right?).  So I get why we need that one, and why the UAS should care about it.  Having separate params for "rc"/"cc" doesn't make sense to me - who cares if the location-service learned it through a SIP REGISTER or just read some tea leaves?  The param "rt" seems like a bad conflation of "noop" and "cc". (really bad)

I guess one explanation can be "for troubleshooting purposes", but I'm guessing we'll be troubleshooting these troubleshooting purposes, because devices will invariably get them wrong, and other devices will invariably use them for some actual purpose; or worse, someone will make a middlebox modify these things to fix them to be what the next-hops expect, or hide why it became what it is. :(

This is like response codes all over again.  I know this is freaky thinking, but does it really matter *why* a Proxy inserted an HI entry? - what matters is what the UAS receiving them should *do* with it.

-Hadriel "confused" Kaplan

p.s. these 2-letter param names are really confusing; it was better with short terms.  I don't like making SIP messages longer either, but really the whole HI mechanism is already an exercise in verbosity. (although since they're distinct params, we can always call the param's by their descriptive names and just encode them in 2 letters on the wire - like "loose route" vs. "lr")

---

From: Hans Erik van Elburg <[email-masked]>
Date: Sun, 12 Jul 2009 12:19:55 +0200

Think you are right in that "mp" and "aor" is most important for a UAS 
that is only interested in target-uri use cases.
I.e. the presence of  an "mp" tag can be used to make the best guess 
about what was the original called target. Its absence means the first 
hi-entry is the best guess.
And by looking up the last entry tagged "aor" a UAS can determine the 
GRUU or alternative AOR which was used to reach it. (Similar as what 
P-Called-Party-ID is used for in IMS.)

/Hans Erik

Hadriel Kaplan wrote:
> _______________________________________________
> sipcore mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sipcore
>