Subject: Re: [sipcore] I-D on TCP/SCTP connection reuse

From: Gonzalo Camarillo <[email-masked]>
Date: Wed, 01 Jul 2009 22:48:00 +0300

Hi Vijay,

 > At this point, we are
> not sure where to target it -- sipcore is probably the closest.

when you are not sure where a new draft belongs, it is usually a good 
idea to send it to the DISPATCH list. As you have seen, discussions on 
how to dispatch new items can happen fairly quickly.

Cheers,

Gonzalo

---

From: Salvatore Loreto <[email-masked]>
Date: Wed, 08 Jul 2009 15:03:03 +0300

Hi Vijay,

a question more relate to I-D.ietf-sip-connect-reuse that the draft in 
object.
Working on draft-loreto-mmusic-sctp-sdp 
<http://tools.ietf.org/id/draft-loreto-mmusic-sctp-sdp-03.txt> I have 
been told
that no one has implemented yet TLS/SCTP as described
in RFC3436 (due to several technical problems), and instead TSVwg is 
working on
DTLS/SCTP in I-D.ietf-tsvwg-dtls-for-sctp.
So maybe it should be opportune recognize this fact also in the 
I-D.ietf-sip-connect-reuse

on Section 11 "Closing a TCP or SCTP connection", note that the *closure 
alert* is something TLS specific.
Here you should talk more in TCP or SCTP specific way, and explain if 
TCP half closed is supported or not,
or SCTP Graceful close.

cheers
Sal

Vijay Gurbani wrote:
> Folks: When we had moved connect-reuse ahead for IESG review, we
> had decided to take out the parts dealing with reusing TCP and SCTP
> connections.  The plan was to have a new I-D that documents how to
> use TCP and SCTP connection reuse.
>
> A draft along those lines is now available; please see
> http://tools.ietf.org/html/draft-jain-sip-transport-layer-connection-reuse-00. 
>
>
> Any comments on it will be most helpful.  At this point, we are
> But for now, if you can focus on the contents of the draft, that'll
> be most helpful.
>
> Thank you.
>
> - vijay