Subject: [sipcore] draft-barnes-sipcore-rfc4244bis - hi-targeted-to-uri

From: OKUMURA Shinji <[email-masked]>
Date: Fri, 10 Jul 2009 15:41:49 +0900

Hi,

I have one suggestion.

In the draft hi-targeted-to-uri is defined as follows

hi-targeted-to-uri = name-addr

If there is no special reason for the restriction, I think
addr-spec should be added as follows

hi-targeted-to-uri = name-addr/addr-spec

Regards,
Shinji

---

From: "Mary Barnes" <[email-masked]>
Date: Fri, 10 Jul 2009 11:14:35 -0500

Hi Shinji,

I honestly can't remember if there was a specific reason why we used
just name-addr, other than it also encompasses the addr-spec so you get
consistency in the format for the field. I'd welcome other opinions on
this. 

Thanks,
Mary. 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of OKUMURA Shinji
Sent: Friday, July 10, 2009 1:42 AM
To: [email-masked]
Subject: [sipcore] draft-barnes-sipcore-rfc4244bis - hi-targeted-to-uri

Hi,

I have one suggestion.

If there is no special reason for the restriction, I think addr-spec
should be added as follows

Regards,
Shinji
_______________________________________________
sipcore mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/sipcore

---

From: "Francois Audet" <[email-masked]>
Date: Fri, 10 Jul 2009 12:19:53 -0500

The reason is so that the URI is enclosed in <> which then allows us
to separate the URI parameters from the History-Info parameters.

For example, if we allowed addr-spec, there would be no
clean way to know if a parameter (say "index") was a
URI parameter, or a History-Info parameter.

Now, if you look at the definition of the Contact header,
it has the same problem. Contact can be either
name-addr / addr-spec however. So what we did in 3261 is
include text in 20.10 that says "If no "<" and ">" are 
present, all parameters after the URI are header parameters,
not URI parameters.".

I guess we could have done something similar here, but as you
can see, it it very nasty logic. Furthermore, since H-I very
often includes header parameters, the value of allowing 
addr-spec ends up being very low (i.e., you only same a couple
of letters "<" and ">" in only simple circumstances.

Therefore, using always the "<" ">" makes it much cleaner and
simpler, and easier to parse.

> From: Barnes, Mary (RICH2:AR00) 
> Sent: Friday, July 10, 2009 09:15
> To: OKUMURA Shinji; [email-masked]
> Cc: Audet, Francois (SC100:3055)
> Subject: RE: [sipcore] draft-barnes-sipcore-rfc4244bis - 
> hi-targeted-to-uri
> 
> Hi Shinji,
> 
> I honestly can't remember if there was a specific reason why 
> we used just name-addr, other than it also encompasses the 
> addr-spec so you get consistency in the format for the field. 
> I'd welcome other opinions on this. 
> 
> Thanks,
> Mary. 
> 
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of OKUMURA Shinji

---

From: "Dale Worley" <[email-masked]>
Date: Fri, 10 Jul 2009 16:05:03 -0400

> hi-targeted-to-uri = name-addr/addr-spec

That is an interesting point.  If we made that change, History-Info
would have the same overall syntax as Contact, From, To, etc., namely
that if the URI was not contained in <...>, the first ';' would start
the first header-parameter.

On the other hand, Route and Record route do not allow addr-spec, that
is, the <...> is mandatory.

In SIP 3.0, we should force all these headers to use the same syntax.

Dale

---

From: "Dale Worley" <[email-masked]>
Date: Fri, 10 Jul 2009 16:07:10 -0400

> of letters "<" and ">" in only simple circumstances.

Actually, you could save them any time the URI does not contain ',',
';', or '?'.

> simpler, and easier to parse.

Although the value of this is relatively low, as we can already parse
the complicated case (in To, From, and Contact headers).

Dale

---

From: "Francois Audet" <[email-masked]>
Date: Fri, 10 Jul 2009 16:08:42 -0500

Exactly.

In other words, we screwed up on "Contact". 

> From: Worley, Dale (BL60:9D30) 
> Sent: Friday, July 10, 2009 13:07
> To: Audet, Francois (SC100:3055)
> Cc: Barnes, Mary (RICH2:AR00); OKUMURA Shinji; [email-masked]
> Subject: Re: [sipcore] draft-barnes-sipcore-rfc4244bis - 
> hi-targeted-to-uri
> 
> > I guess we could have done something similar here, but as 
> you can see, 
> > it it very nasty logic. Furthermore, since H-I very often includes 
> > header parameters, the value of allowing addr-spec ends up 
> being very 
> > low (i.e., you only same a couple of letters "<" and ">" in only 
> > simple circumstances.
> 
> Actually, you could save them any time the URI does not 
> contain ',', ';', or '?'.
> 
> > Therefore, using always the "<" ">" makes it much cleaner 
> and simpler, 
> > and easier to parse.
> 
> Although the value of this is relatively low, as we can 
> already parse the complicated case (in To, From, and Contact headers).
> 
> Dale
> 
> 
>