Subject: [sipcore] Info-Event Open Issue: Header field parameter re-use

From: "Christer Holmberg" <[email-masked]>
Date: Wed, 28 Oct 2009 22:48:53 +0100

Hi,

Another issue which came to my mind when going through Keith's comment.

Currently we say that Info Package parameters can only be used with the
package for which it was defined.

But, what if another Info Package needs a parameter with exactly the
same semantics? Even if that other Info Package would use the same
parameter name, it would still have to re-define the parameter.

So, the question is: should we allow Info Package specifications to
refer to parameter defined for other Info Packages?

NOTE that I am NOT saying that Info Packages should be allowed to use
other parameters just like that - the I-P specifications must still
indicate (either by defining or refering to) which parameters are
allowed for that I-P.

Comments?

Regards,

Christer

---

From: "Sanjay Sinha (sanjsinh)" <[email-masked]>
Date: Thu, 29 Oct 2009 03:12:05 -0400

I think parameter name in context of the Info package should provide
enough meaning to distinguish it from  same parameter name use in
another package. So it should be allowed.

Sanjay

From: [email-masked] [mailto:[email-masked]] On
Behalf Of Christer Holmberg
Sent: Thursday, October 29, 2009 3:19 AM
To: SIPCORE
Subject: [sipcore] Info-Event Open Issue: Header field parameter re-use

Hi, 

Comments? 

Regards, 

Christer

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Thu, 29 Oct 2009 13:44:10 +0100

By reference is allowed, but it should be an explicit reference to the specific parameter from the new Info Package. (And it obviously has to make sense in the new Info Package definition.

Reference works a bit like a macro call, at the point the reference is made, include the referenced text in the document. So essentially reference is just like defining the parameter in full in the new document.

regards

Keith

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of Christer Holmberg
Sent: Wednesday, October 28, 2009 9:49 PM
To: SIPCORE
Subject: [sipcore] Info-Event Open Issue: Header field parameter re-use

Hi,

Currently we say that Info Package parameters can only be used with the package for which it was defined.

But, what if another Info Package needs a parameter with exactly the same semantics? Even if that other Info Package would use the same parameter name, it would still have to re-define the parameter.

So, the question is: should we allow Info Package specifications to refer to parameter defined for other Info Packages?

NOTE that I am NOT saying that Info Packages should be allowed to use other parameters just like that - the I-P specifications must still indicate (either by defining or refering to) which parameters are allowed for that I-P.

Comments?

Regards,

Christer

---

From: "Christer Holmberg" <[email-masked]>
Date: Thu, 29 Oct 2009 13:55:10 +0100

Hi,
 
>By reference is allowed, but it should be an explicit reference to the
specific  
>parameter from the new Info Package.  
 
Yes.
 
 >(And it obviously has to make sense in the new Info Package
definition. 
 
It always does :)
 
>Reference works a bit like a macro call, at the point the reference is
made, include the  
>referenced text in the document. So essentially reference is just like
defining the  
>parameter in full in the new document. 
 
Yes.
 
Regards,
 
Christer

 
regards
 
Keith

	From: [email-masked] [mailto:[email-masked]]
On Behalf Of Christer Holmberg
	Sent: Wednesday, October 28, 2009 9:49 PM
	To: SIPCORE
	Subject: [sipcore] Info-Event Open Issue: Header field parameter
re-use

	Hi, 

	Another issue which came to my mind when going through Keith's
comment. 

	Currently we say that Info Package parameters can only be used
with the package for which it was defined. 

	But, what if another Info Package needs a parameter with exactly
the same semantics? Even if that other Info Package would use the same
parameter name, it would still have to re-define the parameter.

	So, the question is: should we allow Info Package specifications
to refer to parameter defined for other Info Packages? 

	NOTE that I am NOT saying that Info Packages should be allowed
to use other parameters just like that - the I-P specifications must
still indicate (either by defining or refering to) which parameters are
allowed for that I-P.

	Comments? 

	Regards, 

	Christer

---

From: "Christer Holmberg" <[email-masked]>
Date: Fri, 30 Oct 2009 14:18:02 +0100

The new version of section 7.4 looks as below:
 
    "The Info Package specification MAY define Info Package parameters
which can be used in the
    Recv-Info or Info-Package header fields, together with the header
field value
    representing the Info Package. 

    The specification MUST describe the syntax and semantics of the
defined parameters. It MUST
    be specified whether a specific parameter is only applicable to the
Recv-Info 
    header field, the Info-Package header field, or both.

    The Info Package specification MAY also use Info Package parameters
defined in
    other Info Package specifications. In such cases the Info Package
specification MUST contain an 
    explicit reference to the parameters and the Info Package
specification in which the parameters are defined.

    By default, an Info Package parameter is only applicable for the
Info Package for which the parameter has 
    been explicitly defined.

    NOTE: Info Package parameters defined for specific Info Packages can
share the name with parameters defined for 
    other Info Packages, but the parameter semantics are specific to the
Info Package for which they are defined."
 
Regards,
 
Christer

	From: [email-masked] [mailto:[email-masked]]
On Behalf Of Christer Holmberg
	Sent: 29. lokakuuta 2009 14:55
	To: DRAGE, Keith (Keith); SIPCORE
	Subject: Re: [sipcore] Info-Event Open Issue: Header field
parameter re-use

	Hi,
	 
	>By reference is allowed, but it should be an explicit reference
to the specific  
	 
	Yes.
	 
definition. 
	 
	It always does :)
	 
	>Reference works a bit like a macro call, at the point the
reference is made, include the  
	>referenced text in the document. So essentially reference is
just like defining the  
	 
	Yes.
	 
	Regards,
	 
	Christer

	 
	regards
	 
	Keith

		From: [email-masked]
[mailto:[email-masked]] On Behalf Of Christer Holmberg
		Sent: Wednesday, October 28, 2009 9:49 PM
		To: SIPCORE
		Subject: [sipcore] Info-Event Open Issue: Header field
parameter re-use

		Hi, 

		Another issue which came to my mind when going through
Keith's comment. 

		Currently we say that Info Package parameters can only
be used with the package for which it was defined. 

		But, what if another Info Package needs a parameter with
exactly the same semantics? Even if that other Info Package would use
the same parameter name, it would still have to re-define the parameter.

		So, the question is: should we allow Info Package
specifications to refer to parameter defined for other Info Packages? 

		NOTE that I am NOT saying that Info Packages should be
allowed to use other parameters just like that - the I-P specifications
must still indicate (either by defining or refering to) which parameters
are allowed for that I-P.

		Comments? 

		Regards, 

		Christer

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Fri, 30 Oct 2009 14:21:14 +0100

Works for me.

Keith

________________________________
From: Christer Holmberg [mailto:[email-masked]]
Sent: Friday, October 30, 2009 1:18 PM
To: DRAGE, Keith (Keith); SIPCORE
Subject: RE: [sipcore] Info-Event Open Issue: Header field parameter re-use

    "The Info Package specification MAY define Info Package parameters which can be used in the
    Recv-Info or Info-Package header fields, together with the header field value
    representing the Info Package.
    The specification MUST describe the syntax and semantics of the defined parameters. It MUST
    be specified whether a specific parameter is only applicable to the Recv-Info
    header field, the Info-Package header field, or both.
    The Info Package specification MAY also use Info Package parameters defined in
    other Info Package specifications. In such cases the Info Package specification MUST contain an
    explicit reference to the parameters and the Info Package specification in which the parameters are defined.
    By default, an Info Package parameter is only applicable for the Info Package for which the parameter has
    been explicitly defined.
    NOTE: Info Package parameters defined for specific Info Packages can share the name with parameters defined for
    other Info Packages, but the parameter semantics are specific to the Info Package for which they are defined."

Regards,

Christer

Subject: Re: [sipcore] Info-Event Open Issue: Header field parameter re-use

Hi,

>By reference is allowed, but it should be an explicit reference to the specific

Yes.

 >(And it obviously has to make sense in the new Info Package definition.

It always does :)

>Reference works a bit like a macro call, at the point the reference is made, include the
>referenced text in the document. So essentially reference is just like defining the

Yes.

Regards,

Christer

regards

Keith

Hi,

Comments?

Regards,

Christer