Subject: [sipcore] Some comments on draft-barnes-sipcore-rfc4244bis-03

From: Alan Johnston <[email-masked]>
Date: Mon, 30 Nov 2009 07:13:32 -0600

Comments:

Section 4.1 first paragraph.  The part of this paragraph beginning with 
"Normally, UACs are not expected..." should probably be indented as it 
is a note.  There are probably other places where this could be done to 
improve the readability of the document.

Section 4.1, third paragraph about 3xx response.  I can see why this is 
necessary, but I wonder if anyone will support this requirement?

Section 5.1.2, Step 3 says "Same as per Step 3 above..." but it is not 
clear what step this is.

Section 5.1.3, Step 1 says "The proxy MUST then perform Steps 2 and 3."  
I presume this means the next 2 steps?

Section 5.1.3, Step 3 references "Same as per Step 3 above..."

Section 6.3.2:  Might want to include an explanation why a timeout 
should be treated as a 487 instead of a 408.

Does this document have a good voicemail example?  This is the 
application I am most interested in, so it would be nice to have a very 
clear example of this.

Nits:

p.25 "gratuitly" > "gratuitously"

Thanks,
Alan

---

From: Francois AUDET <[email-masked]>
Date: Mon, 30 Nov 2009 14:56:14 -0800

On Nov 30, 2009, at 5:13 , Alan Johnston wrote:

> 
> Does this document have a good voicemail example?  This is the application I am most interested in, so it would be nice to have a very clear example of this.
> 

That was the intent of section B.2 (in the appendix).

Are you saying you'd want a better voicemail example? Or that we add more voicemail examples? What do you have in mind?

---

From: Shida Schubert <[email-masked]>
Date: Tue, 1 Dec 2009 10:39:50 +0900

Francois;

 This was something Cullen asked we add to the draft too.

 I am assuming what we need is to add an explicit text that aids  
voicemail server to identify the target of the voicemail box.  

 If a call was initially received at Alice then diverted 
to Carol,  then to Bob which then diverts to voicemail, 
the question is for which AoR should the voicemail server 
leave a voicemail? 

 I think the answer depends on the configuration 
of the voicemail server. But with the "mp" tag and 
"mp" index we can identify when the mapping 
(diversion) took place making it much more  
deterministic to identify the target of the voicemail box.

 Looking at the example from the draft below; 

  History-Info: <sip:[email-masked]>;index=1
  History-Info: <sip:[email-masked]?Reason=SIP;cause=302>;\
                   index=1.1;rc
     History-Info: <sip:[email-masked]>;index=1.2;mp=1
     History-Info: <sip:[email-masked]>;index=1.2.1;rc
     History-Info: <sip:[email-masked]>;index=1.3;mp=1.2
     History-Info: <sip:[email-masked]>;index=1.3.1

 If the voicemail server is configured to use the voicemail box 
of the initial target it can look for the first mp tag and look 
at the hi-entry that mp index references ([email-masked]). 

 If the voicemail server is configured to use the voicemail box 
of the last target then it can look for the last mp tag and look 
at the hi-entry that mp index references ([email-masked]) etc. 

 Regards
  Shida

On Dec 1, 2009, at 7:56 AM, Francois AUDET wrote:

> _______________________________________________
> sipcore mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sipcore