Subject: [sipcore] INFO EVENT @ IETF#76: What is required to register an Info Package

From: "Christer Holmberg" <[email-masked]>
Date: Mon, 9 Nov 2009 08:37:52 +0100

Hi,

At the SIPCORE session the issue about what is required to register an
Info Package.

The outcome was that a specification (not necessarily not an IETF
document) is needed.

Regards,

Christer

---

From: Eric Burger <[email-masked]>
Date: Tue, 10 Nov 2009 10:04:06 +0900

Specifically, "Specification Required" as described in BCP 26 / RFC  
5226.

On Nov 9, 2009, at 4:37 PM, Christer Holmberg wrote:

>
> Hi,
>
> At the SIPCORE session the issue about what is required to register  
> an Info Package.
>
> _______________________________________________
> sipcore mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sipcore

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Tue, 10 Nov 2009 02:10:18 +0100

If you want to refer to RFC 5226 please define what you expect the expert review to review.

regards

Keith 

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Eric Burger
> Sent: Tuesday, November 10, 2009 1:04 AM
> To: Christer Holmberg
> Cc: [email-masked]
> Subject: Re: [sipcore] INFO EVENT @ IETF#76: What is required 
> to register an Info Package
> 
> Specifically, "Specification Required" as described in BCP 26 
> / RFC 5226.
>

---

From: "Christer Holmberg" <[email-masked]>
Date: Tue, 10 Nov 2009 02:14:04 +0100

Hi, 

>If you want to refer to RFC 5226 please define what you expect the
expert review to review.

Yes. I will discuss with the chairs, Robert etc, in order to get the
wording clear and correct.

Regards,

Christer

> Subject: Re: [sipcore] INFO EVENT @ IETF#76: What is required to 
> register an Info Package
>

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Tue, 10 Nov 2009 02:25:13 +0100

Does your response mean that you are proposing this should include expert review.

Keith 

> From: Christer Holmberg [mailto:[email-masked]] 
> Sent: Tuesday, November 10, 2009 1:14 AM
> To: DRAGE, Keith (Keith); Eric Burger
> Cc: [email-masked]
> Subject: RE: [sipcore] INFO EVENT @ IETF#76: What is required 
> to register anInfo Package
> 
> 
> Hi, 
> 
> Yes. I will discuss with the chairs, Robert etc, in order to 
> get the wording clear and correct.
> 
> Regards,
> 
> Christer
> 
>

---

From: "Christer Holmberg" <[email-masked]>
Date: Tue, 10 Nov 2009 02:33:46 +0100

Hi, 

>Does your response mean that you are proposing this should include
expert review.

That is my understanding, yes. IANA is supposed to request someone to
review the package. But, the intention is not to have technical
discussions about the mechanism as such.

But, this is what I will need to get help from the chairs and Robert on
- to make sure we have a clear understanding :)

Regards,

Christer

> Subject: RE: [sipcore] INFO EVENT @ IETF#76: What is required to 
> register anInfo Package
> 
> 
> Hi,
>

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Tue, 10 Nov 2009 02:54:00 +0100

In my view the only part that is expert reviewable is the bit that constitutes the IANA registration.

I see no reason for performing an expert review of the Info package specification itself.

regards

Keith

> Sent: Tuesday, November 10, 2009 1:34 AM
> That is my understanding, yes. IANA is supposed to request 
> someone to review the package. But, the intention is not to 
> have technical discussions about the mechanism as such.
>

---

From: Adam Roach <[email-masked]>
Date: Tue, 10 Nov 2009 11:00:14 +0900

[as an individual]

Jon Peterson actually explained this pretty well during the session -- 
RFC 5226 only requires:

            "[The] use of a Designated
             Expert, who will review the public specification and
             evaluate whether it is sufficiently clear to allow
             interoperable implementations."

And that is *all* they do. They evaluate whether it is clear enough to 
allow interoperability. Not whether it's a good idea, not whether it's 
secure -- merely that it is a specification that allows interoperability.

/a

On 11/10/09 10:10 AM, DRAGE, Keith (Keith) wrote:
>>> At the SIPCORE session the issue about what is required to
>>>        
>> register an
>>      
>>> Info Package.
>>>

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Tue, 10 Nov 2009 03:09:41 +0100

And I think we are therefore into the problem.

The package is a means of transporting an application.

We cannot set ourselves up as gods to review the application, which could well be part of the specification. I also believe it is beyond the scope of IETF to even think about that. It is like IETF insisting on reviewing all port number usage for interoperability.

So what remains to be reviewed of the Info-Package. Not a lot that helps interoperability I would content.

regards

Keith

> From: Adam Roach [mailto:[email-masked]] 
> Sent: Tuesday, November 10, 2009 2:00 AM
> To: DRAGE, Keith (Keith)
> Cc: Eric Burger; Christer Holmberg; [email-masked]
> Jon Peterson actually explained this pretty well during the 
> session -- RFC 5226 only requires:
> 
> And that is *all* they do. They evaluate whether it is clear 
> enough to allow interoperability. Not whether it's a good 
> idea, not whether it's secure -- merely that it is a 
> specification that allows interoperability.
> 
> /a
>

---

From: "Christer Holmberg" <[email-masked]>
Date: Tue, 10 Nov 2009 05:20:41 +0100

Hi,

I guess the expert reviewer CAN make sure that the Info Package does not specify things which break the core I-P mechanism (ie that a 469 should terminate the whole dialog etc), or put other requirements on the SIP protocol.

However, as Keith indicated (unless I missunderstood), in order to figure out whether the CONTENT of the I-P causes any interop issues, one would need to have detailed knowledge of the applications using the I-P.

Regards,

Christer

-----Alkuperäinen viesti-----
Lähettäjä: DRAGE, Keith (Keith) [mailto:[email-masked]]
Lähetetty: ti 10.11.2009 3:09
Vastaanottaja: Adam Roach
Kopio: Eric Burger; Christer Holmberg; [email-masked]
Aihe: RE: [sipcore] INFO EVENT @ IETF#76: What is required to register anInfo Package

regards

Keith

---

From: Dean Willis <[email-masked]>
Date: Wed, 11 Nov 2009 00:50:01 -0600

> I see no reason for performing an expert review of the Info package specification itself.

question for the reviewer: is the referenced specification credible as a
specification? that is, is it available and likely to stay that way and
does it actually describe the info-package?

note that we do not ask "does the specification make sense as an
application for INFO or is INFO a reasonable solution to the problem?

--
dean

---

From: "Christer Holmberg" <[email-masked]>
Date: Mon, 16 Nov 2009 22:37:58 +0100

What about the following text?

		"Please create a subregistry in the SIP Parameters
registry for Info Packages.

            Based on <xref target="RFC5226">, IANA assigns an expert in
order to review an Info Package which is to
            be registered. The Info Package specification is provided to
the reviewer, who ensures that the Info Package is described 
            in a proper way.
 
            The reviewer does not consider the applicability of the Info
Package for the usage for which it is defined.

            The following data elements populate the Info Package
Registry.<list style="symbols">

			Info Package Name: The Info Package Name is a
case insensitive
			token. In addition, IANA shall not register
multiple Info Package
			names that have identical case-insensitive
values.

			Reference: A reference to the specification
which describes the
			Info Package."

Regards,

Christer

-----Original Message-----
From: Dean Willis [mailto:[email-masked]] 
Sent: 11. marraskuuta 2009 8:50
To: DRAGE, Keith (Keith)
Cc: Christer Holmberg; Eric Burger; [email-masked]
Subject: Re: [sipcore] INFO EVENT @ IETF#76: What is required to
register anInfo Package

--
dean

---

From: Eric Burger <[email-masked]>
Date: Tue, 17 Nov 2009 06:49:06 +0800

WFM