Subject: Re: [sipcore] Reviewing the sec-flows draft

From: Gonzalo Camarillo <[email-masked]>
Date: Sun, 06 Dec 2009 19:10:54 +0200

Folks,

as you know, when we restructured the RAI area one of the plans was to 
avoid working on specifications people were not interested in any 
longer. Adam and I have had to assign a new editor (with cycles) to this 
document and have unsuccessfully asked for reviewers *many* times. If we 
do not see some activity related to this draft in the near future the 
only conclusion we can draw is that we should abandon it.

So, if you think this is important, now it would be a good time for 
volunteering. Also, if you think we should abandon this draft, let us 
know as well.

Thanks,

Gonzalo
SIPCORE co-chair

Gonzalo Camarillo wrote:
> Folks,
> 
> as you may have noticed, Brian has submitted a new revision of this 
> draft and sent a couple of notes to the list (on November 24th) 
> describing the topics on which he expects to get feedback. Please, send 
> your comments to this list.
> 
> Thanks,
> 
> Gonzalo
> SIPCORE co-chair
> 
> Gonzalo Camarillo wrote:
>> Folks,
>>
>> as you know, we have asked for volunteers to review the sec-flows 
>> draft many times. We got a couple of reviews but we would like to get 
>> at least one dedicated review more. If you want to volunteer, please 
>> send your review to the list.
>>
>> Additionally, the reviews we got pointed out at issues that require WG 
>> consensus (as opposed to the editor simply going off and implementing 
>> them).
>>
>> As next steps, the draft's editor (Brian) will be submitting a new 
>> revision of the draft because the current one has expired. Then, he 
>> will be sending a set of emails to the list so that we can reach 
>> consensus on the issues that need discussion.
>>
>> Thanks,
>>
>> Gonzalo
>> SIPCORE co-chair
>> _______________________________________________
>> sipcore mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/sipcore
>>
> 
> _______________________________________________
> sipcore mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sipcore
>

---

From: "Vijay K. Gurbani" <[email-masked]>
Date: Sun, 06 Dec 2009 20:41:50 -0600

> volunteering. Also, if you think we should abandon this draft, let us

We should NOT abandon it; the draft has some good information.
I had promised Brian a review of some sections after Thanksgiving,
but have been tied up last week.  I intend to send out comments
this week (i.e., Dec. 7).

Thanks,

- vijay
-- 
Vijay K. Gurbani, Bell Laboratories, Alcatel-Lucent
1960 Lucent Lane, Rm. 9C-533, Naperville, Illinois 60566 (USA)
Email: vkg@{alcatel-lucent.com,bell-labs.com,acm.org}
Web:   http://ect.bell-labs.com/who/vkg/

---

From: Cullen Jennings <[email-masked]>
Date: Wed, 9 Dec 2009 12:55:19 -0700

I get many emails from implementors that use this draft. I'm really would not wan to abandon it. The reason no one is very excited to work on it is that it has been pretty much done for many years now. I'm not even sure when I should bother to read it and I'm an author. If we are going to actually finish it, I'm glad to to get people to read it but the current process seems to just leave it in zombie land where no one does anything because there is no commitment one way or the other to do anything with it.

Cullen <with my individual contributor hat on>

On Dec 6, 2009, at 10:10 AM, Gonzalo Camarillo wrote:

> Folks,
> 
> as you know, when we restructured the RAI area one of the plans was to avoid working on specifications people were not interested in any longer. Adam and I have had to assign a new editor (with cycles) to this document and have unsuccessfully asked for reviewers *many* times. If we do not see some activity related to this draft in the near future the only conclusion we can draw is that we should abandon it.
> 
> So, if you think this is important, now it would be a good time for volunteering. Also, if you think we should abandon this draft, let us know as well.
> 
> Thanks,
> 
> Gonzalo
> SIPCORE co-chair
> 
> 
> Gonzalo Camarillo wrote:
>> Folks,
>> as you may have noticed, Brian has submitted a new revision of this draft and sent a couple of notes to the list (on November 24th) describing the topics on which he expects to get feedback. Please, send your comments to this list.
>> Thanks,
>> Gonzalo
>> SIPCORE co-chair
>> Gonzalo Camarillo wrote:
>>> Folks,
>>> 
>>> as you know, we have asked for volunteers to review the sec-flows draft many times. We got a couple of reviews but we would like to get at least one dedicated review more. If you want to volunteer, please send your review to the list.
>>> 
>>> Additionally, the reviews we got pointed out at issues that require WG consensus (as opposed to the editor simply going off and implementing them).
>>> 
>>> As next steps, the draft's editor (Brian) will be submitting a new revision of the draft because the current one has expired. Then, he will be sending a set of emails to the list so that we can reach consensus on the issues that need discussion.
>>> 
>>> Thanks,
>>> 
>>> Gonzalo
>>> SIPCORE co-chair

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 09 Dec 2009 15:35:17 -0500

Cullen Jennings wrote:
> I get many emails from implementors that use this draft.

Are those people using it to help them understand the specs?
Or in lieu of bothering to understand the specs?

Unfortunately I have the impression that there are a significant number 
of developers that implement from call flow documents and/or call traces 
of existing implementations rather than trying to understand the specs.

That is almost enough to motivate a "call flows considered harmful" paper.

I personally find call flows most useful:
1) by the writers of specs, to verify that the specs "work",
2) as a design output from implementors for review
    of the design prior to implementation
3) as use cases for planned new work

	Thanks,
	Paul

---

From: Cullen Jennings <[email-masked]>
Date: Wed, 9 Dec 2009 23:04:38 -0700

> Or in lieu of bothering to understand the specs?

Ouch, that is brutal. But uh, yah, some probably only read this spec because they could not find a wireshark capture that they could use to go implement from. But others are trying to use the stuff in here to test and to see at what stage their implementation went wrong. 

> 
> Unfortunately I have the impression that there are a significant number of developers that implement from call flow documents and/or call traces of existing implementations rather than trying to understand the specs.

uh yah, I see some call flows that certainly make me think some people do it that way

> 3) as use cases for planned new work

Generally agree but in case of TLS or S/MIME, when you are implementing, it is really hard to figure out what went wrong. You just get a "security failed" error from underlying libraries and it is really nice to be able to compare your call flow to a "known good" one or even use some test vectors from it for testing.  Kumiko and I both did separate implementations of all this stuff then did messages between them in working on this draft.

---

From: Gonzalo Camarillo <[email-masked]>
Date: Thu, 10 Dec 2009 13:25:25 +0200

Hi,

thanks all of you who replied showing interest in this work and, more 
importantly, started responding to the questions Brian sent some time 
ago. Let's make sure we keep the ball rolling now.

Thanks,

Gonzalo

Gonzalo Camarillo wrote:
>> describing the topics on which he expects to get feedback. Please, 
>> send your comments to this list.
>>
>> Thanks,
>>
>> Gonzalo
>> SIPCORE co-chair
>>
>> Gonzalo Camarillo wrote:
>>> Folks,
>>>
>>> Additionally, the reviews we got pointed out at issues that require 
>>> WG consensus (as opposed to the editor simply going off and 
>>> implementing them).
>>>