Subject: Re: [sipcore] Some comments on draft-barnes-sipcore-rfc4244bis-03

From: Francois Audet <[email-masked]>
Date: Tue, 1 Dec 2009 19:55:53 -0800

That seems pretty reasonable to me. But...

Perhaps we can clarify a bit more in explaining why a voicemail system  
would choose the first versus the last redirecting target.  This is  
typically not a "configuration" as described in your example below  
(although, it is certainly possible).

Typically, a voicemail system will choose the first one IF it is  
responsible for the mailbox of that target. Obviously, it would be  
impossible otherwise. In this latter case, the voicemail system would  
then use the last redirecting number.

This is why I don't think we can put "normative" text, but instead  
"use case examples" as described above. A implementation could decide  
to always use the last redirecting number.

On Nov 30, 2009, at 17:39 , Shida Schubert wrote:

>
> Francois;
>
> This was something Cullen asked we add to the draft too.
>
> I am assuming what we need is to add an explicit text that aids
> voicemail server to identify the target of the voicemail box.
>
> If a call was initially received at Alice then diverted
> to Carol,  then to Bob which then diverts to voicemail,
> the question is for which AoR should the voicemail server
> leave a voicemail?
>
> I think the answer depends on the configuration
> of the voicemail server. But with the "mp" tag and
> "mp" index we can identify when the mapping
> (diversion) took place making it much more
> deterministic to identify the target of the voicemail box.
>
> Looking at the example from the draft below;
>
>  History-Info: <sip:[email-masked]>;index=1
>  History-Info: <sip:[email-masked]?Reason=SIP;cause=302>;\
>                   index=1.1;rc
>     History-Info: <sip:[email-masked]>;index=1.2;mp=1
>     History-Info: <sip:[email-masked]>;index=1.2.1;rc
>     History-Info: <sip:[email-masked]>;index=1.3;mp=1.2
>     History-Info: <sip:[email-masked]>;index=1.3.1
>
> If the voicemail server is configured to use the voicemail box
> of the initial target it can look for the first mp tag and look
> at the hi-entry that mp index references ([email-masked]).
>
> If the voicemail server is configured to use the voicemail box
> of the last target then it can look for the last mp tag and look
> at the hi-entry that mp index references ([email-masked]) etc.
>
> Regards
>  Shida
>
> On Dec 1, 2009, at 7:56 AM, Francois AUDET wrote:
>
>>
>> On Nov 30, 2009, at 5:13 , Alan Johnston wrote:
>>
>>>
>>> Does this document have a good voicemail example?  This is the  
>>> application I am most interested in, so it would be nice to have a  
>>> very clear example of this.
>>>
>>
>> That was the intent of section B.2 (in the appendix).
>>
>> Are you saying you'd want a better voicemail example? Or that we  
>> add more voicemail examples? What do you have in mind?
>> _______________________________________________
>> sipcore mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/sipcore
>

---

From: Shida Schubert <[email-masked]>
Date: Wed, 2 Dec 2009 14:28:22 +0900

I don't think we need normative text, the whole examples are 
in appendix anyways, but I think what people want is to have 
explicit text on how one can determine the first versus the 
last redirecting target. I am not the one asking for them so 
I can't speak for them though.. 

 Regards
  Shida

On Dec 2, 2009, at 12:55 PM, Francois Audet wrote:

> Perhaps we can clarify a bit more in explaining why a voicemail system would choose the first versus the last redirecting target.  This is typically not a "configuration" as described in your example below (although, it is certainly possible).
> 
> Typically, a voicemail system will choose the first one IF it is responsible for the mailbox of that target. Obviously, it would be impossible otherwise. In this latter case, the voicemail system would then use the last redirecting number.
> 
> This is why I don't think we can put "normative" text, but instead "use case examples" as described above. A implementation could decide to always use the last redirecting number.
> 
>>>> Does this document have a good voicemail example?  This is the application I am most interested in, so it would be nice to have a very clear example of this.
>>>> 
>>> 
>>> Are you saying you'd want a better voicemail example? Or that we add more voicemail examples? What do you have in mind?

---

From: Francois Audet <[email-masked]>
Date: Tue, 1 Dec 2009 21:55:42 -0800

Cullen, Alan, what do you think?

---

From: <[email-masked]>
Date: Wed, 2 Dec 2009 09:12:33 +0100

Hi Shida and François,
I have never heard about an implementation that a forwarding service will choose the first entry for voicemail.
Should I see this more in the surrounding of private networks/PBX?

Seen from the diverting user either I would like to forward my call to an other URI or to an voicemail service. But that is a decision that the diverting user is taking.

Best Regards
Roland 

-----Ursprüngliche Nachricht-----
Von: [email-masked] [mailto:[email-masked]] Im Auftrag von Shida Schubert
Gesendet: Mittwoch, 2. Dezember 2009 06:28
An: Francois Audet
Cc: [email-masked]
Betreff: Re: [sipcore] Some comments on draft-barnes-sipcore-rfc4244bis-03

 Regards
  Shida

---

From: Shida Schubert <[email-masked]>
Date: Wed, 2 Dec 2009 17:46:57 +0900

Roland;

 I agree for service provider like us it's always the 
last diverting user that is the target for voicemail. 

 I could imagine though that call may be diverted to 
several people (AoR) before going to a voicemail server 
within a corporate realm, in which case the target 
may be the first entry who configured the server to 
divert calls to several AoRs before diverting to a 
voicemail server.. 

 Regards
  Shida

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 02 Dec 2009 09:01:02 -0500

> Seen from the diverting user either I would like to forward my call to an other URI or to an voicemail service. But that is a decision that the diverting user is taking.

IMO the diverting user should have the option to attempt a diversion to 
another number but have the call go to his own voicemail if that 
diversion fails - preempting subsequent diversion to another's voicemail.

But that should *not* depend on on the downstream users using the same 
VM server. Its a matter of the diverting user entering a preference that 
the call not go to voicemail downstream. Callerprefs has a mechanism to 
indicate this, but I have never heard of it being supported for this.

This would of course be *policy*. In other cases I might indeed want to 
delegate full responsibility for the call, including going to voicemail.

Unfortunately, making this work requires that the diversion target 
cooperate.

	Thanks,
	Paul

---

From: <[email-masked]>
Date: Wed, 2 Dec 2009 16:02:41 +0100

The only application I could think about is a company's network where one call agent has a couple of replacements and if they are not reachable then the voicemail of the originally called UA is then put in charge.

But As Paul said that is a policy within a private network/PBX and will never happen for an operator approach. So if such an example will be put into, then the circumstances should be described explicitly.

Thanks you and Best Regards

Roland 

-----Ursprüngliche Nachricht-----
Von: Paul Kyzivat [mailto:[email-masked]] 
Gesendet: Mittwoch, 2. Dezember 2009 15:01
An: Jesske, Roland
Cc: [email-masked]; [email-masked]; [email-masked]
Betreff: Re: [sipcore] Some comments on draft-barnes-sipcore-rfc4244bis-03

	Thanks,
	Paul

---

From: Francois Audet <[email-masked]>
Date: Wed, 2 Dec 2009 09:19:58 -0800

Yeah, PBXs do this.

I was told that service providers do this to.

When you think about it, it makes sense.

If you call me, you would expect to get my voicemail, not somebody else's.

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 02 Dec 2009 12:25:25 -0500

> But As Paul said that is a policy within a private network/PBX and will never happen for an operator approach. So if such an example will be put into, then the circumstances should be described exp…

Some cases that are (IMO) very plausible:

1) I want incoming calls to my cellphone to divert to my home phone
    if I don't answer. But if there is no answer at home either,
    then I want the call to go to my cellphone voicemail. (Because
    I'm more likely to check that in a timely way.)

2) I want calls to my office phone to try my personal cell phone
    if I'm not in the office. But I want any messages left on my
    office voicemail because it is corporate policy not to have
    business stuff recorded on VM servers it doesn't control.

3) When I'm at lunch, I want calls to my business line to try
    the person who backs me up when I'm away. But if that person
    can't take the call then I want it on my voicemail to deal
    with after lunch.

    (Converse to this: When I'm on *vacation*, I want calls to my
    business line to try the person who backs me up. If they can't
    answer, then I want messages left on *their* vm, so that they
    can deal with it later. Don't want callers waiting until I get
    back from vacation.)

	Thanks,
	Paul

---

From: "Elwell, John" <[email-masked]>
Date: Wed, 2 Dec 2009 21:15:34 +0100

I agree with these examples Paul has enumerated, and I personally use the second one. It relies on my domain proxy stepping in and cancelling the call to my cellphone before it has chance to divert to cellphone (personal) voicemail (unless of course I have disabled that capability). As Paul pointed out earlier, SIP does have a means of doing it using caller preferences, but this doesn't work if the call goes to PSTN.

John

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Paul Kyzivat
> Sent: 02 December 2009 17:25
> To: [email-masked]
> Cc: [email-masked]; [email-masked]
> Subject: Re: [sipcore] Some comments on 
> draft-barnes-sipcore-rfc4244bis-03
> 
> 
> 
> > The only application I could think about is a company's 
> network where one call agent has a couple of replacements and 
> if they are not reachable then the voicemail of the 
> originally called UA is then put in charge.
> > 
> > But As Paul said that is a policy within a private 
> network/PBX and will never happen for an operator approach. 
> So if such an example will be put into, then the 
> circumstances should be described explicitly.
> 
> >> I have never heard about an implementation that a 
> forwarding service will choose the first entry for voicemail.
> >> Seen from the diverting user either I would like to 
> forward my call to an other URI or to an voicemail service. 
> But that is a decision that the diverting user is taking.
> > 
> >> Von: [email-masked] 
> [mailto:[email-masked]] Im Auftrag von Shida Schubert
> >>> Perhaps we can clarify a bit more in explaining why a 
> voicemail system would choose the first versus the last 
> redirecting target.  This is typically not a "configuration" 
> as described in your example below (although, it is certainly 
> possible).
> >>>
> >>> Typically, a voicemail system will choose the first one 
> IF it is responsible for the mailbox of that target. 
> Obviously, it would be impossible otherwise. In this latter 
> case, the voicemail system would then use the last redirecting number.
> >>>
> >>> This is why I don't think we can put "normative" text, 
> but instead "use case examples" as described above. A 
> implementation could decide to always use the last redirecting number.
> >>>
> >>>>>> Does this document have a good voicemail example?  
> This is the application I am most interested in, so it would 
> be nice to have a very clear example of this.
> >>>>>>
> >>>>> Are you saying you'd want a better voicemail example? 
> Or that we add more voicemail examples? What do you have in mind?

---

From: Gonzalo Camarillo <[email-masked]>
Date: Sun, 06 Dec 2009 18:39:54 +0200

Hi,

> If you call me, you would expect to get my voicemail, not somebody else's.

yes, Paul's example has been discussed *many* times. So, addressing it 
in some way would be a good thing.

Cheers,

Gonzalo

---

From: Paul Kyzivat <[email-masked]>
Date: Sun, 06 Dec 2009 12:52:17 -0500

The main tactic I know of that is currently deployed to address this 
need is to cancel the forwarded call after a few "rings", hopefully 
before it is transferred to voicemail there. But of course that doesn't 
work if you guess wrong about the number of rings, and especially if the 
call goes direct to voicemail.

While there is no way, once I have forwarded a call to you, for me to 
*prevent* you from handling the call as voicemail, it is typically in 
the best interests of both of us. Specifically, if I am forwarding the 
call to you, but asked you *not* to send the call to your voicemail, 
then honoring that saves you the trouble handling the voicemail, and 
also keeps you in my good graces.

So the key here is to communicate preferences for how the call should be 
handed, and define the recommended handling of calls in the presence of 
such a recommendation.

The basics to do this have been in callerprefs for a long time. But I 
don't think they have been considered seriously in this context. I'm not 
*certain* that is sufficient to address the problem, but it seems like 
the right starting point.

Note that this sort of approach *does not* require looking back in the 
History-Info to decide which voice mailbox to use.

	Thanks,
	Paul

---

From: Shida Schubert <[email-masked]>
Date: Thu, 24 Dec 2009 16:25:12 +0900

If the focus is about which target (AoR) is to be considered for 
any special call handling such as voicemail (use of RFC4458?)
, so when call is forwarded the receiving end knows there is a 
preferred identity which is to be honored, then we may have 
some work to do with History-Info but otherwise I don't think 
there is much more to do beside elaborating the voicemail section.  

 Any thoughts? 
 
 Regards
  Shida

On Dec 7, 2009, at 2:52 AM, Paul Kyzivat wrote:

> The main tactic I know of that is currently deployed to address this need is to cancel the forwarded call after a few "rings", hopefully before it is transferred to voicemail there. But of course that doesn't work if you guess wrong about the number of rings, and especially if the call goes direct to voicemail.
> 
> While there is no way, once I have forwarded a call to you, for me to *prevent* you from handling the call as voicemail, it is typically in the best interests of both of us. Specifically, if I am forwarding the call to you, but asked you *not* to send the call to your voicemail, then honoring that saves you the trouble handling the voicemail, and also keeps you in my good graces.
> 
> So the key here is to communicate preferences for how the call should be handed, and define the recommended handling of calls in the presence of such a recommendation.
> 
> The basics to do this have been in callerprefs for a long time. But I don't think they have been considered seriously in this context. I'm not *certain* that is sufficient to address the problem, but it seems like the right starting point.
> 
> Note that this sort of approach *does not* require looking back in the History-Info to decide which voice mailbox to use.
> 
> 	Thanks,
> 	Paul
> 
> 
> Gonzalo Camarillo wrote:
>> Hi,
>> yes, Paul's example has been discussed *many* times. So, addressing it in some way would be a good thing.
>> Cheers,
>> Gonzalo