Subject: [sipcore] 199 issue: UAC issue when proxies send unreliable 199 in case of Require:100rel

From: Christer Holmberg <[email-masked]>
Date: Mon, 24 Jan 2011 18:12:26 +0100

Hi,

An issue that came up during the review of 199 was whether the fact that a proxy was allowed to send unreliable 199 responses, even in the case of Require:100rel.

The WG previously agreed that Require:100rel as such does not affect proxies. But, the issue that has been raised is more related to the UAC: it could receive unreliable 199 responses even if it has required provisional responses to be sent reliably.

So, people asked whether we would need to update RFC 3262, and state that a UAC has to be ready to receive unreliable provisional responses even in the case of Require:100rel.

Another proposal was so simply say that a proxy is not allowed to send 199 responses in case of Require:100rel, and include a recommendation that the UAC does not use Require:100rel when also indicating support of 199 - unless the UAC also uses other extensions that mandates Require:100rel, that is.

My suggestion is to move forward with the second proposal, i.e. to say that a proxy must not send 199 responses in case of Require:100rel.

If someone objects to such way forward, please indicate it on the list (preferable together with an alternative solution) by Friday this week.

Thanks!

Regards,

Christer

---

From: Christer Holmberg <[email-masked]>
Date: Sun, 30 Jan 2011 13:31:33 +0100

Hi,

As there were no objections, I have now submitted a new version (-04) of the draft, that implements the suggested changes below.

Regards,

Christer

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of Christer Holmberg
Sent: 24. tammikuuta 2011 19:12
To: [email-masked]
Subject: [sipcore] 199 issue: UAC issue when proxies send unreliable 199 in case of Require:100rel

Hi,

Thanks!

Regards,

Christer

---

From: "Elwell, John" <[email-masked]>
Date: Mon, 31 Jan 2011 13:03:34 +0100

Christer,

It seems to me that section 9 is not needed. The two normative statements it contains seem to duplicate normative statements made earlier, but using slightly different language. IMO it is not good practice to repeat normative statements, and repeating them using different language is even worse - if the two instances are found to have subtly different meanings, which one wins?

John

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Christer Holmberg
> Sent: 30 January 2011 12:32
> To: [email-masked]
> Subject: Re: [sipcore] 199 issue: UAC issue when proxies send 
> unreliable 199 in case of Require:100rel
> 
> Hi,
>  
> As there were no objections, I have now submitted a new 
> version (-04) of the draft, that implements the suggested 
> changes below.
>  
> Regards,
>  
> Christer
> 
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Christer Holmberg
> An issue that came up during the review of 199 was whether 
> the fact that a proxy was allowed to send unreliable 199 
> responses, even in the case of Require:100rel.
>  
> The WG previously agreed that Require:100rel as such does not 
> affect proxies. But, the issue that has been raised is more 
> related to the UAC: it could receive unreliable 199 responses 
> even if it has required provisional responses to be sent reliably.
>  
> So, people asked whether we would need to update RFC 3262, 
> and state that a UAC has to be ready to receive unreliable 
> provisional responses even in the case of Require:100rel.
>  
> Another proposal was so simply say that a proxy is not 
> allowed to send 199 responses in case of Require:100rel, and 
> include a recommendation that the UAC does not use 
> Require:100rel when also indicating support of 199 - unless 
> the UAC also uses other extensions that mandates 
> Require:100rel, that is.
>  
> My suggestion is to move forward with the second proposal, 
> i.e. to say that a proxy must not send 199 responses in case 
> of Require:100rel.
>  
> If someone objects to such way forward, please indicate it on 
> the list (preferable together with an alternative solution) 
> by Friday this week.
>  
> Thanks!
>  
> Regards,
>  
> Christer
>  
>  
>  
>

---

From: Christer Holmberg <[email-masked]>
Date: Mon, 31 Jan 2011 13:17:11 +0100

Hi,

I guess I could remove section 9, especially since we no more specify any exception allowing the sending of unreliable 199 responses in case of Require:100rel.

Thanks for the comment!

Regards,

Christer

________________________________________
From: Elwell, John [[email-masked]]
Sent: Monday, January 31, 2011 2:03 PM
To: Christer Holmberg; [email-masked]
Subject: RE: [sipcore] 199 issue: UAC issue when proxies send unreliable 199 in case of Require:100rel

Christer,

John