Subject: [sipcore] I-D Action:draft-ietf-sipcore-location-conveyance-07.txt

From: [email-masked]
Date: Wed, 04 May 2011 15:45:02 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Session Initiation Protocol Core Working Group of the IETF.

	Title           : Location Conveyance for the Session Initiation Protocol
	Author(s)       : J. Polk, et al.
	Filename        : draft-ietf-sipcore-location-conveyance-07.txt
	Pages           : 30
	Date            : 2011-05-04

This document defines an extension to the Session Initiation 
Protocol (SIP) to convey geographic location information from one 
SIP entity to another SIP entity.  The SIP extension covers 
end-to-end conveyance as well as location-based routing, where SIP 
intermediaries make routing decisions based upon the location of the
Location Target.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-sipcore-location-conveyance-07.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: "Elwell, John" <[email-masked]>
Date: Thu, 5 May 2011 10:58:21 +0200

I noticed the following:

Modified text in section 4.2:
"If no Geolocation-Routing header field is present in a SIP request, 
   a SIP intermediary MAY insert this header. Without knowledge from a 
   Rulemaker, the SIP intermediary inserting this header-value SHOULD 
   NOT set the value to "yes", as this could allow the Target's 
   location to be forwarded to third parties without the Target's 
   explicit permission. An easy way around this is to have the Target 
   always insert this header-value as "no"."
Even if the value is set to "no", the target's location could end up being forwarded to third parties without the target's explicit permission. Normal SIP routing (without taking location into account) can result in a request being forwarded to another destination. So the words:
"as this could allow the Target's 
   location to be forwarded to third parties without the Target's 
   explicit permission"
should be deleted, as this can arise anyway and is not impacted by the value of the Geolocation-Routing header field.

John

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of 
> [email-masked]
> Sent: 04 May 2011 23:45
> To: [email-masked]
> Cc: [email-masked]
> Subject: [sipcore] I-D 
> Action:draft-ietf-sipcore-location-conveyance-07.txt
>