Subject: Re: [sipcore] draft-barnes-sipcore-rfc4244bis

From: Cullen Jennings <[email-masked]>
Date: Tue, 21 Jun 2011 16:21:29 -0700

I still feel the same as my email from last nov ...

On Nov 11, 2010, at 1:41 , Cullen Jennings wrote:

> 
> The draft has a lot well specified procedures about how to write tags to a message, and it discusses that the tags could be used in lots of ways. However, I would like to see some text added to section 8 that allowed implementers to use this specification to implemented some of the use cases it is designed to meet. Specifically I would like to see normative language on how a voicemail system can use the tags found in an incoming invite to determined which mailbox the call should be delivered too. 
> 
> People have suggested to me this information is in the call flows document. I like call flows, I think they help people, but this is an information document with no normative language describing how to do this. I'm not a huge fan of people implementing things off call flows. I rather have the procedures for this specified in 4244bis and then have example call flows that illustrated this in the call flow draft.

---

From: "Worley, Dale R (Dale)" <[email-masked]>
Date: Wed, 22 Jun 2011 15:50:10 -0400

________________________________________
From: [email-masked] [[email-masked]] On Behalf Of Cullen Jennings [[email-masked]]

> However, I would like to see some text added to section 8 that allowed implementers to use this specification to implemented some of the use cases it is designed to meet. Specifically I would like to see normative language on how a voicemail system can use the tags found in an incoming invite to determined which mailbox the call should be delivered too.
_______________________________________________

Most importantly, presenting algorithms for the use cases allows the reader to verify that the mechanism does accomplish what it was designed to do, and that there are not peculiar cases where the mechanism fails.

Dale