Subject: [sipcore] 4244bis: How does History-Info account for Route?

From: "Worley, Dale R (Dale)" <[email-masked]>
Date: Tue, 5 Jul 2011 15:10:49 -0400

How does the History-Info reflect the actions due to Route headers?  As written, while the request is being routed due to the Route URIs, the request-URI does not change, and so many History-Info entries show the request-URI (and give no information about where the request was being sent).

Oddly, I ran into this while I was considering a practical use for H-I:  It allows the upstream proxies to determine if a fork reached a particular downstream proxy, and so helps with the "redundant paths" routing issue.

Dale

---

From: Shida Schubert <[email-masked]>
Date: Sun, 10 Jul 2011 18:22:05 +0900

Hi Dale;

 The H-I will capture the request being routed via Route header
but will not add any tag. 

 It would have a redundant R-URI in H-I but will increase the 
depth of branch. It will not have the "rc" tag, we considered 
a tag "np" (No-op) for this in the earlier version of the draft but 
WG decided it was useless so we removed it from the draft. 

 e.g. 

     History-Info: <sip:[email-masked]>;index=1;
     History-Info: <sip:[email-masked]>;index=1.1;  (H-I due to Route header)
     History-Info: <sip:[email-masked]?Reason%3BSIP%3Dcause%3B408>;index=1.1.1;rc=1.1;
     History-Info: <sip:[email-masked]>;index=1.1.2;rc=1.1;

 Regards
  Shida

On Jul 6, 2011, at 4:10 AM, Worley, Dale R (Dale) wrote:

> _______________________________________________
> sipcore mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sipcore