Subject: Re: [sipcore] draft-barnes-sipcore-rfc4244bis

From: Shida Schubert <[email-masked]>
Date: Sun, 10 Jul 2011 16:08:37 +0900

Hi Dale;

 Could you elaborate as to what you are suggesting?

 Regards
  Shida

On Jun 23, 2011, at 4:50 AM, Worley, Dale R (Dale) wrote:

> ________________________________________
> From: [email-masked] [[email-masked]] On Behalf Of Cullen Jennings [[email-masked]]
> 
>> However, I would like to see some text added to section 8 that allowed implementers to use this specification to implemented some of the use cases it is designed to meet. Specifically I would like to see normative language on how a voicemail system can use the tags found in an incoming invite to determined which mailbox the call should be delivered too.
> _______________________________________________
> 
> Most importantly, presenting algorithms for the use cases allows the reader to verify that the mechanism does accomplish what it was designed to do, and that there are not peculiar cases where the mechanism fails.
> 
> Dale
> _______________________________________________
> sipcore mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sipcore

---

From: "Worley, Dale R (Dale)" <[email-masked]>
Date: Mon, 11 Jul 2011 14:55:45 -0400

(replying to the message below)

Cullen was raising the question "Exactly how do you use History-Info to make the decisions that we think it will allow to be made?"  My concept is that we should present algorithms that (allegedly) process History-Info to make the decisions needed by the various use cases.  My message "[sipcore] 4244bis Application processing" (http://www.ietf.org/mail-archive/web/sipcore/current/msg04186.html) was an attempt to present such algorithms -- note that those algorithms work in a different way than do the algorithms in 4244bis.  In principle, you can read the algorithms and tell whether or not History-Info (as we have defined it), processed by the presented algorithm, does what the use case needs.  If it *does*, then we know that History-Info captures enough information for the use case.

Dale
________________________________________
From: Shida Schubert [[email-masked]]
Sent: Sunday, July 10, 2011 3:08 AM
To: Worley, Dale R (Dale)
Cc: Cullen Jennings; [email-masked] WG
Subject: Re: [sipcore] draft-barnes-sipcore-rfc4244bis

Hi Dale;

 Regards
  Shida