Subject: Re: [sipcore] Updates to 4244bis-05

From: Shida Schubert <[email-masked]>
Date: Sun, 10 Jul 2011 16:08:49 +0900

Hi Dale;

 It's not for backward compatibility.

 We couldn't come up with reason why reason should 
be included in case of 2xx responses.

 Mary presented the proposed changes at the last 
meeting and people agreed to the changes.

 Can you think of a good reason why we should revert 
the changes, if so please let us know.

 Regards
  Shida 

On Jun 23, 2011, at 5:06 AM, Worley, Dale R (Dale) wrote:

> ________________________________________
> From: [email-masked] [[email-masked]] On Behalf Of Mary Barnes [[email-masked]]
> 
> 2) Updated section 9.3 (receiving responses) to also include timeouts and updated to reflect that we don't add the Reason header in the case of 2xx responses.
> ________________________________________
> 
> Can you tell me the design considerations for why Reason is not used in the case of 2xx responses?  (Is it for backward compatibility?)
> 
> Dale
> _______________________________________________
> sipcore mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sipcore

---

From: "Worley, Dale R (Dale)" <[email-masked]>
Date: Mon, 11 Jul 2011 14:56:30 -0400

________________________________________
From: Shida Schubert [[email-masked]]

Of course, there is always the attraction of handling as many cases as possible uniformly.

But given that the only case in which the Reason is admitted is 2xx, and all 2xx's are largely created
equal, leaving them off has few disadvantages.

There might be cases when a 2xx carries a Reason showing a success code from a downstream
gateway.

Dale