Subject: Re: [sipcore] Barry Leiba's No Objection on draft-ietf-sipcore-priority-00: (with COMMENT)

From: Robert Sparks <[email-masked]>
Date: Wed, 09 Jan 2013 13:31:18 -0600

SIPCORE WG -

At the urging of a few ADs, I'd like to capture a brief statement of 
_why_ the working
group chose IETF Review for this registry over a lighter-weight 
mechanism. Would
anyone object to adding this text to the IANA registration section:

"This policy was chosen over lighter-weight policies due the potential 
architectural impact of the semantics associated with new values. 
Efforts considering adding a Priority value should consider whether the 
SIP Resource-Priority or even a different protocol would be more 
appropriate for achieving their requirements."

Please respond ASAP.

RjS

On 1/8/13 11:13 AM, Barry Leiba wrote:
> Barry Leiba has entered the following ballot position for
> draft-ietf-sipcore-priority-00: No Objection
>
> When responding, please keep the subject line intact and reply to all
> email addresses included in the To and CC lines. (Feel free to cut this
> introductory paragraph, however.)
>
>
> Please refer to http://www.ietf.org/iesg/statement/discuss-criteria.html
> for more information about IESG DISCUSS and COMMENT positions.
>
>
>
>
> ----------------------------------------------------------------------
> COMMENT:
> ----------------------------------------------------------------------
>
> I support Russ's DISCUSS, but it's trivial to fix and discussion has
> already converged on that.
>
> The shepherd writeup says this:
>
>      The policy for adding new values to the registry was intentionally
>      chosen to be IETF Review. We do not anticipate many additions, and
>      feel this level of review will ensure that any such additions are
>      well considered.
>
> I have discussed this with Robert, and am happy to clear my DISCUSS on it
> (having had the discussion) and move it to a non-blocking comment.  Our
> discussion made it clear that there have been problems with attempts to
> use this header field, that scrutiny of the usage proposals is important,
> and that a single expert isn't appropriate because conversation within
> the SIP community is often important in teasing out issue with
> proposals.
>
> That said, if you can find a way to put a paragraph explaining that into
> the document, as an explanation to and a warning to those who might want
> to mint new values for this header field, I think it would be useful.  I
> don't think it should take much, though I understand that there are
> political land mines that you'll want to step around as you do it.
>
> And remember that this is non-blocking, so if you really can't see a good
> way to say it I'm not going to insist further.
>
>

---

From: Richard Barnes <[email-masked]>
Date: Wed, 9 Jan 2013 18:27:55 -0500

That text looks fine to me.  I think it summarizes the consensus of the group well.
--Richard 

On Jan 9, 2013, at 2:31 PM, Robert Sparks <[email-masked]> wrote:

> SIPCORE WG -
> 
> At the urging of a few ADs, I'd like to capture a brief statement of _why_ the working
> group chose IETF Review for this registry over a lighter-weight mechanism. Would
> "This policy was chosen over lighter-weight policies due the potential architectural impact of the semantics associated with new values. Efforts considering adding a Priority value should consider whether the SIP Resource-Priority or even a different protocol would be more appropriate for achieving their requirements."
> 
> Please respond ASAP.
> 
> RjS
> 
> 
> _______________________________________________
> sipcore mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sipcore

---

From: Adam Roach <[email-masked]>
Date: Wed, 09 Jan 2013 17:30:50 -0600

It sounds fine to me as well.

/a

---

From: Gonzalo Salgueiro <[email-masked]>
Date: Wed, 9 Jan 2013 18:34:34 -0500

The suggested text sounds perfectly reasonable to me.

Cheers,

Gonzalo

---

From: James Polk <[email-masked]>
Date: Wed, 09 Jan 2013 22:53:36 -0600

At 01:31 PM 1/9/2013, Robert Sparks wrote:
>"This policy was chosen over lighter-weight policies due the 
>potential architectural impact of the semantics associated with new 
>values. Efforts considering adding a Priority value should consider 
>whether the SIP Resource-Priority

...[RFC4412]...

>or even a different protocol would be more appropriate for achieving 
>their requirements."

I'm fine with the above reference added.

James

---

From: "Rosen, Brian" <[email-masked]>
Date: Thu, 10 Jan 2013 09:25:09 -0500

Very good idea.  

Brian

---

From: Janet P Gunn <[email-masked]>
Date: Thu, 10 Jan 2013 09:39:52 -0500

I am fine with it, including James's comment.

I just think the wording is terribly ironic considering the hoops we had 
to jump through to show that we needed "Resource Priority", and that 
"Priority" wasn't enough.

Janet

[email-masked] wrote on 01/09/2013 11:53:36 PM:

> From: James Polk <[email-masked]>
> To: Robert Sparks <[email-masked]>, <[email-masked]>, 
> "[email-masked]" <[email-masked]>
> Date: 01/09/2013 11:53 PM
> Subject: Re: [sipcore] Barry Leiba's No Objection on draft-ietf-
> sipcore-priority-00: (with COMMENT)
> Sent by: [email-masked]
> 
> >>Please refer to 
http://www.ietf.org/iesg/statement/discuss-criteria.html