Subject: [sipcore] question about B2B and Forking

From: Ofer Goren <[email-masked]>
Date: Tue, 19 Feb 2013 13:02:23 +0000

Hi All.
I know B2B behavior is not defined with too much details in the relevant SIP RFCs. I do ask for your opinion:
In forking scenarios, if B2B forks an INVITE to several UAS-es, should it forward downstream all the provisional responses to the generating UAC? Or, should it forward only one," absorbing" the rest? Should it even wait for provisional responses, or should it generates its own toward the UAC, independent to the upstream side of the session?
If it should forward all provisional responses downstream, it in fact creates several early dialogs for which it should also handle transactions such as PRACK (in case of reliable provisional responses), or UPDATEs and such.

So what do you think a B2B should do?

Thanks!
Ofer

_______________________________________________________________
If you lend someone $20, and never see that person again, it was probably worth the investment.

---

From: "Roy, Radhika R CIV USARMY (US)" <[email-masked]>
Date: Tue, 19 Feb 2013 15:17:46 +0000

Classification: UNCLASSIFIED
Caveats: NONE

Ofer:

In this case it not B2BUA spec per se. It will be rather specific to
"Forking Specifications using B2BUA." If we want to have a interoperable
implementation of forking using B2BUA. Is it really needed?

BR/Radhika

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Ofer Goren
Sent: Tuesday, February 19, 2013 8:02 AM
To: [email-masked]
Subject: [sipcore] question about B2B and Forking

Hi All.

I know B2B behavior is not defined with too much details in the relevant SIP
RFCs. I do ask for your opinion:

In forking scenarios, if B2B forks an INVITE to several UAS-es, should it
forward downstream all the provisional responses to the generating UAC? Or,
should it forward only one," absorbing" the rest? Should it even wait for
provisional responses, or should it generates its own toward the UAC,
independent to the upstream side of the session?

If it should forward all provisional responses downstream, it in fact
creates several early dialogs for which it should also handle transactions
such as PRACK (in case of reliable provisional responses), or UPDATEs and
such. 

Thanks!

Ofer

If you lend someone $20, and never see that person again, it was probably
worth the investment. 

Classification: UNCLASSIFIED
Caveats: NONE

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 19 Feb 2013 11:23:40 -0500

On 2/19/13 8:02 AM, Ofer Goren wrote:
> In forking scenarios, if B2B forks an INVITE to several UAS-es, should
> it forward downstream all the provisional responses to the generating
> UAC? Or, should it forward only one,” absorbing” the rest? Should it
> even wait for provisional responses, or should it generates its own
> toward the UAC, independent to the upstream side of the session?
>
> creates several early dialogs for which it should also handle
> transactions such as PRACK (in case of reliable provisional responses),
> or UPDATEs and such.
>

These are all design decisions for you when building your B2BUA.
The answers depend upon your goals/objectives.

	Good Luck,
	Paul

---

From: Ofer Goren <[email-masked]>
Date: Wed, 20 Feb 2013 17:53:50 +0000

Hi Roy.
This is exactly my question: is it needed. It looks like it might be, but I cannot understand why would anybody wants to do that. It either a B2BUA, in that case it holds a state machine for each call created on each side, OR it is a proxy forwarding transactions from side to side. I don't understand why anyone would like to mix the behavior, but I can't find anything in the specs prohibit it.

Ofer.

-----Original Message-----
From: Roy, Radhika R CIV USARMY (US) [mailto:[email-masked]] 
Sent: Tuesday, February 19, 2013 5:18 PM
To: Ofer Goren
Cc: [email-masked]
Subject: RE: question about B2B and Forking (UNCLASSIFIED)

Ofer:

BR/Radhika

-----Original Message-----

Hi All.

Thanks!

Ofer