Subject: [sipcore] Multiple P-Access-Network-Info header in the same SIP request

From: Surya Yarramilli <[email-masked]>
Date: Mon, 4 Nov 2013 08:48:12 -0800 (PST)

Hi,

According to RFC specification this header(PANI) should be a single valued header, while in 3GPP specification, this header is defined as multiple valued header. 

Normally we build our software following SIP RFC specification. Actually even inside the 3GPP specification the same RFC specification also has been referenced.
But there are differences between 3GPP spec and the RFC even though the 3GPP spec references the same RFC.  So clearly there is an ambiguity here.

Could you bring some clarity on the SIP RFC spec and  3GPP spec?

Thanks and Regards,

Surya Yarramilli | Principal Software Engineer
ORACLE

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Mon, 4 Nov 2013 18:08:46 +0000

Are you referring to RFC3455 or to https://datatracker.ietf.org/doc/draft-drage-sipping-rfc3455bis/

Release 12 of 3GPP is referencing the latter document.

regards

Keith

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of Surya Yarramilli
Sent: 04 November 2013 16:48
To: [email-masked]
Subject: [sipcore] Multiple P-Access-Network-Info header in the same SIP request

Hi,

Thanks and Regards,

---

From: Brett Tate <[email-masked]>
Date: Mon, 4 Nov 2013 18:42:07 +0000

Hi,

The P-Access-Network-Info ABNF within rfc3455bis is not backwards compatible to RFC 3455 concerning allowing multiple P-Access-Network-Info headers and/or COMMA separated entries.  Does 3GPP provide a mechanism to avoid potential interoperability issues?

Thanks,
Brett

----

draft-drage-sipping-rfc3455bis-09:

    P-Access-Network-Info  = "P-Access-Network-Info" HCOLON
                                  access-net-spec *(COMMA access-net-spec)
         access-net-spec        = (access-type / access-class)
                                  *(SEMI access-info)

RFC 3455:

      P-Access-Network-Info  = "P-Access-Network-Info" HCOLON
                               access-net-spec
      access-net-spec        = access-type *(SEMI access-info)

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Mon, 4 Nov 2013 18:51:50 +0000

No because 3GPP has always specified that that is allowed, thus overriding RFC 3455.

Keith 

> -----Original Message-----
> From: Brett Tate [mailto:[email-masked]] 
> Sent: 04 November 2013 18:42
> To: DRAGE, Keith (Keith); Surya Yarramilli; [email-masked]
> Subject: RE: [sipcore] Multiple P-Access-Network-Info header 
> in the same SIP request
> 
> Hi,
> 
> The P-Access-Network-Info ABNF within rfc3455bis is not 
> backwards compatible to RFC 3455 concerning allowing multiple 
> P-Access-Network-Info headers and/or COMMA separated entries. 
>  Does 3GPP provide a mechanism to avoid potential 
> interoperability issues?
> 
> Thanks,
> Brett
> 
> ----
>

---

From: Mary Barnes <[email-masked]>
Date: Mon, 4 Nov 2013 14:14:26 -0600

That's fine if it works for you all, but that doesn't mean you don't need
to at least document this change in the section that summarizes the changes
made in 3455bis.  You should actually address the backwards compatibility
issue in a sentence highlighting that this is okay because that's what 3GPP
has been doing (which I think implies that there was an error in RFC 3455).

Mary.
As document shepherd

On Mon, Nov 4, 2013 at 12:51 PM, DRAGE, Keith (Keith) <
[email-masked]> wrote:

> _______________________________________________
> sipcore mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sipcore
>

---

From: Brett Tate <[email-masked]>
Date: Mon, 4 Nov 2013 20:35:15 +0000

Hi,

The P-Charging-Function-Addresses header has a similar ABNF backward compatibility issue between the RFC 3455 and rfc3455bis.

Thanks,
Brett

From: Mary Barnes [mailto:[email-masked]]
Sent: Monday, November 04, 2013 3:14 PM
To: DRAGE, Keith (Keith)
Cc: Brett Tate; Surya Yarramilli; [email-masked]
Subject: Re: [sipcore] Multiple P-Access-Network-Info header in the same SIP request

That's fine if it works for you all, but that doesn't mean you don't need to at least document this change in the section that summarizes the changes made in 3455bis.  You should actually address the backwards compatibility issue in a sentence highlighting that this is okay because that's what 3GPP has been doing (which I think implies that there was an error in RFC 3455).

Mary.
As document shepherd

On Mon, Nov 4, 2013 at 12:51 PM, DRAGE, Keith (Keith) <[email-masked]<mailto:[email-masked]>> wrote:
No because 3GPP has always specified that that is allowed, thus overriding RFC 3455.

Keith

> From: Brett Tate [mailto:[email-masked]<mailto:[email-masked]>]
> To: DRAGE, Keith (Keith); Surya Yarramilli; [email-masked]<mailto:[email-masked]>
_______________________________________________
sipcore mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/sipcore

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Tue, 5 Nov 2013 18:32:27 +0000

RFC 3455 is probably not implemented. RFC 3455 as enhanced by 3GPP TS 24.229 is.

the document rfc3455bis is the document that is meant to bring these things back into IETF and corrects these issues, unless you know otherwise. This document will be referenced by 3GPP release 12.

Keith

________________________________
From: Surya Yarramilli [mailto:[email-masked]]
Sent: 05 November 2013 18:25
To: DRAGE, Keith (Keith); [email-masked]
Subject: RE: [sipcore] Multiple P-Access-Network-Info header in the same SIP request

Hi Keith,

I'm referring to RFC 3455, RFC3261 and 3GPP TS24.229(R7, v7.31.0,latest), P-ANI header is extended as below and it follows  the grammar stated RFC3261, and thus P-ANI is supporting multiple rows in R7 v7.31.0.

But as per RFC 3455 and RFC3261 only 1 P-ANI header is allowed. Does it require any correction in SIP RFCs?

BR,
Surya

From: DRAGE, Keith (Keith) [mailto:[email-masked]]
Sent: Monday, November 04, 2013 11:39 PM
To: Surya Yarramilli; [email-masked]
Subject: RE: [sipcore] Multiple P-Access-Network-Info header in the same SIP request

regards

Keith

________________________________
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Surya Yarramilli
Sent: 04 November 2013 16:48
To: [email-masked]<mailto:[email-masked]>
Subject: [sipcore] Multiple P-Access-Network-Info header in the same SIP request
Hi,

Thanks and Regards,

---

From: Surya Yarramilli <[email-masked]>
Date: Tue, 5 Nov 2013 10:25:18 -0800 (PST)

Hi Keith,

BR,

Surya

regards

Keith

  _____  

From: HYPERLINK "mailto:[email-masked]"[email-masked] [mailto:[email-masked]] On Behalf Of Surya Yarramilli
Sent: 04 November 2013 16:48
To: HYPERLINK "mailto:[email-masked]"[email-masked]
Subject: [sipcore] Multiple P-Access-Network-Info header in the same SIP request

Hi,

Thanks and Regards,

---

From: [email-masked] (Dale R. Worley)
Date: Wed, 6 Nov 2013 14:59:08 -0500 (EST)

> From: "DRAGE, Keith (Keith)" <[email-masked]>
> 

[That] may not be backward-compatible with the specification, but it
is backward-compatible with reality.  -- Francois Audet

Dale