Subject: Re: [sipcore] IPv6 in the sip core wg

From: Adam Roach <[email-masked]>
Date: Tue, 21 Jan 2014 16:17:17 -0600

It's really quite silly that we're blocked on a trivial matter of 
terminology here. Grabbing my thesaurus, I suggest:

      June 2014  Request publication of procedures to amend RFC3263
      and RFC6157 for dual-stack client and server handling of SIP URIs
      containing domain names (PS)

Does that work for everyone?

/a

On 12/18/13 11:12, Paul Kyzivat wrote:
> On 12/17/13 6:54 PM, DRAGE, Keith (Keith) wrote:
>> I said in a previous mail that I would like to avoid the use of the 
>> word "supplement" and did suggest alternative wording. My reason is 
>> that some SDOs treat the word "supplement" as identifying informative 
>> material, and given that you want reuse in other SDOs it is best not 
>> to confuse the issue.
>
> I don't see why that should prevent us from using "supplement" in this 
> context. We can have that discussion again if the word is used in a 
> draft, but I don't see why it's a concern there either. (The 
> definitive indication is whether the RFC is standards track, and the 
> normative language in the draft.)
>
>> In any case I don't think we need to bring out in either the title or 
>> the milestone the exact relationship with RFC 3263, only that one 
>> exists. Defining that relationship more accurately belongs to the 
>> abstract.
>
> My latest proposal was:
>
>      June 2014  Request publication of procedures to supplement RFC3263
>      and RFC6157 for dual-stack client and server handling of SIP URIs
>      containing domain names (PS)
>
> Your earlier proposal was: "Use of RFC 3263 in dual-stack devices".
>
> RFC6157 already addresses dual-stack devices. What we are trying to 
> deal with is that 3263 and 6157 are insufficient and/or wrong for 
> dual-stack clients. I see no way to avoid using *some* verb - 
> supplement, update, clarify, expand, ...
>
> Feel free to offer something that addresses both your concerns and the 
> others that have been raised.
>
>     Thanks,
>     Paul
>
>
>> Keith
>>
>>> -----Original Message-----
>>> From: Paul Kyzivat [mailto:[email-masked]]
>>> Sent: 16 December 2013 20:01
>>> To: Cullen Jennings (fluffy)
>>> Cc: Gonzalo Salgueiro (gsalguei); DRAGE, Keith (Keith);
>>> SIPCORE WG; Olle E. Johansson
>>> Subject: Re: [sipcore] IPv6 in the sip core wg
>>>
>>> On 12/16/13 2:33 PM, Cullen Jennings (fluffy) wrote:
>>>>
>>>> On Dec 13, 2013, at 9:28 AM, Paul Kyzivat
>>> <[email-masked]> wrote:
>>>>
>>>>> Having said that, I suggest the following as the milestone:
>>>>>
>>>>>      May 2014  WGLC of procedures to supplement RFC3263 for
>>> dual-stack
>>>>>      client and server handling of SIP URIs containing domain names
>>>>> (PS)
>>>>
>>>> Good with me. And if you want to change "WGLC of" to
>>> "Request publication of" that seems like it would fix the
>>> point Mary raised.
>>>
>>> OK. Latest candidate is:
>>>
>>>       June 2014  Request publication of procedures to
>>> supplement RFC3263
>>>       for dual-stack client and server handling of SIP URIs containing
>>>       domain names (PS)
>>>
>>> (I put back the extra month for Mary.)
>>>
>>> Richard - does this work for you?
>>>
>>>     Thanks,
>>>     Paul
>>>
>>>
>>>
>>>
>
> _______________________________________________
> sipcore mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sipcore

---

From: "Cullen Jennings (fluffy)" <[email-masked]>
Date: Tue, 21 Jan 2014 22:24:49 +0000

No, that implies that 3263 and 6157 are wrong and products that implement need to change - If you want that milestone, first you need to be able be clear about what is wrong with 3263 or 6157.  How about 

> June 2014  Request publication of procedures for dual-stack client and server handling of SIP URIs

On Jan 21, 2014, at 3:17 PM, Adam Roach <[email-masked]> wrote:

> It's really quite silly that we're blocked on a trivial matter of terminology here. Grabbing my thesaurus, I suggest:
> 
>>> I said in a previous mail that I would like to avoid the use of the word "supplement" and did suggest alternative wording. My reason is that some SDOs treat the word "supplement" as identifying informative material, and given that you want reuse in other SDOs it is best not to confuse the issue.
>> 
>> I don't see why that should prevent us from using "supplement" in this context. We can have that discussion again if the word is used in a draft, but I don't see why it's a concern there either. (The definitive indication is whether the RFC is standards track, and the normative language in the draft.)
>> 
>>> In any case I don't think we need to bring out in either the title or the milestone the exact relationship with RFC 3263, only that one exists. Defining that relationship more accurately belongs to the abstract.
>> 
>> My latest proposal was:
>> 
>> RFC6157 already addresses dual-stack devices. What we are trying to deal with is that 3263 and 6157 are insufficient and/or wrong for dual-stack clients. I see no way to avoid using *some* verb - supplement, update, clarify, expand, ...
>> 
>> Feel free to offer something that addresses both your concerns and the others that have been raised.
>> 
>>    Thanks,
>>    Paul
>> 
>> 
>>> Keith
>>>

---

From: Adam Roach <[email-masked]>
Date: Tue, 21 Jan 2014 16:40:43 -0600

>> June 2014  Request publication of procedures for dual-stack client and server handling of SIP URIs

That runs the risk of being confused with what 6157 already does. How about:

    June 2014 Request publication of Happy Eyeballs procedures for 
handling of SIP URIs

Which seems a fair summary of what Olle and Gonzalo's current document 
intends to do.

/a

---

From: "Cullen Jennings (fluffy)" <[email-masked]>
Date: Tue, 21 Jan 2014 22:42:57 +0000

works for me

On Jan 21, 2014, at 3:40 PM, Adam Roach <[email-masked]> wrote:

>   June 2014 Request publication of Happy Eyeballs procedures for handling of SIP URIs
> 
> Which seems a fair summary of what Olle and Gonzalo's current document intends to do.
> 
> /a

---

From: "Gonzalo Salgueiro (gsalguei)" <[email-masked]>
Date: Tue, 21 Jan 2014 22:44:42 +0000

+1

-G

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 21 Jan 2014 20:29:35 -0500

I'm ok with this if it settles the rift.

	Paul

---

From: "Olle E. Johansson" <[email-masked]>
Date: Wed, 22 Jan 2014 07:12:08 +0100

> I'm ok with this if it settles the rift.
Me too.

/O
>>>> Which seems a fair summary of what Olle and Gonzalo's current document intends to do.

---
* Olle E Johansson - [email-masked]
* Cell phone +46 70 593 68 51, Office +46 8 96 40 20, Sweden

---

From: "Vijay K. Gurbani" <[email-masked]>
Date: Wed, 22 Jan 2014 09:41:44 -0600

> I'm ok with this if it settles the rift.

I liked Paul's original text better, and I suspected that there
was some consensus to it, no?

In any case, it is not worth having another debate that holds up
progress.  Whether or not draft-johansson-sip-dual-stack updates
only rfc3263 or updates both rfc3253 and rfc6157 can be determined
as the work progresses.

As such, if folks are happy with "Request publication of Happy Eyeballs
procedures for handling of SIP URIs" then lets proceed.

Thanks,

- vijay
-- 
Vijay K. Gurbani, Bell Laboratories, Alcatel-Lucent
1960 Lucent Lane, Rm. 9C-533, Naperville, Illinois 60563 (USA)
Email: vkg@{bell-labs.com,acm.org} / [email-masked]
Web: http://ect.bell-labs.com/who/vkg/  | Calendar: http://goo.gl/x3Ogq

---

From: [email-masked] (Dale R. Worley)
Date: Wed, 22 Jan 2014 21:29:43 -0500 (EST)

> From: "Vijay K. Gurbani" <[email-masked]>

> procedures for handling of SIP URIs" then lets proceed.

Whatever gets the work on the calendar is good.  The exact
characterization of the output product will only become certain as we
complete the work.

Dale