Subject: Re: [sipcore] draft-sparks-sipcore-refer-clarifications-00 is available

From: Andrew Allen <[email-masked]>
Date: Wed, 2 Jul 2014 18:22:25 +0000

I support this draft and progressing it as a WG item.

One comment - i think a UA that supports receiving REFER  needs to include a GRUU as a Contact in INVITE requests so that the sender of the REFER has a GRUU to target the REFER at. This should be specified in the draft.

Andrew

----- Original Message -----
From: Robert Sparks [mailto:[email-masked]]
Sent: Monday, June 16, 2014 04:18 PM Eastern Standard Time
To: [email-masked] <[email-masked]>
Subject: [sipcore] draft-sparks-sipcore-refer-clarifications-00 is available

To continue the conversation started in the London meeting, see
<http://datatracker.ietf.org/doc/draft-sparks-sipcore-refer-clarifications/>

RjS

_______________________________________________
sipcore mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/sipcore

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 3 Jul 2014 15:12:32 +0000

Hi,

Regarding GRUU, if we move forward with 'Require:explicitsub', why would a UA need to include a GRUU in the REFER Contact? It now *knows* that no implicit subscription will be created.

Regards,

Chrsiter

---

From: Andrew Allen <[email-masked]>
Date: Thu, 3 Jul 2014 15:19:52 +0000

Christer

This is not the case. According to the no refer sub RFC support of the norefersub mechanism does not mean that a UAS has to accept the request not to create a subscription. It can still decide to create the subscription according to the RFC.

Andrew

----- Original Message -----
From: Christer Holmberg [mailto:[email-masked]]
Sent: Thursday, July 03, 2014 11:12 AM Eastern Standard Time
To: Paul Kyzivat <[email-masked]>; [email-masked] <[email-masked]>
Subject: Re: [sipcore] draft-sparks-sipcore-refer-clarifications-00 is available

Hi,

Regards,

Chrsiter

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 03 Jul 2014 11:20:19 -0400

> Regarding GRUU, if we move forward with 'Require:explicitsub', why would a UA need to include a GRUU in the REFER Contact? It now *knows* that no implicit subscription will be created.

IIUC, there would be no *special* requirement on the contact in those 
cases where Require:explicitsub is used.

BUT, recall that 3261 has *always* required that contact URIs be 
globally routable!

	Thanks,
	Paul

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 3 Jul 2014 15:28:51 +0000

Hi Andrew,

I am not talking about norefersub, but explicitsub - the other draft the Robert submitted.

Regards,

Christer

________________________________________
From: Andrew Allen [[email-masked]]
Sent: Thursday, 03 July 2014 6:19 PM
To: Christer Holmberg; [email-masked]; [email-masked]
Subject: Re: [sipcore] draft-sparks-sipcore-refer-clarifications-00 is available

Christer

Andrew

----- Original Message -----
From: Christer Holmberg [mailto:[email-masked]]
Sent: Thursday, July 03, 2014 11:12 AM Eastern Standard Time
To: Paul Kyzivat <[email-masked]>; [email-masked] <[email-masked]>
Subject: Re: [sipcore] draft-sparks-sipcore-refer-clarifications-00 is available

Hi,

Regards,

Chrsiter

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 03 Jul 2014 11:30:33 -0400

> This is not the case. According to the no refer sub RFC support of the norefersub mechanism does not mean that a UAS has to accept the request not to create a subscription. It can still decide to c…

Christer was asking about explicitsub. (From new draft by Robert.)