Subject: [sipcore] Fwd: New Version Notification for draft-johansson-sip-dual-stack-03.txt

From: "Olle E. Johansson" <[email-masked]>
Date: Mon, 6 Oct 2014 15:43:12 +0200

Hi!
Just updated the version number to make this draft active again.

During SIPit31 last week we confirmed the issues mentioned in the draft, but also discovered a new issue. 

This may not be directly SIP related but important for developers:

We added a few IPv6 ULA networks to the SIPit LAN. It seemed like multiple network addresses apart from one global and one link-local had not been tested by the developers before. We noticed that implementations had problems selecting candidates for ICE as well as selecting source IP address. I added a SIP proxy on a ULA address and it could not be reached. Aside from that, the proxy itself had issues selecting source address (with a more than ten year old IPv6 implementation). It made it very clear to participants that "one interface, one address" does no longer apply.

Cheers,
/O

Begin forwarded message:

> From: [email-masked]
> Subject: New Version Notification for draft-johansson-sip-dual-stack-03.txt
> Date: 6 Oct 2014 15:27:14 GMT+2
> To: "Gonzalo Salgueiro" <[email-masked]>, Olle E. Johansson <[email-masked]>, "Olle E. Johansson" <[email-masked]>, Gonzalo Salgueiro <[email-masked]>
> 
> 
> A new version of I-D, draft-johansson-sip-dual-stack-03.txt
> has been successfully submitted by Olle E. Johansson and posted to the
> IETF repository.
> 
> Name:		draft-johansson-sip-dual-stack
> Revision:	03
> Title:		Locating Session Initiation Protocol (SIP) Servers in a Dual-Stack IP Network
> Document date:	2014-10-06
> Group:		Individual Submission
> Pages:		6
> URL:            http://www.ietf.org/internet-drafts/draft-johansson-sip-dual-stack-03.txt
> Status:         https://datatracker.ietf.org/doc/draft-johansson-sip-dual-stack/
> Htmlized:       http://tools.ietf.org/html/draft-johansson-sip-dual-stack-03
> Diff:           http://www.ietf.org/rfcdiff?url2=draft-johansson-sip-dual-stack-03
> 
> Abstract:
>   RFC 3263 defines how a Session Initiation Protocol (SIP)
>   implementation, given a SIP Uniform Resource Identifier (URI), should
>   locate the next hop SIP server using Domain Name System (DNS)
>   procedures.  The specification repeatedly states that the
>   implementation should look up IPv4 or IPv6 addresses.  This is not a
>   suitable solution and one that can cause severely degraded user
>   experience dual-stack clients, as detailed in the Happy Eyeballs
>   specification.  This document specifies amended procedures for dual-
>   stack SIP implementations so that they look up both IPv4 and IPv6
>   addresses.  This way, the SIP implementation can find the preferred
>   network path and protocol with an improved chance of successfully
>   reaching the desired service.  This document also clarifies DNS SRV
>   usage for single-stack clients.
> 
> 
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat
>

---

From: "Olle E. Johansson" <[email-masked]>
Date: Mon, 6 Oct 2014 16:33:24 +0200

> Just updated the version number to make this draft active again.
Which was a stupid thing, since it's replaced by draft-ietf-sipcore-dns-dual-stack-00.

Life.

/O
> _______________________________________________
> sipcore mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sipcore