Subject: [sipcore] Draft new: draft-holmberg-dispatch-pani-abnf-00 [was: [dispatch] [Technical Errata Reported] RFC7315 (4474)]

From: Christer Holmberg <[email-masked]>
Date: Sun, 18 Oct 2015 11:49:21 +0000

Hi,

Based on Ben’s guidance, I’ve submitted a draft which makes the ABNF update.

NOTE: As RFC 7315 is an Informational RFC, I had to add the RFC as an Informative reference in the draft, in order to pass the Idnits check.

A new version of I-D, draft-holmberg-dispatch-pani-abnf-00.txt

has been successfully submitted by Christer Holmberg and posted to the IETF repository.

Name:                 draft-holmberg-dispatch-pani-abnf

Revision:            00

Title:                    P-Access-Network-Info ABNF Update

Document date:              2015-10-18

Group:                Individual Submission

Pages:                 4

URL:            https://www.ietf.org/internet-drafts/draft-holmberg-dispatch-pani-abnf-00.txt

Status:         https://datatracker.ietf.org/doc/draft-holmberg-dispatch-pani-abnf/

Htmlized:       https://tools.ietf.org/html/draft-holmberg-dispatch-pani-abnf-00

Abstract:

   This document updates RFC 7315, by modifying the extension-access-

   info part of the P-Access-Network-Info header field Augmented Backus-

   Naur Form (ABNF).

Regards,

Christer

From: sipcore [mailto:[email-masked]] On Behalf Of Christer Holmberg
Sent: 18 October 2015 10:52
To: Ben Campbell <[email-masked]>
Cc: DISPATCH list <[email-masked]>; SIPCORE <[email-masked]>; Cullen Jennings <[email-masked]>
Subject: Re: [sipcore] [dispatch] [Technical Errata Reported] RFC7315 (4474)

Hi,

So, shall I address the draft to some WG, or?

draft-holmberg-dispatch ?

Regards,

Christer

Sent from my Windows Phone
________________________________
From: Ben Campbell<mailto:[email-masked]>
Sent: ‎14/‎10/‎2015 17:21
To: Christer Holmberg<mailto:[email-masked]>
Cc: Cullen Jennings<mailto:[email-masked]>; DISPATCH list<mailto:[email-masked]>; SIPCORE<mailto:[email-masked]>
Subject: Re: [sipcore] [dispatch] [Technical Errata Reported] RFC7315 (4474)
On 8 Oct 2015, at 21:03, Christer Holmberg wrote:

> Hi Cullen,
>
> So, you are suggesting a SIPCORE draft that updates the ABNF?

This is where the chairs will point out that special-purpose extensions
are generally not in scope for sipcore :-) If so, this might could also
be done as AD sponsored.

Ben.

---

From: "Ben Campbell" <[email-masked]>
Date: Sun, 18 Oct 2015 13:27:03 -0500

If 7315 is informational, why does the update need to be standards 
track?

Ben.

On 18 Oct 2015, at 6:49, Christer Holmberg wrote:

> NOTE: As RFC 7315 is an Informational RFC, I had to add the RFC as an 
> Informative reference in the draft, in order to pass the Idnits check.
>
>
> URL:            
> https://www.ietf.org/internet-drafts/draft-holmberg-dispatch-pani-abnf-00.txt
>
> Status:         
> https://datatracker.ietf.org/doc/draft-holmberg-dispatch-pani-abnf/
>
> Htmlized:       
> https://tools.ietf.org/html/draft-holmberg-dispatch-pani-abnf-00
>
>
>
>
>
> Abstract:
>
> Cc: Cullen Jennings<mailto:[email-masked]>; DISPATCH 
> list<mailto:[email-masked]>; SIPCORE<mailto:[email-masked]>

---

From: Christer Holmberg <[email-masked]>
Date: Sun, 18 Oct 2015 18:59:09 +0000

Hi,

>If 7315 is informational, why does the update need to be standards track?

Good point - I guess it doesn't have to :)

Regards,

Christer

On 18 Oct 2015, at 6:49, Christer Holmberg wrote:

> This is where the chairs will point out that special-purpose 
> extensions are generally not in scope for sipcore :-) If so, this 
> might could also be done as AD sponsored.
>
> Ben.

---

From: Christer Holmberg <[email-masked]>
Date: Sun, 18 Oct 2015 19:10:20 +0000

Hi,

I've submitted a new version, -01, where the category is changed to 'Informational'.

Regards,

Christer

-----Original Message-----
From: dispatch [mailto:[email-masked]] On Behalf Of Christer Holmberg
Sent: 18 October 2015 21:59
To: Ben Campbell <[email-masked]>
Cc: DISPATCH list <[email-masked]>; SIPCORE <[email-masked]>
Subject: Re: [dispatch] Draft new: draft-holmberg-dispatch-pani-abnf-00 [was: [sipcore] [Technical Errata Reported] RFC7315 (4474)]

Hi,

Regards,

Christer

> Sent from my Windows Phone
_______________________________________________
dispatch mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dispatch

---

From: Cullen Jennings <[email-masked]>
Date: Thu, 22 Oct 2015 18:03:10 -0600

I read the draft and looks pretty simple to me. Hope we can move this quickly. 

> On Oct 18, 2015, at 1:10 PM, Christer Holmberg <[email-masked]> wrote:
> 
> Hi,
>

---

From: "A. Jean Mahoney" <[email-masked]>
Date: Tue, 27 Oct 2015 16:45:54 -0500

Hi Christer,

The draft looks good to me. Just a few nits:

1. Introduction

2nd paragraph: "requires new values are required" => "requires new values".

4th paragraph: "have been followed" => "have been defined"

You may also consider adding a reference to TS 24.229, which defines 
values for access-info, to the 4th paragraph.

Thanks!

Jean

---

From: Christer Holmberg <[email-masked]>
Date: Tue, 27 Oct 2015 22:02:34 +0000

Hi Jean,

Thanks for your comments! I will update the draft according to your suggestions.

Regards,

Christer

-----Original Message-----
From: A. Jean Mahoney [mailto:[email-masked]] 
Sent: 27 October 2015 23:46
To: Christer Holmberg <[email-masked]>; Ben Campbell <[email-masked]>
Cc: DISPATCH list <[email-masked]>; SIPCORE <[email-masked]>
Subject: Re: [dispatch] Draft new: draft-holmberg-dispatch-pani-abnf-00 [was: [sipcore] [Technical Errata Reported] RFC7315 (4474)]

Hi Christer,

1. Introduction

You may also consider adding a reference to TS 24.229, which defines values for access-info, to the 4th paragraph.

Thanks!

Jean

On 10/18/15 2:10 PM, Christer Holmberg wrote:
> Subject: Re: [dispatch] Draft new: 
> draft-holmberg-dispatch-pani-abnf-00 [was: [sipcore] [Technical Errata 
> Reported] RFC7315 (4474)]
>
> Hi,
>
>> https://www.ietf.org/internet-drafts/draft-holmberg-dispatch-pani-abn
>> f
>> -00.txt
>>
>> Status:

---

From: Christer Holmberg <[email-masked]>
Date: Tue, 27 Oct 2015 22:15:44 +0000

Hi,

The new version can be seen at: https://github.com/cdh4u/draft-pani-abnf

I'll submit it when the submission window opens.

Regards,

Christer

-----Original Message-----
From: sipcore [mailto:[email-masked]] On Behalf Of Christer Holmberg
Sent: 28 October 2015 00:03
To: A. Jean Mahoney <[email-masked]>; Ben Campbell <[email-masked]>
Cc: DISPATCH list <[email-masked]>; SIPCORE <[email-masked]>
Subject: Re: [sipcore] [dispatch] Draft new: draft-holmberg-dispatch-pani-abnf-00 [was: [Technical Errata Reported] RFC7315 (4474)]

Hi Jean,

Regards,

Christer

-----Original Message-----
From: A. Jean Mahoney [mailto:[email-masked]]
Sent: 27 October 2015 23:46
To: Christer Holmberg <[email-masked]>; Ben Campbell <[email-masked]>
Cc: DISPATCH list <[email-masked]>; SIPCORE <[email-masked]>
Subject: Re: [dispatch] Draft new: draft-holmberg-dispatch-pani-abnf-00 [was: [sipcore] [Technical Errata Reported] RFC7315 (4474)]

Hi Christer,

1. Introduction

Thanks!

Jean

_______________________________________________
sipcore mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/sipcore

---

From: "A. Jean Mahoney" <[email-masked]>
Date: Tue, 27 Oct 2015 17:18:45 -0500

Thanks for the quick update! Looks good.

Jean