Subject: Re: [sipcore] sip/tcp with primary & secondary outbound proxies (behavior upon receipt of tcp rst)

From: "Penar, Russell" <[email-masked]>
Date: Tue, 2 Feb 2016 15:57:42 +0000

Thank you Dale, I will.  I appreciate the link as I am definitely new to the forum/process.
Should I draft using standard RFC template and then look to work that into an addendum to an existing RFC? I do want to follow process and gain support.

Regards,
Russ

-----Original Message-----
From: Dale R. Worley [mailto:[email-masked]]
Sent: Sunday, January 31, 2016 8:11 PM
To: Penar, Russell
Cc: [email-masked]
Subject: Re: [sipcore] sip/tcp with primary & secondary outbound proxies (behavior upon receipt of tcp rst)

"Penar, Russell" <[email-masked]> writes:
> While we agree on these informal best practices (including retrying
> primary target upon receipt of RST), it seems vendors aren't getting
> the memo and ideally these practices/behaviors would be included in an
> RFC for easy reference and less back and forth with vendors who chose
> wrong up front.

You could write an RFC covering what you want to see:
http://www.ietf.org/edu/documents/81IETF-New-Work.pdf

Dale
This communication is the property of CenturyLink and may contain confidential or privileged information. Unauthorized use of this communication is strictly prohibited and may be unlawful. If you have received this communication in error, please immediately notify the sender by reply e-mail and destroy all copies of the communication and any attachments.

---

From: [email-masked] (Dale R. Worley)
Date: Fri, 12 Feb 2016 14:28:17 -0500

"Penar, Russell" <[email-masked]> writes:
> Should I draft using standard RFC template and then look to work that
> into an addendum to an existing RFC? I do want to follow process and
> gain support.

Probably the best thing is to write a draft for a "best current
practice" RFC containing the various rules we've been talking about.
You can see from the list of RFCs
(https://www.rfc-editor.org/rfc-index.html) that a lot of them are "best
current practice".  I suspect that with further discussion you'll hear
of a lot of other rules that SIP implementors know but have never been
written down.  Circulate your draft in the Dispatch working to see what
people think.

Usually, people use XML2RFC to write RFCs.  The page to use that tool is
http://xml2rfc.tools.ietf.org/, it also contains links to most of the
documentation for it.

Dale