Subject: Re: [sipcore] [Technical Errata Reported] RFCs 3515, 5502, 5360, ...

From: Paul Kyzivat <[email-masked]>
Date: Fri, 1 Apr 2016 09:56:44 -0400

On 3/31/16 6:08 PM, Robert Sparks wrote:
> Again, I don't think errata is the right way to skin this.
> <http://mailarchive.ietf.org/arch/msg/sipcore/OZN1Eey88Ksex8fia20fCZH_8qE>

I agree that when in doubt a draft is the better path.

But in this case, I don't think a revision to 3261 would cover all the 
other documents out there that define header fields with this problem. 
It would still be necessary to update each of those documents to adopt 
the change.

But we could do one document that updates 3261 *and* each of the other 
affected documents. Then, in the future, any new header field where this 
should apply could simply normatively reference this document.

	Thanks,
	Paul

> RjS
>
> On 3/31/16 4:48 PM, Dale R. Worley wrote:
>> Brett Tate <[email-masked]> writes:
>>> I agree; that was why I sent the following email in October 2013 while
>>> sipcore was working on similar errata for RFC 3325.  I used that
>>> email and
>>> aspects of the RFC 3325 errata to produce the recent errata for RFC
>>> 3515,
>>> RFC 5002, RFC 5318, RFC 5360, and RFC 5502.  I have not check any
>>> headers
>>> register with IANA since October 2013.
>>>
>>> http://www.ietf.org/mail-archive/web/sipcore/current/msg05731.html
>> Why don't we put in an erratum that edits RFC 3261 section 20.10.  The
>> old text is:
>>
>>     Even if the "display-name" is empty, the "name-addr" form MUST be
>>     used if the "addr-spec" contains a comma, semicolon, or question
>>     mark.  There may or may not be LWS between the display-name and the
>>     "<".
>>
>> The new text adds:
>>
>>     In any header field whose value syntax is
>>         (name-addr / addr-spec) *(SEMI generic-param)
>>     or
>>         (name-addr / addr-spec) *(SEMI generic-param)
>>             *(COMMA (name-addr / addr-spec) *(SEMI generic-param))
>>     the "addr-spec" alternative may not be used if its value would
>>     contain a comma, semicolon, or question mark.
>>
>> In a sense, that's what everybody *thinks* RFC 3261 requires.
>>
>> Dale
>>
>> _______________________________________________
>> sipcore mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/sipcore
>
> _______________________________________________
> sipcore mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sipcore
>

---

From: Robert Sparks <[email-masked]>
Date: Sat, 2 Apr 2016 10:02:37 -0300

On 4/1/16 10:56 AM, Paul Kyzivat wrote:
> affected documents.
That's what my message said.
> Then, in the future, any new header field where this should apply 
> could simply normatively reference this document.
>
>     Thanks,
>     Paul
>
>> RjS
>>