Subject: [sipcore] Half outbound

From: "Olle E. Johansson" <[email-masked]>
Date: Fri, 17 Jun 2016 15:15:50 +0200

http://www.slideshare.net/oej/sip-half-outbound-random-notes

Trying to summarize - am I right?

- No one seems to oppose some work in this area
- No one seems to say “Yay” for Outbound and stop doing alternatives

As this is not an update to the core protocols, it seems like any draft that
can come out of this discussion needs to go to dispatch and follow
any route that group suggests.

Anyone that wants to join me in writing a first draft to start the process?

/O

---

From: "Neelakantan, Neel" <[email-masked]>
Date: Fri, 17 Jun 2016 13:18:44 +0000

Olle,

I am willing to help and contribute in this.  I know we discussed this in SIP Forums when the outbound came up.

Thanks,
Neel.

> -----Original Message-----
> From: sipcore [mailto:[email-masked]] On Behalf Of Olle E.
> Johansson
> Sent: Friday, June 17, 2016 8:16 AM
> To: SIPCORE <[email-masked]>
> Cc: Olle E Johansson <[email-masked]>
> Subject: [sipcore] Half outbound
> 
> As this is not an update to the core protocols, it seems like any draft that can
> come out of this discussion needs to go to dispatch and follow any route that
> group suggests.
> 
> _______________________________________________
> sipcore mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sipcore

---

From: "Olle E. Johansson" <[email-masked]>
Date: Fri, 17 Jun 2016 15:22:29 +0200

> On 17 Jun 2016, at 15:18, Neelakantan, Neel <[email-masked]> wrote:
> 
> Olle,
> 
Great! Welcome to the team :-)

I’ll start with writing an outline and committing to github and we’ll can take it from there.

Cheers,
/O

---

From: Paul Kyzivat <[email-masked]>
Date: Fri, 17 Jun 2016 10:48:36 -0400

> Anyone that wants to join me in writing a first draft to start the process?

I thought we had concluded that half-outbound isn't needed, because the 
existing outbound may be used with a single connection/flow if properly 
configured.

If people still don't want to do it, then maybe what we need is research 
into why.

	Thanks,
	Paul

---

From: "Olle E. Johansson" <[email-masked]>
Date: Fri, 17 Jun 2016 16:52:18 +0200

> On 17 Jun 2016, at 16:48, Paul Kyzivat <[email-masked]> wrote:
> 
> I thought we had concluded that half-outbound isn't needed, because the existing outbound may be used with a single connection/flow if properly configured.
> 
> If people still don't want to do it, then maybe what we need is research into why.

The SIPconnect team more or less refused to add outbound regardless on
how many times I pointed at it as the only solution. I hope they can answer!

So let’s take another round :-)

/O

---

From: Christer Holmberg <[email-masked]>
Date: Sat, 18 Jun 2016 09:02:40 +0000

Hi,

If you plan to bring this to DISPATCH, I suggest the following:

1. Don't call it "Half Outbound". It will people focus on the mechanism instead of what you actually want to achieve.

2. Write down a high-level use-case/call flow. Start by showing people what you want to do - not by showing what is wrong with existing mechanism (Outbound etc).

3. Based on the use-case/call-flow, write down a list of requirements. Again, leave the SIP protocol mechanism specifics out.

4. THEN you can start talking about protocol mechanisms. You can e.g. pick the parts of outbound that would fulfil the requirements. THAT you can call "half outbound".

5. If you are going to make statements like "people don't want to implement outbound", you really need some justification and background information. Otherwise people will just ask "how do you know people will implement this new mechanism?".

Regards,

Christer

-----Original Message-----
From: sipcore [mailto:[email-masked]] On Behalf Of Olle E. Johansson
Sent: 17 June 2016 17:52
To: Paul Kyzivat <[email-masked]>
Cc: [email-masked]; Olle E Johansson <[email-masked]>
Subject: Re: [sipcore] Half outbound

>> As this is not an update to the core protocols, it seems like any 
>> draft that can come out of this discussion needs to go to dispatch 
>> and follow any route that group suggests.
>> 

The SIPconnect team more or less refused to add outbound regardless on how many times I pointed at it as the only solution. I hope they can answer!

/O

---

From: "Olle E. Johansson" <[email-masked]>
Date: Sat, 18 Jun 2016 21:45:09 +0200

> On 18 Jun 2016, at 11:02, Christer Holmberg <[email-masked]> wrote:
> 
> 
> Hi,
> 
> 5. If you are going to make statements like "people don't want to implement outbound", you really need some justification and background information. Otherwise people will just ask "how do you know people will implement this new mechanism?”.

Great feedback, thank you!

/Olle

---

From: Ranjit Avasarala <[email-masked]>
Date: Sat, 18 Jun 2016 23:23:06 -0500

yes I agree - half outbound as a name does not sound appropriate - a more
meaningful name is better

Regards
Ranjit

On Sat, Jun 18, 2016 at 2:45 PM, Olle E. Johansson <[email-masked]> wrote:

> > 1. Don't call it "Half Outbound". It will people focus on the mechanism
> instead of what you actually want to achieve.
> >
> > 2. Write down a high-level use-case/call flow. Start by showing people
> what you want to do - not by showing what is wrong with existing mechanism
> (Outbound etc).
> >
> > 3. Based on the use-case/call-flow, write down a list of requirements.
> Again, leave the SIP protocol mechanism specifics out.
> >
> > 4. THEN you can start talking about protocol mechanisms. You can e.g.
> pick the parts of outbound that would fulfil the requirements. THAT you can
> call "half outbound".
> >
> > 5. If you are going to make statements like "people don't want to
> implement outbound", you really need some justification and background
> information. Otherwise people will just ask "how do you know people will
> implement this new mechanism?”.
>

---

From: "Olle E. Johansson" <[email-masked]>
Date: Sun, 19 Jun 2016 19:32:17 +0200

> On 19 Jun 2016, at 06:23, Ranjit Avasarala <[email-masked]> wrote:
> 
> yes I agree - half outbound as a name does not sound appropriate - a more meaningful name is better
ABsolutely - but it was helpful in explaining what I wanted to do :-)

“SIP Client Managed Connection Reuse” may work better.

/O
> 
> Regards
> Ranjit
> 
> On Sat, Jun 18, 2016 at 2:45 PM, Olle E. Johansson <[email-masked] <mailto:[email-masked]>> wrote:
> 
> > On 18 Jun 2016, at 11:02, Christer Holmberg <[email-masked] <mailto:[email-masked]>> wrote:
> >
> >
> > Hi,
> >
> > From: sipcore [mailto:[email-masked] <mailto:[email-masked]>] On Behalf Of Olle E. Johansson
> > Sent: 17 June 2016 17:52
> > To: Paul Kyzivat <[email-masked] <mailto:[email-masked]>>
> > Cc: [email-masked] <mailto:[email-masked]>; Olle E Johansson <[email-masked] <mailto:[email-masked]>>
> >> On 17 Jun 2016, at 16:48, Paul Kyzivat <[email-masked] <mailto:[email-masked]>> wrote:
> >>
> >>> http://www.slideshare.net/oej/sip-half-outbound-random-notes <http://www.slideshare.net/oej/sip-half-outbound-random-notes>
> >>>
> > [email-masked] <mailto:[email-masked]>
> > https://www.ietf.org/mailman/listinfo/sipcore <https://www.ietf.org/mailman/listinfo/sipcore>
> > [email-masked] <mailto:[email-masked]>
> > https://www.ietf.org/mailman/listinfo/sipcore <https://www.ietf.org/mailman/listinfo/sipcore>
> 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/sipcore <https://www.ietf.org/mailman/listinfo/sipcore>
>

---

From: "Hutton, Andrew" <[email-masked]>
Date: Mon, 20 Jun 2016 16:23:29 +0000

> how many times I pointed at it as the only solution. I hope they can

I cannot speak on behalf of everybody in the SIP Forum's SIPconnect 2.0 task group but I was a co-editor of the spec and involved in the discussion that Olle refers to.

I don't think it was a case of refusing to add outbound there was actually no consensus in the group to add it which has been the case every time the issue has been raised over a number of years. The SIP Forum task group asked the SIP Service Providers and the vendors that participate if they needed SIP outbound and/or actually used it and nobody spoke up.  The only argument given for including it was that it is the only IETF/RFC specified approach to this issue but since nobody stated that they actually needed or used it at present it was not included in SIPconnect.

Regards
Andy