Subject: [sipcore] Content-ID header field not defined in SIP

From: Ivo Sedlacek <[email-masked]>
Date: Thu, 11 Aug 2016 17:59:34 +0000

Hello,

The Content-ID header field does not seem to be defined as a *SIP* header field - Content-ID cannot be found in in RFC3261 and Content-ID also cannot be found in http://www.iana.org/assignments/sip-parameters/sip-parameters.xhtml#sip-parameters-2 

NOTE: Content-ID header field is defined to be a *MIME multipart/mixed* header field.

However, rfc5368 section 7 and Figure 3 describe REFER request:
- with a single body (of application/resource-lists+xml MIME type) with a Content-ID *SIP* header field; and
- with Refer-To header field referring to the body.

Also, it is possible to send an INVITE request *without SDP offer* and with location information according to rfc6442. In such case, the INVITE request:
- has a single body (of application/pidf+xml MIME type) with a Content-ID *SIP* header field; and
- has Geolocation header field referring to the body.

One can of course put a single body inside a multipart/mixed, but that is rather messy. I assume the proper solution is to define the Content-ID header field as *SIP* header field.

Is there any support for such definition? If so, I would prepare a draft.

Kind regards

Ivo Sedlacek

---

From: "Drage, Keith (Nokia - GB)" <[email-masked]>
Date: Thu, 11 Aug 2016 18:07:21 +0000

Can we first establish the use case as to why we need one.

We need it in MIME because we may need to distinguish between multiple part bodies of identical type.

We don't need it for SDP because we known the SDP contained in a SIP transaction relates to the dialog.

We don't need it in an INFO request because we known the body relates to the Info-package.

We don't need it with PIDF-LO because the Geolocation header field points to it.

Essentially we mostly deal with this by knowing the body is specific to other header fields in the SIP message.

Do you have any specific existing use cases (ignoring the ecrit discussion).

Keith

-----Original Message-----
From: sipcore [mailto:[email-masked]] On Behalf Of Ivo Sedlacek
Sent: 11 August 2016 19:00
To: [email-masked]
Subject: [sipcore] Content-ID header field not defined in SIP

Hello,

Kind regards

Ivo Sedlacek

_______________________________________________
sipcore mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/sipcore

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 11 Aug 2016 15:03:13 -0400

> We don't need it with PIDF-LO because the Geolocation header field points to it.

We *do* need it with PIDF-LO precisely because the Geolocation header 
field points to it. It points to it *via* the Content-ID.

It currently works in INVITE as long as there is also an offer. If there 
is no offer, then the only body part is the PIDF-LO, and it needs a 
Content-ID so that there is something for the cid URL in the Call-Info 
to reference.

	Thanks,
	Paul

---

From: Ivo Sedlacek <[email-masked]>
Date: Thu, 11 Aug 2016 19:30:40 +0000

I gave two cases below:

> - with Refer-To header field >>>referring to the body.<<<
>
> - has Geolocation header field >>>referring to the body.<<<

Kind regards

Ivo

---

From: [email-masked] (Dale R. Worley)
Date: Thu, 11 Aug 2016 19:54:14 -0400

Ivo Sedlacek <[email-masked]> writes:
> The Content-ID header field does not seem to be defined as a *SIP*
> header field - Content-ID cannot be found in in RFC3261 and Content-ID
> also cannot be found in
> http://www.iana.org/assignments/sip-parameters/sip-parameters.xhtml#sip-parameters-2 

> Is there any support for such definition? If so, I would prepare a draft.

It seems to me that, effectively, Content-ID is already defined as a SIP
header.  It seems to be just an accident that the published grammars
include Content-ID headers for parts of multipart bodies in SIP messages
but don't include Content-ID headers for the bodies of SIP messages.

Thus, yes, I support a draft to correct the situation.

Dale

---

From: Ranjit Avasarala <[email-masked]>
Date: Thu, 11 Aug 2016 23:17:38 -0500

Hi
I agree Content-ID is a useful header in SIP when there is no body and it
could point to any URL.  I can contribute to the draft if possible.

Regards
Ranjit

On Thu, Aug 11, 2016 at 12:59 PM, Ivo Sedlacek <[email-masked]>
wrote:

> Hello,
>
> The Content-ID header field does not seem to be defined as a *SIP* header
> field - Content-ID cannot be found in in RFC3261 and Content-ID also cannot
> be found in http://www.iana.org/assignments/sip-parameters/
> sip-parameters.xhtml#sip-parameters-2
>
> Also, it is possible to send an INVITE request *without SDP offer* and
> with location information according to rfc6442. In such case, the INVITE
> request:
> One can of course put a single body inside a multipart/mixed, but that is
> rather messy. I assume the proper solution is to define the Content-ID
> header field as *SIP* header field.
>