Subject: Re: [sipcore] SIP Push: PNS-specific SIP response code?

From: Christer Holmberg <[email-masked]>
Date: Fri, 15 Dec 2017 11:04:09 +0000

Hi,

I have updated the pull request by adding a new SIP response code, 555 (Push Notification Service Not Supported).

https://github.com/cdh4u/draft-sip-push/pull/4

Regards,

Christer

From: sipcore <[email-masked]<mailto:[email-masked]>> on behalf of Christer Holmberg <[email-masked]<mailto:[email-masked]>>
Date: Thursday 14 December 2017 at 09:57
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [sipcore] SIP Push: PNS-specific SIP response code?

Hi,

It is currently suggested (see pull request in other e-mail) that a proxy that receives a SIP REGISTER request with pn- parameters for a PNS provider it does not support sends a 501 (Not Implemented) response code.

The question is whether it would be useful to define a PNS-specific response code for this? E.g., 514 (Push Notification Service Not Supported). In addition, we could define a feature capability indicator that could be added to the response and list the PNS providers supported by the proxy.

Regards,

Christer

---

From: Christer Holmberg <[email-masked]>
Date: Mon, 18 Dec 2017 08:29:44 +0000

Hi,

I have updated the pull request, but clarifying that the SIP UA uses the protocol/procedures associated with the PNS when registering with that PNS.

So far nobody has objected to the changes/additions in the pull request, so I intend to merge it, and submit a new version of the draft.

Regards,

Christer

From: sipcore <[email-masked]<mailto:[email-masked]>> on behalf of Christer Holmberg <[email-masked]<mailto:[email-masked]>>
Date: Friday 15 December 2017 at 13:04
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [sipcore] SIP Push: PNS-specific SIP response code?

Hi,

Regards,

Christer

Hi,

Regards,

Christer