Subject: Re: [sipcore] I-D Action: draft-ietf-sipcore-sip-push-02.txt - fci syntax

From: Christer Holmberg <[email-masked]>
Date: Thu, 11 Jan 2018 14:31:27 +0000

Hi Paul,

What about the following syntax:

pns-fc          = "+sip.pns" EQUAL LDQUOT pns-list RDQUOT
  pns-list        = pns *(COMMA pns)
  pns             = tag-value

  ; tag-value as defined in RFC 3840

Regards,

Christer

On 21/12/17 17:07, "sipcore on behalf of Paul Kyzivat"
<[email-masked] on behalf of [email-masked]> wrote:

>Christer,
>
>I just looked more closely at the ABNF for the indicator. It has some
>problems.
>
>      sip.pns         = "<" pns-list ">"
>      pns-list        = pns *(COMMA pns)
>      pns             = pvalue
>
>      ; pvalue as defined in RFC 3261
>
>First, 'sip.pns' isn't a valid rulename. I presume you simply mean that
>the name of this feature-capability indicator is "sip.pns", or "pns" in
>the "sip" tree. This would be taken care of if you filled in a
>registration template as specified in rfc6809. I can find no such
>template.
>
>Next, according to rfc3840 the syntax of a feature param is:
>
>    feature-param    =  enc-feature-tag [EQUAL LDQUOT (tag-value-list
>                        / string-value ) RDQUOT]
>...
>    tag-value-list  =  tag-value *("," tag-value)
>    tag-value       =  ["!"] (token-nobang / boolean / numeric)
>    token-nobang    =  1*(alphanum / "-" / "." / "%" / "*"
>                       / "_" / "+" / "`" / "'" / "~" )
>    boolean         =  "TRUE" / "FALSE"
>    numeric         =  "#" numeric-relation number
>    numeric-relation  =  ">=" / "<=" / "=" / (number ":")
>    number          =  [ "+" / "-" ] 1*DIGIT ["." 0*DIGIT]
>    string-value    =  "<" *(qdtext-no-abkt / quoted-pair ) ">"
>    qdtext-no-abkt  =  LWS / %x21 / %x23-3B / %x3D
>                            / %x3F-5B / %x5D-7E / UTF8-NONASCII
>
>Notably, the value of the feature-param is always enclosed in double
>quotes. Also, I think your use of "<" and ">" means that you intend this
>to be a string-value with a particular syntax, but possibly the
>tag-value-list syntax would work for you.
>
>	Thanks,
>	Paul
>
>
>On 12/21/17 8:44 AM, [email-masked] wrote:
>> 
>> A New Internet-Draft is available from the on-line Internet-Drafts
>>directories.
>> This draft is a work item of the Session Initiation Protocol Core WG of
>>the IETF.
>> 
>>          Title           : Push Notification with the Session
>>Initiation Protocol (SIP)
>>          Author          : Christer Holmberg
>> 	Filename        : draft-ietf-sipcore-sip-push-02.txt
>> 	Pages           : 14
>> 	Date            : 2017-12-21
>> 
>> Abstract:
>>     This document describes how push notification mechanisms can be used
>>     to wake up suspended Session Initiation Protocol (SIP) User Agents
>>     (UAs), in order to be able to receive and generate SIP requests.
>>The
>>     document defines new SIP URI parameters, that can be used in a SIP
>>     REGISTER request to provide push notification information from the
>>     SIP User Agent (UA) to the SIP entity (realized as a SIP proxy in
>>     this document) that will send a push request to the push server in
>>     order to trigger a push notification towards the SIP UA.
>> 
>> 
>> The IETF datatracker status page for this draft is:
>> https://datatracker.ietf.org/doc/draft-ietf-sipcore-sip-push/
>> 
>> There are also htmlized versions available at:
>> https://tools.ietf.org/html/draft-ietf-sipcore-sip-push-02
>> https://datatracker.ietf.org/doc/html/draft-ietf-sipcore-sip-push-02
>> 
>> A diff from the previous version is available at:
>> https://www.ietf.org/rfcdiff?url2=draft-ietf-sipcore-sip-push-02
>> 
>> 
>> Please note that it may take a couple of minutes from the time of
>>submission
>> until the htmlized version and diff are available at tools.ietf.org.
>> 
>> Internet-Drafts are also available by anonymous FTP at:
>> ftp://ftp.ietf.org/internet-drafts/
>> 
>> _______________________________________________
>> sipcore mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/sipcore
>> 
>
>_______________________________________________
>sipcore mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/sipcore

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 11 Jan 2018 16:12:55 -0500

WFM