Subject: [sipcore] Draft new version: SIP Push-05

From: Christer Holmberg <[email-masked]>
Date: Tue, 13 Feb 2018 08:35:49 +0000

Hi,

I have submitted a new version (-05) of draft-sip-push, based on the WGLC comments.

The main technical changes are:

-I have added support of VAPID.
-I have removed the text and parameters about end-to-end payload encryption, as the mechanism doesn’t make use of payloads.
-I have added a note about UAs that are able to awake using e.g, timers to send re-registration REGISTER requests, but still want to use push to awake to process incoming calls.

In addition, the new version also contains lofts of editorial improvements (I hope), and Mickey has been added as co-editor.

Please take a look, and comment on what still needs to be done.

(Note that the draft still uses URI parameters, instead of header field parameters as suggested by Dale.)

Regards,

Christer

---

From: Mickey Arnold <[email-masked]>
Date: Tue, 13 Feb 2018 13:44:17 +0000

Hi all,

This new draft addresses all my WGLC comments. I've fixed a few editorial nits and added a some text clarifying the UA's responsibilities if a push notification subscription expires. You can find these changes in the pull request here: https://github.com/cdh4u/draft-sip-push/pull/10

Please let me know if you have any feedback.

Thanks, Mickey

From: sipcore [mailto:[email-masked]] On Behalf Of Christer Holmberg
Sent: 13 February 2018 08:36
To: [email-masked]
Cc: [email-masked]
Subject: [sipcore] Draft new version: SIP Push-05

Hi,

-I have added support of VAPID.
-I have removed the text and parameters about end-to-end payload encryption, as the mechanism doesn't make use of payloads.
-I have added a note about UAs that are able to awake using e.g, timers to send re-registration REGISTER requests, but still want to use push to awake to process incoming calls.

Regards,

Christer

---

From: Christer Holmberg <[email-masked]>
Date: Tue, 13 Feb 2018 14:01:09 +0000

Hi Mickey,

Your change suggestions look good. Unless anyone have any issues, we’ll merge them into the next version of the draft.

Thanks!

Regards,

Christer

From: Mickey Arnold <[email-masked]<mailto:[email-masked]>>
Date: Tuesday 13 February 2018 at 15:44
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: Christer Holmberg <[email-masked]<mailto:[email-masked]>>
Subject: RE: Draft new version: SIP Push-05

Hi all,

This new draft addresses all my WGLC comments. I’ve fixed a few editorial nits and added a some text clarifying the UA’s responsibilities if a push notification subscription expires. You can find these changes in the pull request here: https://github.com/cdh4u/draft-sip-push/pull/10

Thanks, Mickey

From: sipcore [mailto:[email-masked]] On Behalf Of Christer Holmberg
Sent: 13 February 2018 08:36
To: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: [sipcore] Draft new version: SIP Push-05

Hi,

Regards,

Christer