Subject: Re: [sipcore] WGLC: draft-ietf-sipcore-sip-push - uncompliant Contact example

From: Aymeric Moizard <[email-masked]>
Date: Mon, 5 Feb 2018 23:54:14 +0100

Hi Christer,

There is a REGISTER sample in Section 1 with this Contact:

     Contact: <sip:[email-masked];
       pn-provider=acme;
       pn-param=acme-param;
       pn-prid="ZTY4ZDJlMzODE1NmUgKi0K">

The "pn-prid" parameter contains DQUOTE.
However, this doesn't look to be compliant with rfc3261.
the draft correctly defines pn-prid  (and others) as
a "pvalue" (defined in rfc3261) but "pvalue" does not
contain DQUOTE.

Thus, the Contact header is wrong. I guess
the fix is to remove the DQUOTE, which are useless
here. Otherwise, DQUOTE should be escaped in the
pn-prid example.

     Contact: <sip:[email-masked];
       pn-provider=acme;
       pn-param=acme-param;
       pn-prid=ZTY4ZDJlMzODE1NmUgKi0K>

OR

     Contact: <sip:[email-masked];
       pn-provider=acme;
       pn-param=acme-param;
       pn-prid=%22ZTY4ZDJlMzODE1NmUgKi0K%22>

>From rfc3261:

pvalue            =  1*paramchar
paramchar         =  param-unreserved / unreserved / escaped
param-unreserved  =  "[" / "]" / "/" / ":" / "&" / "+" / "$"
unreserved  =  alphanum / mark
mark        =  "-" / "_" / "." / "!" / "~" / "*" / "'"
                     / "(" / ")"
escaped     =  "%" HEXDIG HEXDIG

>From the draft: (which is correct)

uri-parameter   =/ pn-provider / pn-param / pn-prid / pn-enccode /
                        pn-enckey
pn-provider     = "pn-provider" EQUAL pvalue
pn-param        = "pn-param" EQUAL pvalue
pn-prid         = "pn-prid" EQUAL pvalue
pn-enccode      = "pn-enccode" EQUAL pvalue
pn-enckey       = "pn-enckey" EQUAL pvalue
   ; pvalue as defined in RFC 3261
   ; EQUAL as defined in RFC 3261
   ; COLON as defined in RFC 3261

I hope I didn't made any mistake!
Tks,
Aymeric

Aymeric Moizard

-- 
Antisip - http://www.antisip.com

---

From: Christer Holmberg <[email-masked]>
Date: Tue, 6 Feb 2018 03:04:13 +0000

Hi Aymeric,

You are right – the DQUOTES shall be removed. Will be fixed.

Thanks!

Regards,

Christer

From: Aymeric Moizard [mailto:[email-masked]]
Sent: 06 February 2018 00:54
To: sipcore <[email-masked]>; Christer Holmberg <[email-masked]>
Subject: Re: [sipcore] WGLC: draft-ietf-sipcore-sip-push - uncompliant Contact example

Hi Christer,

     Contact: <sip:[email-masked]<mailto:[email-masked]>;
       pn-provider=acme;
       pn-param=acme-param;
       pn-prid="ZTY4ZDJlMzODE1NmUgKi0K">

     Contact: <sip:[email-masked]<mailto:[email-masked]>;
       pn-provider=acme;
       pn-param=acme-param;
       pn-prid=ZTY4ZDJlMzODE1NmUgKi0K>

OR

     Contact: <sip:[email-masked]<mailto:[email-masked]>;
       pn-provider=acme;
       pn-param=acme-param;
       pn-prid=%22ZTY4ZDJlMzODE1NmUgKi0K%22>

From rfc3261:

pvalue            =  1*paramchar

Aymeric Moizard

--
[http://sip.antisip.com/am48.png]Antisip - http://www.antisip.com

---

From: [email-masked] (Dale R. Worley)
Date: Mon, 05 Feb 2018 23:00:56 -0500

>        pn-prid=%22ZTY4ZDJlMzODE1NmUgKi0K%22>

Good point.

Though in the second version, the typical interpretation of parameters
would be that the PRID value "contains" an initial and final
double-quote, which is unlikely in practice.

Dale