Subject: Re: [sipcore] WGLC: draft-ietf-sipcore-sip-push - SIP combine with push implementation experience

From: [email-masked] (Dale R. Worley)
Date: Thu, 08 Mar 2018 22:03:49 -0500

Roman Shpount <[email-masked]> writes:
> [much interesting and informative material]
> As far as Registration expiration is concerned, for SIP-push it is needed
> to specify the minimum allowed registration expires interval otherwise
> there is not enough time for a SIP-push notification to complete and
> registration request to be sent before registration expires. We have used a
> minimum expires value of 90 seconds and failed all registrations with all
> lower expires non-zero values.

I would expect in situations where the UA desires to power down when it
is not in use, it would be very desirable to use long registrations.
However, you describe allowing a registration interval of 90 seconds,
which seems very short.  Can you explain the scenarios in which such a
short registration is desirable?

Dale

---

From: Roman Shpount <[email-masked]>
Date: Thu, 8 Mar 2018 22:24:03 -0500

Dale,

I said that we did not allow registrations with expires value less then 90
seconds. Normally much larger expires values (1 hour) were used.

This was done since if registration expiration interval is too short, there
is not enough time to send push notification and for registration
transaction to complete before registration expires.

Regards,

_____________
Roman Shpount

---

From: Christer Holmberg <[email-masked]>
Date: Fri, 9 Mar 2018 07:37:02 +0000

Hi Roman,

>I said that we did not allow registrations with expires value less then 90 seconds. Normally much larger expires values (1 hour) were used.
>
>This was done since if registration expiration interval is too short, there is not enough time to send push notification and for registration transaction to complete before registration expires.

Just to clarify, do you want me to add some text to the draft? If so, please provide the text.

Personally, the only time I’ve seen short re-registration intervals is when the re-registrations are used to maintain NAT bindings. But that’s not the case here.

Regards,

Christer

On Thu, Mar 8, 2018 at 10:03 PM, Dale R. Worley <[email-masked]<mailto:[email-masked]>> wrote:

Dale