Subject: Re: [sipcore] AD Evaluation of draft-ietf-sipcore-sip-push-20 - Ben's technical comments - Exipres issue

From: Christer Holmberg <[email-masked]>
Date: Fri, 30 Nov 2018 21:04:49 +0000

Hi,

>>>>   -2nd paragraph:
>>>>   I don't think we can assume that all UAs will always learn all the 
>>>> bindings they need to to setup at the same time.
>>>>  For example, a UA might have changes in network configuration that 
>>>> require them to add or remove bindings. This
>>>>  makes it impractical to register them at the same time and always 
>>>> use the same expirations, unless we ask them to
>>>>  refresh all existing bindings whenever they add a new one. (Or 
>>>> perhaps ask them to set the expiration of any new
>>>> binding to match the remaining time for existing ones, but that seems 
>>>> like a more difficult approach.)
>>>
>>> I don't think the text assumes that the UA is aware of all bindings at 
>>> the same time - it only says that it should use the same 'expires' 
>>> value for each binding.
>> 
>> That depends on whether you consider “Expires” to be the time remaining 
>> until expiration, or the Expires header (or parameter) on a specific 
>> Register request. For example, if I register contact “A” with an 
>> expiration of 2 hours, and then register contact “B” an hour later, it 
>> would need to have a 1 hour expires value in order to expire at roughly 
>> the same time.
>    
>    The time in the expiration time in the request is only a preference. The 
>    registrar may reduce this value. So, if the registrar wants the 
>    expiration time for one binding to match that of some other binding then 
>    it has some power to make that happen as long as the requested 
>    expiration is big enough.
>  
>    (This can be confusing because while the values negotiated are encoded 
>    as intervals what is actually being negotiated is a particular point in 
>    time when the expiration occurs. Each end sets the point in time as its 
>    notion of the current time plus the expiration time (interval). Due to 
>    propagation delay the times at the two ends are only approximately 
>    equal. For the UAC this needs to be done based on the value in the 
>    response.)
  
Luckily, in most deployments, all contacts (all one of them :) will be provided at the same time.

Also, using different expirations will not break anything - it may only trigger binding refreshes earlier than needed.
Regards,

Christer

---

From: Ben Campbell <[email-masked]>
Date: Fri, 30 Nov 2018 15:08:58 -0600

> On Nov 30, 2018, at 3:04 PM, Christer Holmberg <[email-masked]> wrote:
> 
> Hi,
> 
>>>>>  -2nd paragraph:

Would it make sense to change that paragraph to non-normative guidance that suggests making a reasonable effort to keep expirations in sync, and what happens if you don’t?

> Regards,
> 
> Christer
> 
> 
> 
> _______________________________________________
> sipcore mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sipcore