Subject: Re: [sipcore] AD Evaluation of draft-ietf-sipcore-sip-push-20 - Ben's technical comments - Exipres issue

From: Christer Holmberg <[email-masked]>
Date: Sat, 1 Dec 2018 16:09:13 +0000

Hi,

...

    >>>   The time in the expiration time in the request is only a preference. The
    >>>   registrar may reduce this value. So, if the registrar wants the
    >>>   expiration time for one binding to match that of some other binding then
    >>>   it has some power to make that happen as long as the requested
    >>>   expiration is big enough.
    >>> 
    >>>   (This can be confusing because while the values negotiated are encoded
    >>>   as intervals what is actually being negotiated is a particular point in
    >>>   time when the expiration occurs. Each end sets the point in time as its
    >>>   notion of the current time plus the expiration time (interval). Due to
    >>>   propagation delay the times at the two ends are only approximately
    >>>   equal. For the UAC this needs to be done based on the value in the
    >>>   response.)
    >> 
    >> Luckily, in most deployments, all contacts (all one of them :) will be provided at the same time.
    >> 
    >> Also, using different expirations will not break anything - it may only trigger binding refreshes earlier than needed.
    >
    >Would it make sense to change that paragraph to non-normative guidance that suggests making a reasonable effort to keep 
    >expirations in sync, and what happens if you don’t?

    What about removing:

    "If the SIP UA creates multiple bindings (e.g., one for IPv4 and one
     for IPv6), the UA SHOULD use the same 'expires' Contact header field
     parameter value [RFC3261] for each binding."

     ...and adding:

    "NOTE: If the SIP UA creates multiple bindings (e.g., one for IPv4 and one
    for IPv6), since a push notification will trigger to UA to refresh all bindings,
    it is preferable if one can ensure that all bindings expire at the same
    time. That will help preventing that some bindings are refreshed earlier
    than needed."
  
Regards,

Christer

---

From: Ben Campbell <[email-masked]>
Date: Sat, 1 Dec 2018 12:54:24 -0600

> On Dec 1, 2018, at 10:09 AM, Christer Holmberg <[email-masked]> wrote:
> 
> Hi,
> 
> ...
> 
>    than needed.”

WFM.

Thanks!

Ben.