Subject: Re: [sipcore] [Gen-art] Genart last call review of draft-ietf-sipcore-sip-push-21

From: Christer Holmberg <[email-masked]>
Date: Thu, 20 Dec 2018 15:37:03 +0000

Hi Stewart,

Thank You for the review! Please see inline.

>Summary: A well written document with some minor points that could use a little
>attention.
>
>Major issues: None
>
>Minor issues:
>
>In Figure 1 the following is included:
>
>     REGISTER sip:[email-masked] SIP/2.0
>     Via: SIP/2.0/TCP alicemobile.example.com:5060;branch=z9hG4bKnashds7
>     Max-Forwards: 70
>     To: Alice <sip:[email-masked]>
>     From: Alice <sip:[email-masked]>;tag=456248
>     Call-ID: 843817637684230@998sdasdh09
>     CSeq: 1826 REGISTER
>     Contact: <sip:[email-masked];
>       pn-provider=acme;
>       pn-param=acme-param;
>       pn-prid=ZTY4ZDJlMzODE1NmUgKi0K>
>     Expires: 7200
>     Content-Length: 0
>
> SB> However I don't at this stage of the text see the relationship between the
> SB> packet flow digram and the text that follows.

I could add the following:

“Below is an example of a SIP REGISTER request in Figure 1.”

=========

>   Contact: IESG ([email-masked]<mailto:[email-masked]>)
>
> SB> Is the whole IESG the most appropriate first point of contact?

That is what I was told :)

Note that I have used it also for other documents.

=========

>Nits/editorial comments:
>Presumably the references to RFC XXXX will be replaced by RFC <this RFC> but
>that does not seem to be noted in the text

I will add a note to the RFC editor about that.

        “[RFC EDITOR NOTE: Please replace RFCXXXX with the RFC number of this document.]”

========

> SB> As dicussed in [RFC4320] and [RFC4321], non-INVITE transactions must
> SB> Typo s/dicussed/discussed/

I will fix as suggested.

========

>   Example: pn-prid = 00fc13adff78512
>
>   For more information about the APNs Topic and device token:
>
> SB> Is the following part of the example? If so it could usefully be delimited
> SB> as such, otherwise, I don't understand why it is not a normal document
> SB> reference.
>
>   https://developer.apple.com/library/archive/documentation/NetworkingI
>   nternet/Conceptual/RemoteNotificationsPG/CommunicatingwithAPNs.html
>
> SB> Similarly in the following section

The link reference is not part of the example. Perhaps I could place to reference before the examples, to make that more clear?

Are you suggesting that I add the link to the reference section, similar to document references?

=========

Regards,

Christer

---

From: Ben Campbell <[email-masked]>
Date: Fri, 21 Dec 2018 17:40:02 -0600

> On Dec 20, 2018, at 9:37 AM, Christer Holmberg <[email-masked]> wrote:
> 
> >   https://developer.apple.com/library/archive/documentation/NetworkingI <https://developer.apple.com/library/archive/documentation/NetworkingI>

One common approachto this  is to add a URL reference section after the normal references.

Thanks!

Ben.

---

From: Stewart Bryant <[email-masked]>
Date: Mon, 24 Dec 2018 10:01:45 +0000

> “Below is an example of a SIP REGISTER request in Figure 1.”

SB> Thank you, that would clarify what was happening.

> =========
>
> >  Contact: IESG ([email-masked] <mailto:[email-masked]>)
>
> >
>
SB> Whatever the IESG want... :)

> “[RFC EDITOR NOTE: Please replace RFCXXXX with the RFC number of this 
SB> That would be a fine way of clarifying it to the editors and those 
that read the pre-edited final text.

> The link reference is not part of the example. Perhaps I could place 
> to reference before the examples, to make that more clear?
>
SB> Yes, if it is just a reference, I would have expected it to be 
treated just like any other reference, i.e. a pointer to a reference at 
the end of the document. That method also clarifies the matter of 
whether the reference is normative or informational which does not 
happen with embedded references.

Best regards

Stewart