Subject: Re: [sipcore] AD Evaluation of draft-ietf-sipcore-sip-push-20 - Ben's editorial comments

From: Christer Holmberg <[email-masked]>
Date: Sat, 1 Dec 2018 16:51:06 +0000

Hi,

    >>>   - 5th paragraph:
    >>>   -- "... proxy that is not between the push proxy and the UA...". Doesn't this really mean a proxy that is between the push
    >>> proxy and the registrar? If so, saying where the proxy _is_ would be clearer than saying where it is _not_.
    >> 
    >> I used to have upstream/downstream terminology here, but was asked to change it (since people confuse what is upstream 
    >> and what is downstream). The text talks about the push proxy knowing that there is another push proxy (between itself and 
    >> the registrar) that will be able to handle the PNS.
    >
    > Right, but wouldn’t “between the proxy and the registrar” be clearer than “not between the proxy and the UA”?
 
The "not" is a spelling error. The proxy can forward the request if it knows that there IS another proxy that supports the PNS.

What about: 

   "(e.g., if the proxy knows that another proxy that will receive the REGISTER request supports the type of PNS)"

Regards,

Christer

---

From: Ben Campbell <[email-masked]>
Date: Sat, 1 Dec 2018 12:51:06 -0600

> On Dec 1, 2018, at 10:51 AM, Christer Holmberg <[email-masked]> wrote:
> 
> Hi,
> 
>>>>  - 5th paragraph:
>   "(e.g., if the proxy knows that another proxy that will receive the REGISTER request supports the type of PNS)”

WFM.

Thanks!

Ben.