Subject: [sipcore] Benjamin Kaduk's No Objection on draft-ietf-sipcore-originating-cdiv-parameter-07: (with COMMENT)

From: Benjamin Kaduk <[email-masked]>
Date: Thu, 06 Dec 2018 01:23:47 -0800

Benjamin Kaduk has entered the following ballot position for
draft-ietf-sipcore-originating-cdiv-parameter-07: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-sipcore-originating-cdiv-parameter/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Section 6.2

   sessioncase-param        = "sescase" EQUAL ("orig"/"term")/ orig-cdiv

It's quite possible I'm just confused about the ABNF, but why do we need the
grouping?

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 6 Dec 2018 11:37:03 -0500

> It's quite possible I'm just confused about the ABNF, but why do we need the

IIUC, you are asking if the above:

1) sessioncase-param  = "sescase" EQUAL ("orig"/"term")/ orig-cdiv

is equivalent to:

2) sessioncase-param  = "sescase" EQUAL "orig"/"term"/ orig-cdiv

The answer is no, it isn't. Using more bracketing to show the syntax 
more clearly, (1) is equivalent to:

1a) sessioncase-param  = ("sescase" EQUAL ("orig"/"term")) / orig-cdiv

while (2) is equivalent to:

2a) sessioncase-param  = ("sescase" EQUAL "orig") / "term" / orig-cdiv

	Thanks,
	Paul

---

From: <[email-masked]>
Date: Sun, 9 Dec 2018 23:07:36 +0000

Hi Benjamin,

We had email exchanges about the syntax and how to make it aligned with what has been designed (and is already implemented by networks).
Paul is correct existing syntax 1) is equivalent to 1a) by following ABNF rules.
The idea is to optimize the syntax so 1) should be the correct form.
 
Are you fine with that?

BR,
Marianne

-----Message d'origine-----
De : sipcore [mailto:[email-masked]] De la part de Paul Kyzivat
Envoyé : jeudi 6 décembre 2018 17:37
À : Benjamin Kaduk
Cc : [email-masked]
Objet : Re: [sipcore] Benjamin Kaduk's No Objection on draft-ietf-sipcore-originating-cdiv-parameter-07: (with COMMENT)

is equivalent to:

	Thanks,
	Paul

_______________________________________________
sipcore mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/sipcore

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Benjamin Kaduk <[email-masked]>
Date: Sun, 9 Dec 2018 18:24:37 -0600

That is fine for me.  To be clear, I had no objection to the original, and
I was just confused.  The follow-up discussion helped me, and I am not
requesting a chamge to the document for my sake.

-Benjamin