Subject: [sipcore] SIP Push: UA/Proxy procedure re-write pull request

From: Christer Holmberg <[email-masked]>
Date: Sun, 20 Jan 2019 15:05:00 +0000

Hi,

Below is the link to the pull request with the suggested changes to the UA and Proxy procedures in the SIP push draft.

https://github.com/cdh4u/draft-sip-push/pull/32

The re-write is based on Ekr’s IESG review comment that we need some re-writes, to make procedures more clear. When I stared doing them, I found text and sections myself that I think can be clarified.

Note that there are also some technical changes, mostly related to the syntax of some parameters. For example, the draft allows pn-provider without a value. Also, any Feature-Caps header field can only contain one sip.pns feature-capability indicator, and any feature-capability indicator indicating support of an extension (e.g., VAPID) associated with the PNS indicated by sip.pns must be in the same Feature-Capability header field – in order to inform which PNS an extension is associated with.

So, as you will see (don’t worry if the pull requests looks messy – I intend to submit a new version of the draft) there are quite many changes.

I will leave it up to the chairs to decide whether we need a new WGLC, but once I’ve submitted a new version I at least would like people to take a good look.

Regards,

Christer

---

From: Eric Rescorla <[email-masked]>
Date: Sat, 26 Jan 2019 20:04:30 -0800

This is too big for me to plausibly review as a PR. Happy to review a new
draft.

With that said, it seems clear to me that the technical changes requiree WG
consent.

-Ekr

On Sun, Jan 20, 2019 at 7:05 AM Christer Holmberg <
[email-masked]> wrote:

> Hi,
>
>
>
> Below is the link to the pull request with the suggested changes to the UA
> and Proxy procedures in the SIP push draft.
>
>
>
> The re-write is based on Ekr’s IESG review comment that we need some
> re-writes, to make procedures more clear. When I stared doing them, I found
> text and sections myself that I think can be clarified.
>
>
>
> Note that there are also some technical changes, mostly related to the
> syntax of some parameters. For example, the draft allows pn-provider
> without a value. Also, any Feature-Caps header field can only contain one
> sip.pns feature-capability indicator, and any feature-capability indicator
> indicating support of an extension (e.g., VAPID) associated with the PNS
> indicated by sip.pns must be in the same Feature-Capability header field –
> in order to inform which PNS an extension is associated with.
>
>
>
> So, as you will see (don’t worry if the pull requests looks messy – I
> intend to submit a new version of the draft) there are quite many changes.
>
>
>
> I will leave it up to the chairs to decide whether we need a new WGLC, but
> once I’ve submitted a new version I at least would like people to take a
> good look.
>
>
>
> Regards,
>
>
>
> Christer
>

---

From: Christer Holmberg <[email-masked]>
Date: Sun, 27 Jan 2019 10:59:01 +0000

Hi Ekr,

Note that the PR has been merged, and a new version of the draft has been submitted, so the latest version of the draft contains the changes.

Regards,

Christer

________________________________
From: Eric Rescorla <[email-masked]>
Sent: Sunday, January 27, 2019 6:04 AM
To: Christer Holmberg
Cc: [email-masked]; [email-masked]; Ben Campbell; [email-masked]
Subject: Re: SIP Push: UA/Proxy procedure re-write pull request

This is too big for me to plausibly review as a PR. Happy to review a new draft.

With that said, it seems clear to me that the technical changes requiree WG consent.

-Ekr

On Sun, Jan 20, 2019 at 7:05 AM Christer Holmberg <[email-masked]<mailto:[email-masked]>> wrote:

Hi,

Regards,

Christer