Subject: Re: [sipcore] [Technical Errata Reported] RFC3261 (5619)

From: Ben Campbell <[email-masked]>
Date: Thu, 31 Jan 2019 13:12:16 -0600

Hi,

I think the point of the example was that Alice’s phone could have learned its home proxy via configuration or DHCP. Whether it learns an address, or a name that it then resolves with DNS is not material to the example. Perhaps it would have been more clear if some other word had been chosen than “address”.

I lean towards rejecting this as a technical erratum. If people want to address the use of “address” as an editorial erratum, we could address that with a new errata report (which would likely be marked as “hold for update”.

What do other people think?

Thanks!

Ben.

> On Jan 31, 2019, at 12:15 PM, RFC Errata System <[email-masked]> wrote:
> 
> The following errata report has been submitted for RFC3261,
> "SIP: Session Initiation Protocol".
> 
> --------------------------------------
> You may review the report below and at:
> http://www.rfc-editor.org/errata/eid5619
> 
> --------------------------------------
> Type: Technical
> Reported by: Isabella Damböck <[email-masked]>
> 
> Section: 4
> 
> Original Text
> -------------
> The address
> of the atlanta.com SIP server could have been configured in Alice's
> softphone, or it could have been discovered by DHCP, for example.
> 
> Corrected Text
> --------------
> The address
> of the atlanta.com SIP server could have been configured in Alice's
> softphone, or it could have been discovered by DNS, for example.
> 
> Notes
> -----
> DHCP Server gives away the DNS-Server to use (or sets it with DHCP option) but usually does no address translation itself. It would also be possible to omit the whole sentence.
> 
> Instructions:
> -------------
> This erratum is currently posted as "Reported". If necessary, please
> use "Reply All" to discuss whether it should be verified or
> rejected. When a decision is reached, the verifying party
> can log in to change the status and edit the report, if necessary.
> 
> --------------------------------------
> RFC3261 (draft-ietf-sip-rfc2543bis-09)
> --------------------------------------
> Title               : SIP: Session Initiation Protocol
> Publication Date    : June 2002
> Author(s)           : J. Rosenberg, H. Schulzrinne, G. Camarillo, A. Johnston, J. Peterson, R. Sparks, M. Handley, E. Schooler
> Category            : PROPOSED STANDARD
> Source              : Session Initiation Protocol
> Area                : Real-time Applications and Infrastructure
> Stream              : IETF
> Verifying Party     : IESG

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 31 Jan 2019 19:55:07 -0500

> What do other people think?

I think just reject it.

> _______________________________________________
> sipcore mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sipcore
>