Subject: [sipcore] Alissa Cooper's No Objection on draft-ietf-sipcore-sip-push-21: (with COMMENT)

From: Alissa Cooper <[email-masked]>
Date: Wed, 09 Jan 2019 07:26:16 -0800

Alissa Cooper has entered the following ballot position for
draft-ietf-sipcore-sip-push-21: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-sipcore-sip-push/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Section 13: "MUST ... unless" is a construct worth avoiding.

---

From: Christer Holmberg <[email-masked]>
Date: Wed, 9 Jan 2019 15:31:01 +0000

Hi Alissa,

Thank You for the review! Please see inline.

>Section 13: "MUST ... unless" is a construct worth avoiding.

I will use something else, e.g., SHOULD ... unless.

Regards,

Christer

---

From: Ben Campbell <[email-masked]>
Date: Wed, 9 Jan 2019 13:41:33 -0600

> On Jan 9, 2019, at 9:26 AM, Alissa Cooper <[email-masked]> wrote:
> 

Hi Alissa,

I can see why that specific "MUST... unless” may not be appropriate, given the vagueness of the condition and the way we’ve constructed “MUST support/SHOULD use” requirements for TLS in the past.

But are you suggesting that conditional MUSTs are never appropriate?  I’ve been recommended “MUST ... unless...” constructions for cases where the MUST is true except in enumerated special cases. “SHOULD” doesn’t really accomplish the same thing, since a SHOULD as defined by 2119 allows for exceptions beyond those enumerated in the spec.

Thanks!

Ben.

---

From: Alissa Cooper <[email-masked]>
Date: Wed, 9 Jan 2019 14:47:15 -0500

> On Jan 9, 2019, at 2:41 PM, Ben Campbell <[email-masked]> wrote:
> 
> 
> 

I think “MUST … unless” is hard to square with how MUST is defined in 2119.

For this doc it seems like a simple re-wording would do the trick, e.g.: TLS or a mechanism that offers equivalent security properties MUST be used to secure the signaling.

Alissa

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 9 Jan 2019 17:08:19 -0500

> But are you suggesting that conditional MUSTs are never appropriate?  I’ve been recommended “MUST ... unless...” constructions for cases where the MUST is true except in enumerated special cases. “…

"MUST X unless Y" is equivalent to "If not Y then MUST X".

The latter seems perfectly fine to me. Because the former is equivalent 
I see no reason to forbid it. I think which one is clearest may depend 
on the situation.

	Thanks,
	Paul

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 10 Jan 2019 09:32:44 +0000

Hi,

>> I can see why that specific "MUST... unless” may not be appropriate, given the
>> vagueness of the condition and the way we’ve constructed “MUST support/SHOULD use”
>> requirements for TLS in the past.
>
> But are you suggesting that conditional MUSTs are never appropriate?  I’ve been
> recommended “MUST ... unless...” constructions for cases where the MUST is true
> except in enumerated special cases. “SHOULD” doesn’t really accomplish the same
> thing, since a SHOULD as defined by 2119 allows for exceptions beyond those enumerated in the spec.

I would be fine with "SHOULD Y … unless X" - if X was the ONLY allowed exception for not doing Y.

But, as Paul suggests, people seem to have different opinions on that.

In any case, this is not SIP push specific, and should probably be discussed (once again...) elsewhere.

 Regards,

Christer

---

From: Christer Holmberg <[email-masked]>
Date: Fri, 11 Jan 2019 10:48:59 +0000

Hi,

So, how to move forward? Can I, or can I not, use "MUST … unless"?

Regards,

Christer

________________________________
From: sipcore <[email-masked]> on behalf of Christer Holmberg <[email-masked]>
Sent: Thursday, January 10, 2019 11:32 AM
To: Paul Kyzivat; [email-masked]
Subject: Re: [sipcore] Alissa Cooper's No Objection on draft-ietf-sipcore-sip-push-21: (with COMMENT)

Hi,

 Regards,

Christer