Subject: [sipcore] SIP Push: SIP UA procedures editorial re-write

From: Christer Holmberg <[email-masked]>
Date: Wed, 16 Jan 2019 13:18:31 +0000

Hi,

Based on Ekr’s IESG review, I have done a “re-write” pull request of the SIP UA procedures (Proxy procedures still to come). Much is moving existing text into new sub-sections, which I think make the document more readable, but I have also tried to clarify procedures explicitly pointed out by Ekr.

https://github.com/cdh4u/draft-sip-push/pull/32

In addition to the editorial changes, I have done the following modifications/additions:

  *   The UA can include multiple pn-provider values when performing a query
  *   Text about using binding-refresh push notifications also to update other state (e.g., subscriptions) have been added.

I do *NOT* want this document to become a new BUNDLE, where publication is delayed forever because of never-ending re-writes. So, if you care about the text, please take a look *NOW*.

Regards,

Christer

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 17 Jan 2019 17:05:34 +0000

Hi,

I have submitted a new commit, with re-write of the proxy procedures.

https://github.com/cdh4u/draft-sip-push/pull/32/commits/01a50a4a6108586bccdcbe23e3bf9e8ca2211176

Note that the issue regarding a UA indicating support of multiple PNSs is still open, and the text will still need to be changed based on the outcome of that discussion.

Regards,

Christer

From: sipcore <[email-masked]> on behalf of Christer Holmberg <[email-masked]>
Date: Wednesday, 16 January 2019 at 15.19
To: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, Ben Campbell <[email-masked]>, Eric Rescorla <[email-masked]>
Subject: [sipcore] SIP Push: SIP UA procedures editorial re-write

Hi,

Regards,

Christer