Subject: [sipcore] display-name ABNF rule is incorrect in RFC 3261

From: Roman Shpount <[email-masked]>
Date: Fri, 11 Jan 2019 16:21:38 -0500

Hi All,

The name-addr ABNF rule in RFC 3261 specifies:

name-addr      =  [ display-name ] LAQUOT addr-spec RAQUOT
addr-spec      =  SIP-URI / SIPS-URI / absoluteURI
display-name   =  *(token LWS)/ quoted-string

Based on this, LWS is always required between token and the "<" and the
following Name-Address value is invalid:

foo<sip:[email-masked]>

At the same time https://tools.ietf.org/html/rfc3261#section-20.10 says:

There may or may not be LWS between the display-name and the    "<".

This implies that foo<sip:[email-masked]> should be acceptable.

Based on this, should the display-name rule be updated to be:

display-name   =  token *(LWS token)/ quoted-string

Should I file an errata or was this ever corrected in subsequent RFC?

Regards,
_____________
Roman Shpount

---

From: Paul Kyzivat <[email-masked]>
Date: Fri, 11 Jan 2019 18:25:15 -0500

On 1/11/19 4:21 PM, Roman Shpount wrote:
> foo<sip:[email-masked] <mailto:[email-masked]>>
> 

Good catch.

> This implies that foo<sip:[email-masked] <mailto:[email-masked]>> should 
> be acceptable.
> 

I'm not aware of this ever being corrected.

	Thanks,
	Paul

---

From: Roman Shpount <[email-masked]>
Date: Fri, 11 Jan 2019 18:56:44 -0500

Hi Paul,

> I'm not aware of this ever being corrected.

Thank you for checking this.

This was actually caught by a regression testing of an open source SIP
stack implementation. I have submitted the errata for RFC 3261 with a new
ABNF display-name rule.

Regards,
_____________
Roman Shpount