Subject: [sipcore] Call for WG adoption: draft-yusef-sipcore-digest-scheme

From: "A. Jean Mahoney" <[email-masked]>
Date: Mon, 1 Apr 2019 15:45:43 -0500

Hi all,

This is a call for adoption of draft-yusef-sipcore-digest-scheme in the 
SIPCORE working group.

https://datatracker.ietf.org/doc/draft-yusef-sipcore-digest-scheme/

Please send your comments to the list or to the chairs by April 15th.

Thanks!

Jean

---

From: Christer Holmberg <[email-masked]>
Date: Tue, 2 Apr 2019 06:35:47 +0000

Hi,

I support the adopting the draft, and I will provide input (I think the draft is in pretty good shape already) and review the document.

Regards,

Christer

On 01/04/2019, 23.46, "sipcore on behalf of A. Jean Mahoney" <[email-masked] on behalf of [email-masked]> wrote:

    Hi all,

    
    
    Thanks!
    
    Jean
    
    _______________________________________________
    sipcore mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/sipcore

---

From: Brian Rosen <[email-masked]>
Date: Tue, 2 Apr 2019 10:35:13 -0400

<As individual>
I support adopting this draft, and the NENA folks need it.  I wonder if we should expressly allow any new entries to the RFC7616 registry to be used.

Brian

> On Apr 2, 2019, at 2:35 AM, Christer Holmberg <[email-masked]> wrote:
> 
> Hi,
>

---

From: [email-masked] (Dale R. Worley)
Date: Wed, 03 Apr 2019 22:30:06 -0400

> On 01/04/2019, 23.46, A. Jean Mahoney wrote:

I favor adopting draft-yusef-sipcore-digest-scheme.

(Editorial:  The Abstract needs revision.  As far as I can tell, the
general idea is to have MD5 be replaced by SHA-256 in general usage.
But the specifics are that the document adds both SHA-256 and
SHA-512-256 and does not remove MD5.)

Dale

---

From: Rifaat Shekh-Yusef <[email-masked]>
Date: Fri, 5 Apr 2019 09:08:47 -0400

Hi Dale,

The document does not require the removal of MD5 support because it is
needed for backward compatibility.

Regards,
 Rifaat

---

From: Rifaat Shekh-Yusef <[email-masked]>
Date: Fri, 5 Apr 2019 09:10:53 -0400

Hi Brian,

I have one comment about that in the IANA section.
If that is not enough, I can add one more sentence to make it clear that
this is the intent.

Regards,
 Rifaat

On Tue, Apr 2, 2019 at 10:35 AM Brian Rosen <[email-masked]> wrote:

> <As individual>
> I support adopting this draft, and the NENA folks need it.  I wonder if we
> should expressly allow any new entries to the RFC7616 registry to be used.
>
> Brian
>
> > I support the adopting the draft, and I will provide input (I think the
> draft is in pretty good shape already) and review the document.
> >
> > Regards,
> >
> > Christer
> >
> >
> > On 01/04/2019, 23.46, "sipcore on behalf of A. Jean Mahoney" <
> [email-masked] on behalf of [email-masked]> wrote:
> >
> >    Hi all,
> >

---

From: Brian Rosen <[email-masked]>
Date: Fri, 5 Apr 2019 14:08:49 -0400

<as individual>
Consider adding text saying that MD5 is not deprecated by this document but its use is restricted to older devices and when communicating with newer devices SHA MUST be used.

Brian

> On Apr 5, 2019, at 9:08 AM, Rifaat Shekh-Yusef <[email-masked]> wrote:
> 
> Hi Dale,
> 
> The document does not require the removal of MD5 support because it is needed for backward compatibility.
> 
> Regards,
>  Rifaat
> 
> 
> 
> On Wed, Apr 3, 2019 at 10:30 PM Dale R. Worley <[email-masked] <mailto:[email-masked]>> wrote:
> >     https://datatracker.ietf.org/doc/draft-yusef-sipcore-digest-scheme/ <https://datatracker.ietf.org/doc/draft-yusef-sipcore-digest-scheme/>
> 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/sipcore <https://www.ietf.org/mailman/listinfo/sipcore>

---

From: Rifaat Shekh-Yusef <[email-masked]>
Date: Sat, 6 Apr 2019 14:31:49 -0400

It will be very difficult to enforce this, as a downgrade attack will
always be possible unless a secure mechanism to identify the client is
being used.
I will add some text to cover this.

Regards,
 Rifaat

On Fri, Apr 5, 2019 at 2:08 PM Brian Rosen <[email-masked]> wrote:

> <as individual>
> Consider adding text saying that MD5 is not deprecated by this document
> but its use is restricted to older devices and when communicating with
> newer devices SHA MUST be used.
>
> Brian
>

---

From: "A. Jean Mahoney" <[email-masked]>
Date: Tue, 16 Apr 2019 18:32:14 -0500

Hi all,
The draft received support on list and the chairs did not hear any objections off list, so the draft is adopted as a WG item. Rifaat, please rename the draft as draft-ietf-sipcore-digest-scheme and resubmit.
Thanks! 
Jean

Sent from my phone
-------- Original message --------From: "A. Jean Mahoney" <[email-masked]> Date: 4/1/19  3:45 PM  (GMT-06:00) To: SIPCORE <[email-masked]> Subject: [sipcore] Call for WG adoption: draft-yusef-sipcore-digest-scheme 
Hi all,

Thanks!

Jean