Subject: [sipcore] I-D Action: draft-ietf-sipcore-digest-scheme-07.txt

From: [email-masked]
Date: Wed, 03 Jul 2019 05:33:42 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Session Initiation Protocol Core WG of the IETF.

        Title           : The Session Initiation Protocol (SIP) Digest Authentication Scheme
        Author          : Rifaat Shekh-Yusef
	Filename        : draft-ietf-sipcore-digest-scheme-07.txt
	Pages           : 9
	Date            : 2019-07-03

Abstract:
   This document updates [RFC3261] by updating the Digest Access
   Authentication scheme used by the Session Initiation Protocol (SIP)
   to add support for more secure digest algorithms, e.g.  SHA-256 and
   SHA-512-256, to replace the broken MD5 algorithm, which might be used
   for backward compatibility reasons only.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-sipcore-digest-scheme/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-sipcore-digest-scheme-07
https://datatracker.ietf.org/doc/html/draft-ietf-sipcore-digest-scheme-07

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-sipcore-digest-scheme-07

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Rifaat Shekh-Yusef <[email-masked]>
Date: Wed, 3 Jul 2019 08:37:03 -0400

Hi Jean,

Thanks you again for the detailed review, comments, and suggested text.
I believe that with this version I have addressed all your comments; can
you please take a look and let me know what you think?

Thanks,
 Rifaat

On Wed, Jul 3, 2019 at 8:33 AM <[email-masked]> wrote:

> _______________________________________________
> sipcore mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sipcore
>

---

From: "A. Jean Mahoney" <[email-masked]>
Date: Wed, 3 Jul 2019 16:31:42 -0500

Hi Rifaat,

Thanks for incorporating the feedback! Just two tiny nits left -

Although idnits wants the Abstract to mention which RFC is being 
updated, it doesn't like the [RFCNNNN] reference format, so 
s/[RFC3261]/RFC 3261.

S2.7 heading: remove "the"

I will upload my Doc Shepherd write-up.

Jean

On 7/3/19 7:37 AM, Rifaat Shekh-Yusef wrote:
> On Wed, Jul 3, 2019 at 8:33 AM <[email-masked] 
> <mailto:[email-masked]>> wrote:
> 
> 
>     until the htmlized version and diff are available at tools.ietf.org
>     <http://tools.ietf.org>.
> 
>     [email-masked] <mailto:[email-masked]>

---

From: Rifaat Shekh-Yusef <[email-masked]>
Date: Wed, 3 Jul 2019 17:40:38 -0400

Thanks Jean,

I have just submitted a new version with these changes.

Regards,
 Rifaat

---

From: "A. Jean Mahoney" <[email-masked]>
Date: Wed, 3 Jul 2019 16:58:41 -0500

And I have uploaded the Doc Shepherd write-up

https://datatracker.ietf.org/doc/draft-ietf-sipcore-digest-scheme/shepherdwriteup/

Thanks!

Jean

On 7/3/19 4:40 PM, Rifaat Shekh-Yusef wrote:
> On Wed, Jul 3, 2019 at 5:31 PM A. Jean Mahoney <[email-masked] 
> <mailto:[email-masked]>> wrote:
> 
>     Hi Rifaat,
> 
>     <mailto:[email-masked]>
>      > <mailto:[email-masked]
>     <mailto:[email-masked]>>> wrote:
>      >
>      >
>      >     A New Internet-Draft is available from the on-line
>     Internet-Drafts
>      >     directories.
>      >     This draft is a work item of the Session Initiation Protocol
>     Core WG
>      >     of the IETF.
>      >
>      >         SHA-512-256, to replace the broken MD5 algorithm, which
>     might be
>      >     used
>      >     until the htmlized version and diff are available at
>     tools.ietf.org <http://tools.ietf.org>
>      >     <http://tools.ietf.org>.
>      >
>     <mailto:[email-masked] <mailto:[email-masked]>>