Subject: [sipcore] I-D Action: draft-ietf-sipcore-digest-scheme-15.txt

From: [email-masked]
Date: Mon, 04 Nov 2019 05:46:05 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Session Initiation Protocol Core WG of the IETF.

        Title           : The Session Initiation Protocol (SIP) Digest Authentication Scheme
        Author          : Rifaat Shekh-Yusef
	Filename        : draft-ietf-sipcore-digest-scheme-15.txt
	Pages           : 9
	Date            : 2019-11-04

Abstract:
   This document updates RFC 3261 by updating the Digest Access
   Authentication scheme used by the Session Initiation Protocol (SIP)
   to add support for more secure digest algorithms, e.g., SHA-256 and
   SHA-512-256, to replace the obsolete MD5 algorithm.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-sipcore-digest-scheme/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-sipcore-digest-scheme-15
https://datatracker.ietf.org/doc/html/draft-ietf-sipcore-digest-scheme-15

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-sipcore-digest-scheme-15

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Rifaat Shekh-Yusef <[email-masked]>
Date: Mon, 4 Nov 2019 08:48:18 -0500

All,

I think this version of the draft addresses all recent comments.
Please, take a look and let me know if I missed anything.

Regards,
 Rifaat

On Mon, Nov 4, 2019 at 8:46 AM <[email-masked]> wrote:

> _______________________________________________
> sipcore mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sipcore
>

---

From: Christer Holmberg <[email-masked]>
Date: Mon, 4 Nov 2019 14:09:45 +0000

Hi,

One minor thing. The text says:

“by the length of the value of the algorithm used,”

I am not sure what “value of the algorithm” means. Don’t you mean “value created by the algorithm”, “algorithm output value”, or something?

Regards,

Christer

From: sipcore <[email-masked]> on behalf of Rifaat Shekh-Yusef <[email-masked]>
Date: Monday, 4 November 2019 at 15.48
To: "[email-masked]" <[email-masked]>
Subject: Re: [sipcore] I-D Action: draft-ietf-sipcore-digest-scheme-15.txt

All,

Regards,
 Rifaat

On Mon, Nov 4, 2019 at 8:46 AM <[email-masked]<mailto:[email-masked]>> wrote:

Abstract:

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org>.

_______________________________________________
sipcore mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/sipcore

---

From: Rifaat Shekh-Yusef <[email-masked]>
Date: Mon, 4 Nov 2019 09:15:07 -0500

I will fix that.

Regards,
 Rifaat

On Mon, Nov 4, 2019 at 9:09 AM Christer Holmberg <
[email-masked]> wrote:

> I am not sure what “value of the algorithm” means. Don’t you mean “value
> created by the algorithm”, “algorithm output value”, or something?
>
>
>
> Regards,
>
>
>
> Christer
>
>
>
> *From: *sipcore <[email-masked]> on behalf of Rifaat
> Shekh-Yusef <[email-masked]>
> *Date: *Monday, 4 November 2019 at 15.48
> *To: *"[email-masked]" <[email-masked]>
> *Subject: *Re: [sipcore] I-D Action:
> draft-ietf-sipcore-digest-scheme-15.txt
>
>
>
> All,
>
>
>