Subject: [sipcore] Éric Vyncke's No Objection on draft-ietf-sipcore-locparam-05: (with COMMENT)

From: Éric Vyncke via Datatracker <[email-masked]>
Date: Sun, 02 Feb 2020 07:45:11 -0800

Éric Vyncke has entered the following ballot position for
draft-ietf-sipcore-locparam-05: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-sipcore-locparam/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Thank you for the work put into this document. I found the document easy to
read even for a non SIP-fluent person like me.

I have just one non-blocking comment/question. Your reply will be appreciated.

-- Section 7 --
If the source of location is critical, then I wonder why this source is not
cryptographically authenticated... Having hop-by-hop TLS protection is not
enough probably as the UE (or any adverse proxy on the path) could insert a
fake Geoloc with a fake loc-src.

I hope that this helps to improve the document,

Regards,

-éric

---

From: <[email-masked]>
Date: Mon, 10 Feb 2020 09:56:00 +0000

Hi,
Thank you for your comment.
This document updates RFC6442. We are using the security and privacy considerations within RFC6442 which is also addressing encryption. We have not repeated all security considerations and ruling as stated in RFC6442 to avoid duplication.

I hope this is OK for you.

Best Regards

Roland 

-----Ursprüngliche Nachricht-----
Von: Éric Vyncke via Datatracker <[email-masked]> 
Gesendet: Sonntag, 2. Februar 2020 16:45
An: The IESG <[email-masked]>
Cc: [email-masked]; Jean Mahoney <[email-masked]>; [email-masked]; [email-masked]; [email-masked]
Betreff: Éric Vyncke's No Objection on draft-ietf-sipcore-locparam-05: (with COMMENT)

When responding, please keep the subject line intact and reply to all email addresses included in the To and CC lines. (Feel free to cut this introductory paragraph, however.)

Thank you for the work put into this document. I found the document easy to read even for a non SIP-fluent person like me.

-- Section 7 --
If the source of location is critical, then I wonder why this source is not cryptographically authenticated... Having hop-by-hop TLS protection is not enough probably as the UE (or any adverse proxy on the path) could insert a fake Geoloc with a fake loc-src.

Regards,

-éric

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Wed, 19 Feb 2020 14:42:55 +0000

Roland

Sorry for the belated reply but my excuse was a white sand beach and blue sky... more attractive than your document even if interesting and useful ;-)

I am trusting you and my security / ART AD colleagues on this one.

Regards and thank you for your reply

-éric

On 10/02/2020, 10:56, "[email-masked]" <[email-masked]> wrote:

    Hi,

    Best Regards
    
    Roland 
    
    -----Ursprüngliche Nachricht-----
    Von: Éric Vyncke via Datatracker <[email-masked]> 
    Gesendet: Sonntag, 2. Februar 2020 16:45
    An: The IESG <[email-masked]>
    Cc: [email-masked]; Jean Mahoney <[email-masked]>; [email-masked]; [email-masked]; [email-masked]
    Betreff: Éric Vyncke's No Objection on draft-ietf-sipcore-locparam-05: (with COMMENT)

    

    
    -- Section 7 --

    Regards,
    
    -éric