Subject: [sipcore] Alexey Melnikov's No Objection on draft-ietf-sipcore-locparam-05: (with COMMENT)

From: Alexey Melnikov via Datatracker <[email-masked]>
Date: Thu, 06 Feb 2020 04:06:30 -0800

Alexey Melnikov has entered the following ballot position for
draft-ietf-sipcore-locparam-05: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-sipcore-locparam/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

**********************************************************************
* Note, that I am conducting an experiment when people aspiring to be*
* Area Directors get exposed to AD work ("AD shadowing experiment"). *
* As a part of this experiment they get to review documents on IESG  *
* telechats according to IESG Discuss criteria document and their    *
* comments get relayed pretty much verbatim to relevant editors/WGs. *
* As an AD I retain responsibility in defending their position when  *
* I agree with it.                                                   *
* Recipients of these reviews are encouraged to reply to me directly *
* about perceived successes or failures of this experiment.          *
**********************************************************************

The following comments were provided by Benjamin Schwartz <[email-masked]>:

Benjamin would have balloted *YES* on this document.

## Section 1

Typo: “to identity itself”

Purpose: “How the entity adding the locationValue to the header field obtains
the location information is out of scope of this document.” -> OK, but if this
document isn’t intending to change the semantic intent of the Geolocation
header, then it should say so.  In the current text, it’s hard to tell whether
the field indicates the location of the endpoint or the intermediary.  Some
text like “this parameter does not alter the subject of the locationValue”
would help.

## Section 7

“If such trust domain is not given, it is strongly recommended to delete the
location information.” -> Is this consistent with the example in Figure 2?  I
think this is worth clarifying in the example text.

---

From: <[email-masked]>
Date: Mon, 10 Feb 2020 07:00:22 +0000

Hi,
Thank you for your comments.
I have incorporated your proposals as below mentioned.

Best Regards

Roland

-----Ursprüngliche Nachricht-----
Von: sipcore <[email-masked]> Im Auftrag von Alexey Melnikov via Datatracker
Gesendet: Donnerstag, 6. Februar 2020 13:07
An: The IESG <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]
Betreff: [sipcore] Alexey Melnikov's No Objection on draft-ietf-sipcore-locparam-05: (with COMMENT)

When responding, please keep the subject line intact and reply to all email addresses included in the To and CC lines. (Feel free to cut this introductory paragraph, however.)

## Section 1

[RJ]: done

Purpose: “How the entity adding the locationValue to the header field obtains the location information is out of scope of this document.” -> OK, but if this document isn’t intending to change the semantic intent of the Geolocation header, then it should say so.  In the current text, it’s hard to tell whether the field indicates the location of the endpoint or the intermediary.  Some text like “this parameter does not alter the subject of the locationValue”
would help.

[RJ] I have added the following sentence. I hope this is OK
   ..... is out of scope of this document. 
    	Please note that the "loc-src" parameter field does not alter the subject of the locationValue.

## Section 7

“If such trust domain is not given, it is strongly recommended to delete the location information.” -> Is this consistent with the example in Figure 2?  I think this is worth clarifying in the example text.

[RJ]: I have changed the test below Figure 2 as follows:

Figure 2: Example Location Request (in trust domain)

_______________________________________________
sipcore mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/sipcore

---

From: Ben Schwartz <[email-masked]>
Date: Mon, 10 Feb 2020 11:23:52 -0500

OK, thank you for making those changes.

On Mon, Feb 10, 2020 at 2:00 AM <[email-masked]> wrote:

> Cc: [email-masked]; [email-masked];
> [email-masked]; [email-masked]
> Betreff: [sipcore] Alexey Melnikov's No Objection on
> draft-ietf-sipcore-locparam-05: (with COMMENT)
>
> Purpose: “How the entity adding the locationValue to the header field
> obtains the location information is out of scope of this document.” -> OK,
> but if this document isn’t intending to change the semantic intent of the
> Geolocation header, then it should say so.  In the current text, it’s hard
> to tell whether the field indicates the location of the endpoint or the
> intermediary.  Some text like “this parameter does not alter the subject of
> the locationValue”
> would help.
>
> “If such trust domain is not given, it is strongly recommended to delete
> the location information.” -> Is this consistent with the example in Figure
> 2?  I think this is worth clarifying in the example text.
>