Subject: [sipcore] I-D Action: draft-ietf-sipcore-sip-token-authnz-08.txt

From: [email-masked]
Date: Tue, 18 Feb 2020 17:17:17 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Session Initiation Protocol Core WG of the IETF.

        Title           : Third-Party Token-based Authentication and Authorization for Session Initiation Protocol (SIP)
        Authors         : Rifaat Shekh-Yusef
                          Christer Holmberg
                          Victor Pascual
	Filename        : draft-ietf-sipcore-sip-token-authnz-08.txt
	Pages           : 13
	Date            : 2020-02-18

Abstract:
   This document defines a SIP mechanism that relies on the OAuth 2.0
   and OpenID Connect Core 1.0 to enable delegation of the user
   authentication and SIP registration authorization to a third-party.
   The document updates RFC 3261.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-sipcore-sip-token-authnz/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-sipcore-sip-token-authnz-08
https://datatracker.ietf.org/doc/html/draft-ietf-sipcore-sip-token-authnz-08

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-sipcore-sip-token-authnz-08

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Rifaat Shekh-Yusef <[email-masked]>
Date: Tue, 18 Feb 2020 20:22:47 -0500

All,

This new version of the document has few editorial changes.
Many thanks to Jean Mahoney for these editorial changes and the conversion
of the XML source file from v2 to v3.

Regards,
 Rifaat

On Tue, Feb 18, 2020 at 8:17 PM <[email-masked]> wrote:

>         Title           : Third-Party Token-based Authentication and
> Authorization for Session Initiation Protocol (SIP)
> _______________________________________________
> sipcore mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sipcore
>

---

From: "A. Jean Mahoney" <[email-masked]>
Date: Tue, 18 Feb 2020 22:02:44 -0600

I just converted it to v3. I still have edits on my todo list. I'll make 
nit fixes in GitHub and post my comments to the list regarding bigger 
issues. (Like, what's a reference token?)

Thanks!
Jean

On 2/18/20 7:22 PM, Rifaat Shekh-Yusef wrote:
> Many thanks to Jean Mahoney for these editorial changes and the 
> conversion of the XML source file from v2 to v3.
> 
> Regards,
>   Rifaat
> 
> 
> On Tue, Feb 18, 2020 at 8:17 PM <[email-masked] 
> <mailto:[email-masked]>> wrote:
> 
> 
>              Title           : Third-Party Token-based Authentication
>     and Authorization for Session Initiation Protocol (SIP)
>     https://datatracker.ietf..org/doc/html/draft-ietf-sipcore-sip-token-authnz-08
>     <https://datatracker.ietf.org/doc/html/draft-ietf-sipcore-sip-token-authnz-08>
> 
>     until the htmlized version and diff are available at tools.ietf.org
>     <http://tools.ietf.org>.
> 
>     [email-masked] <mailto:[email-masked]>

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 20 Feb 2020 11:06:39 +0000

Hi,

>    issues. (Like, what's a reference token?)
  
A reference token does not contain any metadata or identity information about the user - it is just a reference to such information stored elsewhere. It is also sometimes called an opaque token. We'll clarify that.

Regards,

Christer