Subject: Re: [sipcore] [EXTERNAL] Re: please review and comment on draft-penar-sipcore-ratingprovided-00

From: Richard Shockey <[email-masked]>
Date: Sun, 21 Jun 2020 16:03:04 -0400

I really like this idea as well. 

— 
Richard Shockey

Shockey Consulting LLC

Chairman of the Board SIP Forum

www.shockey.us

www.sipforum.org

richard<at>shockey.us

Skype-Linkedin-Facebook –Twitter  rshockey101

PSTN +1 703-593-2683

On 6/16/20, 7:51 PM, "sipcore on behalf of Russ Penar" <[email-masked] on behalf of russp=[email-masked]> wrote:

    That is an interesting idea Dale thank you,  

    The spirit of my proposal is something to help out specifically in the current call analytics environment, and is hopefully lightweight to implement.  That said, as I read through your email a couple questions came to mind.

    ".. token in the INVITE which would be recorded with the voicemail message to the callee B."

    Should there be any assumption about unanswered calls 'always' going to voicemail?  Perhaps its an exception case, but curious on folks' perspective on the assumption. 

    "...B's call-back could include a token that A could attach to future INVITEs to B as evidence that the call was approved by B and thus avoid being spam-filtered."

    Assuming there are many one-way calling relationships would storage/search requirements for the tokens eventually outweigh the benefit?

    Best regards,
    Russ

    -----Original Message-----
    From: sipcore <[email-masked]> On Behalf Of Dale R. Worley
    Sent: Sunday, June 14, 2020 5:26 PM
    To: [email-masked]
    Subject: [EXTERNAL] Re: [sipcore] please review and comment on draft-penar-sipcore-ratingprovided-00

    I don't know of this question is related to this draft, but reading about this draft brings it to mind:  It seems like an ideal system would allow the potentially-spam caller A to put some sort of token in the INVITE which would be recorded with the voicemail message to the callee B.  Then if B wanted to contact A, B could send an INVITE that includes the token, thus allowing A to process B's call as a continuation of the original call.  Similarly, B's call-back could include a token that A could attach to future INVITEs to B as evidence that the call was approved by B and thus avoid being spam-filtered.

    Dale

    _______________________________________________
    sipcore mailing list
    [email-masked]
    https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fsipcore&amp;data=02%7C01%7Crussp%40microsoft.com%7C13a9320a54304ae3094c08d810c2a591%7C72f988bf86f141af91ab2d7cd011db47%7C0%7C0%7C637277775480546881&amp;sdata=06yb8PXAxBL1jja6QM2P67vV6m5V7VcjYzxonGo6uS4%3D&amp;reserved=0

    _______________________________________________
    sipcore mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/sipcore

---

From: Richard Shockey <[email-masked]>
Date: Sun, 21 Jun 2020 18:37:34 -0400

The real advantage here is the use case only looks like a BCP and we don’t get trapped into the endless fight over a new SIP response code.

This is in perfect alignment with RFC 8688 aka the SIP 608 rejected error code.  If SP's want to use it fine if they don't OK but I do know what the regulators might think. 

And yours truly will be dealing with that tommrrow. 

https://www.sipforum.org/news-events/stir-shaken-virtual-summit/schedule/

For the rest of you folks we do know what the use case is it’s the US TRACED act.  We have a legislative mandate and its going to be enforced. It also might push forward the issue of all IP interconnection.  

Film at 11. 

IMHO this needs to get formalized in SIPCORE ASAP.  I think Russ needs to weigh his options here and lets keep the discussion going but I'll certainly support some kind of draft along these lines as a formal SIPCORE WG item.   There is no need to go to DISPATCH on this. 

As for something catchy .. CREAM really ? Where is the liquor component.  All new SIP protocols or extentions MUST have a reference to booze or James Bond. 

On 6/21/20, 4:47 PM, "Gorman, Pierce A [CTO]" <[email-masked]> wrote:

    Me too!

    End entities exchanging information elements that could be used to authenticate and authorize a communications attempt sounds good to me.  We need a catchy acronym.  I'll volunteer SIGNET.

    Hmmm, on second thought, since it's based on SIP, maybe we should use CREAM; Communications Relationship Extensible Address Method.

    https://access.atis.org/apps/group_public/document.php?document_id=43295   See slide #8.

    Pierce

    -----Original Message-----
    From: sipcore <[email-masked]> On Behalf Of Richard Shockey
    Sent: Sunday, June 21, 2020 3:03 PM
    To: Russ Penar <russp=[email-masked]>; Dale R. Worley <[email-masked]>; [email-masked]
    Subject: Re: [sipcore] [EXTERNAL] Re: please review and comment on draft-penar-sipcore-ratingprovided-00

    — 
    Richard Shockey

    Shockey Consulting LLC

    https://nam01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.shockey.us%2F&amp;data=02%7C01%7Cpierce.gorman%40sprint.com%7Cf7486b9afdd0449d39eb08d8161e2514%7C4f8bc0acbd784bf5b55f1b31301d9adf%7C0%7C0%7C637283666017587982&amp;sdata=8ju5zVIGSCJAkS5yEAy%2B8vbwBP5oLPuNq1haHwIQ1pQ%3D&amp;reserved=0

    https://nam01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.sipforum.org%2F&amp;data=02%7C01%7Cpierce.gorman%40sprint.com%7Cf7486b9afdd0449d39eb08d8161e2514%7C4f8bc0acbd784bf5b55f1b31301d9adf%7C0%7C0%7C637283666017587982&amp;sdata=OTxGsVDk9ua3fyaPy5y8t%2Fy8lGlWlJ8FtxyoXdNiLbI%3D&amp;reserved=0

    richard<at>shockey.us

    PSTN +1 703-593-2683

        Best regards,
        Russ

        -----Original Message-----
        From: sipcore <[email-masked]> On Behalf Of Dale R. Worley
        Sent: Sunday, June 14, 2020 5:26 PM
        To: [email-masked]
        Subject: [EXTERNAL] Re: [sipcore] please review and comment on draft-penar-sipcore-ratingprovided-00

        Dale

        _______________________________________________
        sipcore mailing list
        [email-masked]
        https://nam01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fsipcore&amp;data=02%7C01%7Cpierce.gorman%40sprint.com%7Cf7486b9afdd0449d39eb08d8161e2514%7C4f8bc0acbd784bf5b55f1b31301d9adf%7C0%7C0%7C637283666017587982&amp;sdata=BpZlh%2FaK5Z4ixZ9s0kk91hL71J%2FCpYg%2BCuXE8UQ2gSk%3D&amp;reserved=0

        _______________________________________________
        sipcore mailing list
        [email-masked]
        https://nam01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fsipcore&amp;data=02%7C01%7Cpierce.gorman%40sprint.com%7Cf7486b9afdd0449d39eb08d8161e2514%7C4f8bc0acbd784bf5b55f1b31301d9adf%7C0%7C0%7C637283666017587982&amp;sdata=BpZlh%2FaK5Z4ixZ9s0kk91hL71J%2FCpYg%2BCuXE8UQ2gSk%3D&amp;reserved=0

    _______________________________________________
    sipcore mailing list
    [email-masked]
    https://nam01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fsipcore&amp;data=02%7C01%7Cpierce.gorman%40sprint.com%7Cf7486b9afdd0449d39eb08d8161e2514%7C4f8bc0acbd784bf5b55f1b31301d9adf%7C0%7C0%7C637283666017587982&amp;sdata=BpZlh%2FaK5Z4ixZ9s0kk91hL71J%2FCpYg%2BCuXE8UQ2gSk%3D&amp;reserved=0

---

From: Russ Penar <[email-masked]>
Date: Wed, 24 Jun 2020 21:17:23 +0000

Thank you Rich and Pierce!

Couple thoughts based on discussions thus far;

1) I'd like to progress 1xx 'rated' draft, please see latest revision (01). https://datatracker.ietf.org/doc/draft-penar-sipcore-ratingprovided/
2) I'm open to partner with interested folks on other proposals in the same context, via separate drafts. 
	a) Dale and Pierce ideas on token exchange  - Fun names springing to mind are (bond) JAWS - J(ws) Authorization With S(ip) .. and  (bond & booze) SHOT - Signed Hashed Offer Token
	b) Ryan/Steve's idea on consuming and refactoring final responses

-----Original Message-----
From: sipcore <[email-masked]> On Behalf Of Richard Shockey
Sent: Sunday, June 21, 2020 3:38 PM
To: [email-masked]
Subject: Re: [sipcore] [EXTERNAL] Re: please review and comment on draft-penar-sipcore-ratingprovided-00

https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.sipforum.org%2Fnews-events%2Fstir-shaken-virtual-summit%2Fschedule%2F&amp;data=02%7C01%7Crussp%40microsoft.com%7C72cda5597c654f1a286708d81633b9c5%7C72f988bf86f141af91ab2d7cd011db47%7C0%7C0%7C637283758698759804&amp;sdata=dra%2F81nQmwG4RB28XJJXVtFlh84We4QpMqgfaO%2BKN4Y%3D&amp;reserved=0

Film at 11. 

    Me too!

    https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Faccess.atis.org%2Fapps%2Fgroup_public%2Fdocument.php%3Fdocument_id%3D43295&amp;data=02%7C01%7Crussp%40microsoft.com%7C72cda5597c654f1a286708d81633b9c5%7C72f988bf86f141af91ab2d7cd011db47%7C0%7C0%7C637283758698769798&amp;sdata=a55DTCzR9mrrs17rXrIWl6WwjuIuWvk%2B%2FCc%2FjEb7cW8%3D&amp;reserved=0   See slide #8.

    Pierce

    -----Original Message-----
    From: sipcore <[email-masked]> On Behalf Of Richard Shockey
    Sent: Sunday, June 21, 2020 3:03 PM
    To: Russ Penar <russp=[email-masked]>; Dale R. Worley <[email-masked]>; [email-masked]
    Subject: Re: [sipcore] [EXTERNAL] Re: please review and comment on draft-penar-sipcore-ratingprovided-00

    — 
    Richard Shockey

    Shockey Consulting LLC

    https://nam06.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.shockey.us%2F&amp;data=02%7C01%7Crussp%40microsoft.com%7C72cda5597c654f1a286708d81633b9c5%7C72f988bf86f141af91ab2d7cd011db47%7C0%7C0%7C637283758698769798&amp;sdata=u0LADtytnG%2FHeVaq2wKyKGeZ9KYkSKMmLXwVDYZ9d8s%3D&amp;reserved=0

    https://nam06.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.sipforum.org%2F&amp;data=02%7C01%7Crussp%40microsoft.com%7C72cda5597c654f1a286708d81633b9c5%7C72f988bf86f141af91ab2d7cd011db47%7C0%7C0%7C637283758698769798&amp;sdata=NGIBPm9Le1pKUNRuZt77fLXzk57J3h66d3nfDYpR8q0%3D&amp;reserved=0

    richard<at>shockey.us

    PSTN +1 703-593-2683

        Best regards,
        Russ

        -----Original Message-----
        From: sipcore <[email-masked]> On Behalf Of Dale R. Worley
        Sent: Sunday, June 14, 2020 5:26 PM
        To: [email-masked]
        Subject: [EXTERNAL] Re: [sipcore] please review and comment on draft-penar-sipcore-ratingprovided-00

        Dale

        _______________________________________________
        sipcore mailing list
        [email-masked]
        https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fsipcore&amp;data=02%7C01%7Crussp%40microsoft.com%7C72cda5597c654f1a286708d81633b9c5%7C72f988bf86f141af91ab2d7cd011db47%7C0%7C0%7C637283758698769798&amp;sdata=0wDnjhcL31QRZmi1GwEwbyIrg6qol1dRRQu2ry2Jnq4%3D&amp;reserved=0

        _______________________________________________
        sipcore mailing list
        [email-masked]
        https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fsipcore&amp;data=02%7C01%7Crussp%40microsoft.com%7C72cda5597c654f1a286708d81633b9c5%7C72f988bf86f141af91ab2d7cd011db47%7C0%7C0%7C637283758698769798&amp;sdata=0wDnjhcL31QRZmi1GwEwbyIrg6qol1dRRQu2ry2Jnq4%3D&amp;reserved=0

    _______________________________________________
    sipcore mailing list
    [email-masked]
    https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fsipcore&amp;data=02%7C01%7Crussp%40microsoft.com%7C72cda5597c654f1a286708d81633b9c5%7C72f988bf86f141af91ab2d7cd011db47%7C0%7C0%7C637283758698769798&amp;sdata=0wDnjhcL31QRZmi1GwEwbyIrg6qol1dRRQu2ry2Jnq4%3D&amp;reserved=0

_______________________________________________
sipcore mailing list
[email-masked]
https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fsipcore&amp;data=02%7C01%7Crussp%40microsoft.com%7C72cda5597c654f1a286708d81633b9c5%7C72f988bf86f141af91ab2d7cd011db47%7C0%7C0%7C637283758698769798&amp;sdata=0wDnjhcL31QRZmi1GwEwbyIrg6qol1dRRQu2ry2Jnq4%3D&amp;reserved=0

---

From: "Gorman, Pierce A [CTO]" <[email-masked]>
Date: Sun, 21 Jun 2020 20:47:13 +0000

Me too!

Pierce

-----Original Message-----
From: sipcore <[email-masked]> On Behalf Of Richard Shockey
Sent: Sunday, June 21, 2020 3:03 PM
To: Russ Penar <russp=[email-masked]>; Dale R. Worley <[email-masked]>; [email-masked]
Subject: Re: [sipcore] [EXTERNAL] Re: please review and comment on draft-penar-sipcore-ratingprovided-00

— 
Richard Shockey

Shockey Consulting LLC

richard<at>shockey.us

PSTN +1 703-593-2683

    Best regards,
    Russ

    -----Original Message-----
    From: sipcore <[email-masked]> On Behalf Of Dale R. Worley
    Sent: Sunday, June 14, 2020 5:26 PM
    To: [email-masked]
    Subject: [EXTERNAL] Re: [sipcore] please review and comment on draft-penar-sipcore-ratingprovided-00

    Dale