Subject: [smartpowerdir] Draft for PAP 1

From: Fred Baker <[email-masked]>
Date: Sat, 12 Jun 2010 12:39:31 -0700

Folks: George Arnold and David Su asked me the other day fo a draft to put into NIST's Priority Action Plan #1, which is intended to produce a recommendation regarding the role of IP in the Smart Grid. The requested draft specifies the minimal structure recommended for the use of IP in a secure network.

David: I started to write a new draft, and found myself in part generating new graphics and text, and in part cribbing a lot from http://tools.ietf.org/html/draft-baker-ietf-core. I wonder, what stops us from using an updated version of http://tools.ietf.org/html/draft-baker-ietf-core as this draft?

What needs to be covered, I think, is a relatively simple set of four pictures outlining four basic uses of the IP Protocol Suite:

+-------------------------+
|       Application       |
+-----+------+-----+------+
| TCP | SCTP | UDP | NORM |    Basic IP stack
+-----+------+-----+------+
|      Internet Layer     |
+-------------------------+
|        Link Layer       |
+-------------------------+
|      Physical Layer     |
+-------------------------+

+-------------------------+
|       Application       |
+-----+------+-----+------+
| TCP | SCTP | UDP | NORM |    IP Stack with IPsec in Transport Mode
+-----+------+-----+------+    (eg, HIP-like connectivity between two systems)
|    IP Security Layer    |
+-------------------------+
|      Internet Layer     |
+-------------------------+
|        Link Layer       |
+-------------------------+
|      Physical Layer     |
+-------------------------+

+-------------------------+
|       Application       |
+-----+------+-----+------+
| TCP | SCTP | UDP | NORM |    IP Stack with IPsec in Tunnel Mode
+-----+------+-----+------+    (IPsec VPN)
|      Internet Layer     |
+-------------------------+
|    IP Security Layer    |
+-------------------------+
|      Internet Layer     |
+-------------------------+
|        Link Layer       |
+-------------------------+
|      Physical Layer     |
+-------------------------+

+-------------------------+
|       Application       |
+------------+------------+
|   TLS      |   DTLS     |    IP Stack with TLS in the application
+-----+------+-----+------+    (Secured applications)
| TCP | SCTP | UDP | NORM |
+-----+------+-----+------+
|      Internet Layer     |
+-------------------------+
|        Link Layer       |
+-------------------------+
|      Physical Layer     |
+-------------------------+

and then some discussion of the use of the stack, which I think is mostly there, along with the use of DNS and DHCP.

I have asked and have not gotten any takers... I would really prefer that the security comments in this document were written by a security person. The comments I got from the security directorate told me what they thought was wrong, but didn't suggest what the right way to say it was, and we want to say it in the right way.

In any event, if draft-baker-ietf-core-protocols were cut down to that content, it seems to me that it pretty much fills the bill and is a reasonable IETF output that in fact could be pulled as text into the SGAC's Conceptual Model. 

Directorate, would you agree with that? David?

---

From: Zach Shelby <[email-masked]>
Date: Mon, 14 Jun 2010 15:39:08 +0300

Fred,

> David: I started to write a new draft, and found myself in part generating new graphics and text, and in part cribbing a lot from http://tools.ietf.org/html/draft-baker-ietf-core. I wonder, what st…

In my opinion, it definitely makes sense to just update the original draft. 

Zach

-- 
Zach Shelby, Chief Nerd, Sensinode Ltd.
http://zachshelby.org  - My blog "On the Internet of Things"
http://6lowpan.net - My book "6LoWPAN: The Wireless Embedded Internet"
Mobile: +358 40 7796297

---

From: Ralph Droms <[email-masked]>
Date: Wed, 16 Jun 2010 18:30:20 -0400

+1

- Ralph

On Jun 14, 2010, at 8:39 AM 6/14/10, Zach Shelby wrote:

>> David: I started to write a new draft, and found myself in part  
>> generating new graphics and text, and in part cribbing a lot from http://tools.ietf.org/html/draft-baker-ietf-core 
>> . I wonder, what stops us from using an updated version of http://tools.ietf.org/html/draft-baker-ietf-core 
>>  as this draft?
>

---

From: JP Vasseur <[email-masked]>
Date: Thu, 17 Jun 2010 07:18:32 +0200

Agree too.

JP.

---

From: Vint Cerf <[email-masked]>
Date: Thu, 17 Jun 2010 07:24:19 -0400

see attached edits/suggestions on Fred's excellent draft

vint

On Sat, Jun 12, 2010 at 3:39 PM, Fred Baker <[email-masked]> wrote:

> Folks: George Arnold and David Su asked me the other day fo a draft to put
> into NIST's Priority Action Plan #1, which is intended to produce a
> recommendation regarding the role of IP in the Smart Grid. The requested
> draft specifies the minimal structure recommended for the use of IP in a
> secure network.
>
> David: I started to write a new draft, and found myself in part generating
> new graphics and text, and in part cribbing a lot from
> http://tools.ietf.org/html/draft-baker-ietf-core. I wonder, what stops us
> from using an updated version of
> http://tools.ietf.org/html/draft-baker-ietf-core as this draft?
>
> What needs to be covered, I think, is a relatively simple set of four
> pictures outlining four basic uses of the IP Protocol Suite:
>
> and then some discussion of the use of the stack, which I think is mostly
> there, along with the use of DNS and DHCP.
>
> I have asked and have not gotten any takers... I would really prefer that
> the security comments in this document were written by a security person.
> The comments I got from the security directorate told me what they thought
> was wrong, but didn't suggest what the right way to say it was, and we want
> to say it in the right way.
>
> In any event, if draft-baker-ietf-core-protocols were cut down to that
> content, it seems to me that it pretty much fills the bill and is a
> reasonable IETF output that in fact could be pulled as text into the SGAC's
> Conceptual Model.
>

---

From: Fred Baker <[email-masked]>
Date: Thu, 17 Jun 2010 14:25:09 -0700

thanks

On Jun 17, 2010, at 4:24 AM, Vint Cerf wrote:

> <Baker-Internet-suite-draft-vc-comments.rtf>

http://www.ipinc.net/IPv4.GIF