Subject: Re: [smartpowerdir] Internet Protocols for the Smart Grid

From: Fred Baker <[email-masked]>
Date: Wed, 27 Oct 2010 10:48:40 -0700

Question - any opinions on NTT proprietary cipher suites in the draft-baker-ietf-core?

On Oct 27, 2010, at 10:31 AM, Satoru Kanno wrote:

> Dear Fred,
> 
> Thank you for your reply.
> 
> (2010/10/28 2:14), Fred Baker wrote:
>> What is the RFC number?
>> 
> 
> o TLS RFC
> RFC5932, Camellia Cipher Suites for TLS
> http://www.ietf.org/rfc/rfc5932.txt
> 
> o IPsec RFC
> RFC 5529, Modes of Operation for Camellia for Use with IPsec
> http://www.ietf.org/rfc/rfc5529.txt
> 
> RFC 4312, The Camellia Cipher Algorithm and Its Use With IPsec
> http://www.ietf.org/rfc/rfc4312.txt
> 
> Regards,
> Satoru
> 
>> On Oct 27, 2010, at 10:09 AM, Satoru Kanno wrote:
>> 
>>> Dear Fred,
>>> 
>>> My name is Satoru Kanno from NTT Software.
>>> I am working at standardization activity for Camellia cipher algorithm.
>>> 
>>> I found your internet draft for 'Internet Protocol for the Smart Grid'.
>>> 
>>> The your draft is referring to AES as suites as IPsec and TLS.
>>> We hope to add the Camellia's RFCs to your draft as OPTIONAL,
>>> because we strongly believe that Camellia has been specified in IPsec
>>> and TLS etc in IETF as well as AES.
>>> 
>>> Additionally, the Smart Grid is important topics for NTT :)
>>> 
>>> What do you think?
>>> 
>>> o Camellia Information
>>>  http://info.isl.ntt.co.jp/crypt/eng/camellia/intro.html
>>> 
>>> o Standardization related information
>>>  http://info.isl.ntt.co.jp/crypt/eng/camellia/standard.html
>>> 
>>> Best regards,
>>> 
>>> --
>>> Satoru Kanno
>>> 
>>> Security Business Unit
>>> Mobile and Security Solution Business Group
>>> NTT Software Corporation
>>> 
>>> e-mail: [email-masked]
>>> 
>> 
>> 
> 
> 
> -- 
> Satoru Kanno
> 
> Security Business Unit
> Mobile and Security Solution Business Group
> NTT Software Corporation
> 
> e-mail: [email-masked]
>

---

From: Vint Cerf <[email-masked]>
Date: Wed, 27 Oct 2010 13:58:25 -0400

I would have thought it preferable to avoid proprietary technology if
at all possible unless it is provided gratis and in perpetuity to
everyone?

v