Subject: [Spasm] Want us to do LDAP eaiMail, or decide for someone else to do it

From: Sean Leonard <[email-masked]>
Date: Thu, 30 Jun 2016 14:20:49 -0700

Hello LAMPS (formerly SPASM):

Further to my comments last week, it's important that the IETF 
standardize on how to encode internationalized e-mail addresses in 
Directories (LDAP), and by extension, Directory-related protocol slots.

It would be nice if this WG decides whether that work is in-scope for 
here. Ideally, to reduce implementation errors and duplicate code, the 
format of the attribute should be the same as the format of the eaiName 
GeneralName option under discussion. (I.e., if we decide on UTF8String 
with U-labels--which is what it's trending towards--we use the same 
format for the LDAP attribute.)

Conversely, if people feel that it's not in-scope here, then it should 
be considered in-scope for some other IETF area (or get directly 
sponsored), and coordinated appropriately with this eaiName work and 
with the LDAP folks.

So, uh, how shall this proceed? Should it get a time slot at the IETF 96 
meeting to talk about what people want to do?

Best regards,

Sean

PS I am fine with the premise that a certificate parser should not be 
trolling through the subject DN for said attribute. Note that the LDAP 
mail attribute is almost never included in a certificate subject DN so I 
see a putative LDAP eaiMail attribute pretty much the same way.

---

From: Alexey Melnikov <[email-masked]>
Date: Fri, 1 Jul 2016 07:49:51 +0100

Hi Sean,

> On 30 Jun 2016, at 22:20, Sean Leonard <[email-masked]> wrote:
> 
> Further to my comments last week, it's important that the IETF standardize on how to encode internationalized e-mail addresses in Directories (LDAP), and by extension, Directory-related protocol slots.

I agree that that would be desirable. There might have been LDAP related draft(s) on this topic already?

> It would be nice if this WG decides whether that work is in-scope for here. Ideally, to reduce implementation errors and duplicate code, the format of the attribute should be the same as the format of the eaiName GeneralName option under discussion. (I.e., if we decide on UTF8String with U-labels--which is what it's trending towards--we use the same format for the LDAP attribute.)
> 
> Conversely, if people feel that it's not in-scope here, then it should be considered in-scope for some other IETF area (or get directly sponsored), and coordinated appropriately with this eaiName work and with the LDAP folks.

Probably not in scope for this WG, but I would be happy to AD sponsor this one.

> So, uh, how shall this proceed? Should it get a time slot at the IETF 96 meeting to talk about what people want to do?

In LAMPS or somewhere else?
> 
> Best regards,
> 
> Sean
> 
> PS I am fine with the premise that a certificate parser should not be trolling through the subject DN for said attribute. Note that the LDAP mail attribute is almost never included in a certificate subject DN so I see a putative LDAP eaiMail attribute pretty much the same way.
> 
> 
> _______________________________________________
> Spasm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/spasm