Subject: [Spasm] BoF in Berlin or what?

From: Stephen Farrell <[email-masked]>
Date: Fri, 3 Jun 2016 16:01:15 +0100

Hiya,

We seem to be approaching but not finalising a charter.
Should we have a short BoF in Berlin [1] to discuss this
or would folks prefer we just keep doing it on the list?

If the former, then the BoF approval call (where the
IAB and IESG approve the BoFs to be held in Berlin) is
on June 10th, so please express your opinions on this
before next Tuesday, June 7th.

If the latter, and if we finalise charter text then
there is still time to formally create a WG before
Berlin, in which case do we think the putative WG
would want to meet? If so, again we'd want to get a
slot on the agenda and you'd want to speak up before
the 7th as well.

In either case where we want a meeting slot in Berlin,
that'd mean adding information to [2] (which I can do),
either for a BoF or as a placeholder for the in-formation
WG. I think one hour would be sufficient for either.

So - what do folks want?

FWIW, I'm happy to go with whatever consensus emerges
on the list, but tend to think that a BoF might be
right to give more folks a chance to give us input as
to which of the work items are likely to see deployment.

And in case some folks aren't familiar with IETF
meeting scheduling, if we do go for a f2f meeting slot
for this, we'll only know the specific day/time around
June 24.

Thanks,
S.

[1] https://ietf.org/meeting/96/index.html
[2] https://trac.tools.ietf.org/bof/trac/wiki#Security

---

From: Wei Chuang <[email-masked]>
Date: Fri, 3 Jun 2016 10:00:51 -0700

> WG. I think one hour would be sufficient for either.

I like the idea of meeting up in Berlin.  I would prefer as a WG so work on
the actual drafts could occur.  The draft charter has three items (given
below), two of which (1) and (3) are (I believe) non controversial, and I
hope doesn't get stuck due to the large discussion on item (2).  While
understandably that seems to be a bit more controversial, I hope the
details of which may be worked out in person in Berlin.

Draft work items:

1. Specify the way to include an i18n email address as a subject
   alternative name and an issuer alternative name.

2. Specify the processing for the Extended Key Usage certificate
   extension when it appears in the certificate of an intermediate
   certification authority.

3. Specify the way to use authenticated encryption in S/MIME.

> for this, we'll only know the specific day/time around

If a F2F is setup, can date preferences be taken into account?   In my case
I'll be able to attend for a subset of days due to family restrictions.  If
so can we collect this up in a separate renamed thread?

Thanks very much Stephen for sending this out.
-Wei

> _______________________________________________
> Spasm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/spasm
>
>

---

From: Stephen Farrell <[email-masked]>
Date: Fri, 3 Jun 2016 18:10:15 +0100

Hiya,

On 03/06/16 18:00, Wei Chuang wrote:
> If a F2F is setup, can date preferences be taken into account?   

Not very easily sorry, if you take a look at the IETF95 agenda [1]
and IEF96 requests from existing WGs,[2] and imagine trying to include
all the personnel issues (with ~1100 people) as additional constraints
I'm sure you'll agree that's too hard and would likely fail.

That said, it is worth knowing if significant contributors have
restrictions, as we can sometimes accommodate those, but with no
promises. If you think you're in that category for this meeting
(if there's consensus to want one) then just email me offlist and
we'll see how it pans out.

> In my case

I'd prefer we not do that TBH - too likely to cause disappointment.
And if all WGs did it, it could even be disruptive I guess;-)

Cheers,
S.

[1] https://datatracker.ietf.org/meeting/95/agenda.html
[2] https://datatracker.ietf.org/meeting/96/requests

---

From: Sean Leonard <[email-masked]>
Date: Fri, 3 Jun 2016 10:55:54 -0700

> we'll see how it pans out.

I am 50-50 about going to IETF96, but if there is an official SPASM F2F 
(whether WG or BoF) I will try to be there.

> or would folks prefer we just keep doing it on the list?

There is a scoping question that I believe is best answered in person. 
However, I do not know if the people who are most greatly affected, or 
who are most likely to implement (or not implement), will make it in person.

Draft work items:

The questions are: a) shall this list be expanded to additional points? 
b) shall the scope be expanded to include "general PKIX and S/MIME 
improvement issues"?

I think:
a) yes (and those points need to be fully enumerated before charter is 
finalized),
b) no -- but we should set a precedent for permissively allowing new 
scoped WGs to form to address novel or revision issues.

Sean

---

From: Russ Housley <[email-masked]>
Date: Mon, 6 Jun 2016 15:46:27 -0400

I’d like to see you start the chartering discussion.  If we cannot get to consensus, then we can hold a BOF to sort out any chartering issues.  Otherwise, we can get to the meat of the work.

Russ

---

From: Alexey Melnikov <[email-masked]>
Date: Tue, 7 Jun 2016 11:29:17 +0100

> I’d like to see you start the chartering discussion.  If we cannot get to consensus, then we can hold a BOF to sort out any chartering issues.  Otherwise, we can get to the meat of the work.
+1. We already started some specific work, I would rather we continue that.

---

From: Dmitry Belyavsky <[email-masked]>
Date: Tue, 7 Jun 2016 13:42:51 +0300

Dear Stephen,

> or would folks prefer we just keep doing it on the list?
I think it will be useful to see each other face-to-face. So I strongly
support the idea of BoF.

-- 
SY, Dmitry Belyavsky

---

From: Stephen Farrell <[email-masked]>
Date: Thu, 9 Jun 2016 14:43:25 +0100

Hiya,

So I got a suggestion off list to maybe delete items 2 and
4 from the charter [1] for now and to proceed to charter a
WG on that basis. The charter already says that addition of
new work items requires a re-charter, so if other bits of work
do need doing they can be added as real demand for them becomes
apparent (and assuming the WG turns out to be productive).

I think that leaves us with two choices:

a) delete items 2 and 4 from [1] and I'll start the formal
chartering process and schedule a WG meeting for Berlin,

or,

b) leave [1] as-is and we have a WG-forming BoF in Berlin.

As of now, I prefer (a).

I'll need to decide in the next 24 hours (the BoF scheduling
call is then), though it's not a final decision, as plan (a)
of course requires an at least 2-week period when the IETF
can comment on the new WG before it's formally created.

So, please yell now if you think (a) is unacceptable.

Cheers,
S.

PS: I think John Levine took an action to try check if
item 4 might actually get deployed when he's at the m3aawg
meeting next week. If that seems to garner consensus that
some reasonable level of deployment is likely, I'd be fine
with adding item 4 back during the chartering process.

[1] https://datatracker.ietf.org/doc/charter-ietf-spasm/

---

From: Yoav Nir <[email-masked]>
Date: Thu, 9 Jun 2016 17:19:22 +0300

> On 9 Jun 2016, at 4:43 PM, Stephen Farrell <[email-masked]> wrote:
> 
> 
> Hiya,
> 

Me too.

We can dedicate a portion of WG time to the discussion of practicality vs what we think is right in item #2. There’s no reason to hold back stuff that can progress more quickly while getting that sorted out.

Yoav

---

From: Sean Turner <[email-masked]>
Date: Thu, 9 Jun 2016 09:27:07 -0500

> We can dedicate a portion of WG time to the discussion of practicality vs what we think is right in item #2. There’s no reason to hold back stuff that can progress more quickly while getting that s…

Not yelling against a; I’m yelling for a.

spt

---

From: Dmitry Belyavsky <[email-masked]>
Date: Thu, 9 Jun 2016 17:36:58 +0300

Hello,

On Thu, Jun 9, 2016 at 5:27 PM, Sean Turner <[email-masked]> wrote:

> > We can dedicate a portion of WG time to the discussion of practicality
> vs what we think is right in item #2. There’s no reason to hold back stuff
> that can progress more quickly while getting that sorted out.
> >
> > Yoav
>

Me too

-- 
SY, Dmitry Belyavsky

---

From: Wei Chuang <[email-masked]>
Date: Thu, 9 Jun 2016 08:40:36 -0700

>> Not yelling against a; I’m yelling for a.

In case it wasn't clear from before, my vote is for a.

thanks,
-Wei

---

From: Russ Housley <[email-masked]>
Date: Thu, 9 Jun 2016 16:17:01 -0400

Stephen:

I think we should move forward with option a).

Russ

---

From: Russ Housley <[email-masked]>
Date: Tue, 14 Jun 2016 05:50:05 -0400

My understanding is that a one hour meeting slot for SPASM was approved for Berlin:

	https://mailarchive.ietf.org/arch/msg/spasm/23XSrpv0Gc8knO8bU0MAwsGGXKY

We have two work items in the most recent charter:

1. Specify the way to include an i18n email address as a subject
   alternative name and an issuer alternative name.
  draft-melnikov-spasm-eai-addresses is a proposal in this space. 

2. Specify the way to use authenticated encryption in S/MIME. 
   draft-schaad-rfc5751-bis is a proposal in this space.

Can we count on Alexey and Jim to give status and open issues on these drafts?

Russ

---

From: "Jim Schaad" <[email-masked]>
Date: Tue, 14 Jun 2016 02:59:37 -0700

I will definitely be able to do this.

> -----Original Message-----
> From: Spasm [mailto:[email-masked]] On Behalf Of Russ Housley
> Sent: Tuesday, June 14, 2016 2:50 AM
> To: [email-masked]
> Subject: Re: [Spasm] BoF in Berlin or what?
> 
> My understanding is that a one hour meeting slot for SPASM was approved
for
> Berlin:

---

From: Wei Chuang <[email-masked]>
Date: Wed, 15 Jun 2016 14:29:37 -0700

On Tue, Jun 14, 2016 at 2:50 AM, Russ Housley <[email-masked]> wrote:

> for Berlin:

If Alexey can't make this, I can give an update.

-Wei

---

From: Russ Housley <[email-masked]>
Date: Fri, 17 Jun 2016 15:16:24 -0400

Seing that SPASM has a one hour slot on the preliminary schedule and that document authors have agreed to do status and open issue presentations, I propose the following agenda…

	SPASM WG Agenda

	0)  Minutes, Jabber Scribe, Bluesheets
	1)  Agenda Bash
	2)  Status and open issues for draft-melnikov-spasm-eai-addresses
	3)  Status and open issues for draft-schaad-rfc5751-bis
	4)  WG document adoption
	5)  Wrap Up

The 4th item will be dropped if the IESG has not chartered the SPASM WG in time.

Thoughts?

Russ

---

From: "Jim Schaad" <[email-masked]>
Date: Fri, 17 Jun 2016 15:48:07 -0700

Given the constraints of a one-hour meeting, that looks reasonable.

Jim

> Sent: Friday, June 17, 2016 12:16 PM
> To: [email-masked]
> Seing that SPASM has a one hour slot on the preliminary schedule and that
> document authors have agreed to do status and open issue presentations, I
> propose the following agenda.
> 
> 	SPASM WG Agenda
>

---

From: Wei Chuang <[email-masked]>
Date: Fri, 17 Jun 2016 16:12:02 -0700

That schedule looks good to me too.

-Wei

On Fri, Jun 17, 2016 at 3:48 PM, Jim Schaad <[email-masked]> wrote:

> > The 4th item will be dropped if the IESG has not chartered the SPASM WG
> in
> > time.
> >
> > Thoughts?
> >
> > Russ
> >

---

From: Russ Housley <[email-masked]>
Date: Sun, 19 Jun 2016 14:16:41 -0400

I agree with Jim and Wei, we could easily add one agenda item for that topic.

Russ

On Jun 17, 2016, at 3:18 PM, Salz, Rich <[email-masked]> wrote:

> If CURDLE doesn't meet, could we handle those issues here?
> 
>>> I would really like to discuss how the ECDH and EdDSA algorithms are 
>>> being identified in PKIX, in part because I want it to match what is 
>>> being done in other groups.  So I would appreciate a meeting.
>> 
>> This needs to get sorted out.  It has an impact on the CMS-related drafts too.
>> That said, we might be able to sort it out on the mail list before Berlin.
> 
> --  
> Senior Architect, Akamai Technologies
> IM: [email-masked] Twitter: RichSalz
> 
> 
>> From: Russ Housley [mailto:[email-masked]]
>> Sent: Friday, June 17, 2016 3:16 PM
>> To: [email-masked]
>> propose the following agenda…
>> 
>> 	SPASM WG Agenda
>>