Subject: [Spasm] Updated draft-melnikov-spasm-eai-addresses

From: Wei Chuang <[email-masked]>
Date: Fri, 8 Jul 2016 00:16:50 -0700

Hi all,
This draft incorporates feedback about internationalization, unicode and
language updates.

Your feedback is very much welcome.

-Wei and Alexey

---------- Forwarded message ----------
From: <[email-masked]>
Date: Thu, Jul 7, 2016 at 11:35 PM
Subject: New Version Notification for
draft-melnikov-spasm-eai-addresses-03.txt
To: Alexey Melnikov <[email-masked]>, Weihaw Chuang <
[email-masked]>, Alexey Melnikov <[email-masked]>

A new version of I-D, draft-melnikov-spasm-eai-addresses-03.txt
has been successfully submitted by Weihaw Chuang and posted to the
IETF repository.

Name:           draft-melnikov-spasm-eai-addresses
Revision:       03
Title:          Internationalized Email Addresses in X.509 certificates
Document date:  2016-07-07
Group:          Individual Submission
Pages:          6
URL:            https://www.ietf.org/internet-drafts/draft-melnikov-spasm-
eai-addresses-03.txt
Status:         https://datatracker.ietf.org/doc/draft-melnikov-spasm-eai-
addresses/
Htmlized:       https://tools.ietf.org/html/draft-melnikov-spasm-eai-
addresses-03
Diff:           https://www.ietf.org/rfcdiff?url2=draft-melnikov-spasm-eai-
addresses-03

Abstract:
   This document defines a new name form for inclusion in the otherName
   field of an X.509 Subject Alternative Name extension that allows a
   certificate subject to be associated with an Internationalized Email
   Address.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: "Erik Andersen" <[email-masked]>
Date: Fri, 8 Jul 2016 17:41:07 +0200

Hi,

I wonder why you did not add a new component to the GeneralName data type as shown below. Processing will be easier and you do not have to defined a (long) IETF OID.

GeneralName ::= CHOICE {

  otherName                  [0]  INSTANCE OF OTHER-NAME,

  rfc822Name                 [1]  IA5String,

  dNSName                    [2]  IA5String,

  x400Address                [3]  ORAddress,

  directoryName              [4]  Name,

  ediPartyName               [5]  EDIPartyName,

  uniformResourceIdentifier  [6]  IA5String,

  iPAddress                  [7]  OCTET STRING,

  registeredID               [8]  OBJECT IDENTIFIER,

  ...,

  smtputf8Name name          [9]  UTF8String (SIZE (1..MAX))

}

Erik

Fra: Spasm [mailto:[email-masked]] På vegne af Wei Chuang
Sendt: 08 July 2016 09:17
Til: [email-masked]
Emne: [Spasm] Updated draft-melnikov-spasm-eai-addresses

Hi all,

This draft incorporates feedback about internationalization, unicode and language updates.

-Wei and Alexey

---------- Forwarded message ----------
From: <[email-masked] <mailto:[email-masked]> >
Date: Thu, Jul 7, 2016 at 11:35 PM
Subject: New Version Notification for draft-melnikov-spasm-eai-addresses-03.txt
To: Alexey Melnikov <[email-masked] <mailto:[email-masked]> >, Weihaw Chuang <[email-masked] <mailto:[email-masked]> >, Alexey Melnikov <[email-masked] <mailto:[email-masked]> >

Name:           draft-melnikov-spasm-eai-addresses
Revision:       03
Title:          Internationalized Email Addresses in X.509 certificates
Document date:  2016-07-07
Group:          Individual Submission
Pages:          6
URL:            https://www.ietf.org/internet-drafts/draft-melnikov-spasm-eai-addresses-03.txt
Status:         https://datatracker.ietf.org/doc/draft-melnikov-spasm-eai-addresses/
Htmlized:       https://tools.ietf.org/html/draft-melnikov-spasm-eai-addresses-03
Diff:           https://www.ietf.org/rfcdiff?url2=draft-melnikov-spasm-eai-addresses-03

Abstract:

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org <http://tools.ietf.org> .

The IETF Secretariat

---

From: Sean Leonard <[email-masked]>
Date: Fri, 8 Jul 2016 09:19:08 -0700

Hi Erik,

I actually advocated for exactly that, but pointed out it will require 
ITU-T cooperation. Is ITU-T willing to cooperate? :)

The other issue is that it will break software that was compiled with 
"pre-ellipsis technology". This likely includes most flavors of Windows 
up through and including Windows 10. It's also possible that software 
will choke but will return a successful partial decode of GeneralName 
productions prior to the [9] one, in which case, the proposal is doable 
as long as [9] is the last GeneralName. (Conveniently, it is likely that 
[9] will get sorted to the end in DER, which might save us.)

It would be good to do a comprehensive survey; I have not actually done 
any testing.

Regards,

Sean

On 7/8/2016 8:41 AM, Erik Andersen wrote:
>
> Hi,
>
> I wonder why you did not add a new component to the GeneralName data 
> type as shown below. Processing will be easier and you do not have to 
> defined a (long) IETF OID.
>
> GeneralName ::= CHOICE {
>
>    *smtputf8Name name          [9]  UTF8String (SIZE (1..MAX))*
>
> }
>
> Erik
>
> *Fra:*Spasm [mailto:[email-masked]] *På vegne af *Wei Chuang
> *Sendt:* 08 July 2016 09:17
> *Til:* [email-masked]
> *Emne:* [Spasm] Updated draft-melnikov-spasm-eai-addresses
>
> Hi all,
>
> From: <[email-masked] <mailto:[email-masked]>>
> To: Alexey Melnikov <[email-masked] 
> <mailto:[email-masked]>>, Weihaw Chuang <[email-masked] 
> <mailto:[email-masked]>>, Alexey Melnikov 
> <[email-masked] <mailto:[email-masked]>>
>
>
>
> URL: 
> https://www.ietf.org/internet-drafts/draft-melnikov-spasm-eai-addresses-03.txt
> Status: 
> https://datatracker.ietf.org/doc/draft-melnikov-spasm-eai-addresses/
> Htmlized: 
> https://tools.ietf.org/html/draft-melnikov-spasm-eai-addresses-03
> Diff: 
> https://www.ietf.org/rfcdiff?url2=draft-melnikov-spasm-eai-addresses-03
>
> Abstract:
> until the htmlized version and diff are available at tools.ietf.org 
> <http://tools.ietf.org>.
>
> The IETF Secretariat
>
>
>
> _______________________________________________
> Spasm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/spasm

---

From: "Erik Andersen" <[email-masked]>
Date: Sat, 9 Jul 2016 09:56:06 +0200

Hi Sean,

Sure, ITU-T will cooperate.

We have a little timing problem, but that should not stop us.

The eight edition of X.509  is due to approval at the ITU-T SG17 meeting in
September. It has features we need for Smart Grid security now. I cannot get
any new technical changes in right now. I can issue a defect report after
publication and in this way make it part of the eight edition. This should
not stop us from developing the solution within spasm and then later move it
into X.509.

The issue on breaking current implementations should be resolved.

Kind regards.

Erik

Fra: Sean Leonard [mailto:[email-masked]] 
Sendt: 08 July 2016 18:19
Til: Erik Andersen <[email-masked]>; 'Wei Chuang' <[email-masked]>;
[email-masked]
Emne: Re: [Spasm] Updated draft-melnikov-spasm-eai-addresses

Hi Erik,

I actually advocated for exactly that, but pointed out it will require ITU-T
cooperation. Is ITU-T willing to cooperate? :)

The other issue is that it will break software that was compiled with
"pre-ellipsis technology". This likely includes most flavors of Windows up
through and including Windows 10. It's also possible that software will
choke but will return a successful partial decode of GeneralName productions
prior to the [9] one, in which case, the proposal is doable as long as [9]
is the last GeneralName. (Conveniently, it is likely that [9] will get
sorted to the end in DER, which might save us.)

It would be good to do a comprehensive survey; I have not actually done any
testing.

Regards,

Sean

Hi,

I wonder why you did not add a new component to the GeneralName data type as
shown below. Processing will be easier and you do not have to defined a
(long) IETF OID.

GeneralName ::= CHOICE {

  dNSName                    [2]  IA5String,

  directoryName              [4]  Name,

  ...,

}

Erik

Fra: Spasm [mailto:[email-masked]] På vegne af Wei Chuang
Sendt: 08 July 2016 09:17
Til: [email-masked] <mailto:[email-masked]> 
Emne: [Spasm] Updated draft-melnikov-spasm-eai-addresses

Hi all,

-Wei and Alexey

---------- Forwarded message ----------
From: <[email-masked] <mailto:[email-masked]> >
Date: Thu, Jul 7, 2016 at 11:35 PM
Subject: New Version Notification for
draft-melnikov-spasm-eai-addresses-03.txt
To: Alexey Melnikov <[email-masked]
<mailto:[email-masked]> >, Weihaw Chuang <[email-masked]
<mailto:[email-masked]> >, Alexey Melnikov <[email-masked]
<mailto:[email-masked]> >

https://www.ietf.org/internet-drafts/draft-melnikov-spasm-eai-addresses-03.t
xt

Abstract:

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org
<http://tools.ietf.org> .

The IETF Secretariat

_______________________________________________
Spasm mailing list
[email-masked] <mailto:[email-masked]> 
https://www.ietf.org/mailman/listinfo/spasm