Subject: [lamps] I-D Action: draft-ietf-lamps-rfc5751-bis-07.txt

From: [email-masked]
Date: Fri, 13 Apr 2018 13:17:08 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Limited Additional Mechanisms for PKIX and SMIME WG of the IETF.

        Title           : Secure/Multipurpose Internet Mail Extensions (S/MIME) Version 4.0 Message Specification
        Authors         : Jim Schaad
                          Blake Ramsdell
                          Sean Turner
	Filename        : draft-ietf-lamps-rfc5751-bis-07.txt
	Pages           : 57
	Date            : 2018-04-13

Abstract:
   This document defines Secure/Multipurpose Internet Mail Extensions
   (S/MIME) version 4.0.  S/MIME provides a consistent way to send and
   receive secure MIME data.  Digital signatures provide authentication,
   message integrity, and non-repudiation with proof of origin.
   Encryption provides data confidentiality.  Compression can be used to
   reduce data size.  This document obsoletes RFC 5751.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-lamps-rfc5751-bis/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-lamps-rfc5751-bis-07
https://datatracker.ietf.org/doc/html/draft-ietf-lamps-rfc5751-bis-07

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-lamps-rfc5751-bis-07

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Sean Turner <[email-masked]>
Date: Fri, 13 Apr 2018 16:29:32 -0400

I just noticed this, but since SHA-1 got dropped in v4 should we change the example in 3.5.3.3 to use sha-256?

> On Apr 13, 2018, at 16:17, [email-masked] wrote:
> 
> 
> _______________________________________________
> Spasm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/spasm

---

From: Jim Schaad <[email-masked]>
Date: Fri, 13 Apr 2018 14:18:15 -0700

Did you update the encryption examples in the past - I don't know if they
are up to date either.

> -----Original Message-----
> From: Spasm <[email-masked]> On Behalf Of Sean Turner
> Sent: Friday, April 13, 2018 1:30 PM
> To: LAMPS <[email-masked]>
> Subject: Re: [lamps] I-D Action: draft-ietf-lamps-rfc5751-bis-07.txt
> 
> I just noticed this, but since SHA-1 got dropped in v4 should we change
the
> example in 3.5.3.3 to use sha-256?
> 
> > This draft is a work item of the Limited Additional Mechanisms for PKIX
and
> SMIME WG of the IETF.
> >
> >        Title           : Secure/Multipurpose Internet Mail Extensions
(S/MIME)
> Version 4.0 Message Specification
> >        Authors         : Jim Schaad
> >                          Blake Ramsdell
> >                          Sean Turner
> > Please note that it may take a couple of minutes from the time of
> > submission until the htmlized version and diff are available at
tools.ietf.org.

---

From: Sean Turner <[email-masked]>
Date: Fri, 13 Apr 2018 20:52:09 -0400

I did not update the encryption examples in 5751, but the example in this drafts s3.3 is different than the one in 5751.

spt

> On Apr 13, 2018, at 17:18, Jim Schaad <[email-masked]> wrote:
>