Subject: [lamps] I-D Action: draft-ietf-lamps-cms-hash-sig-06.txt

From: [email-masked]
Date: Tue, 26 Feb 2019 10:41:37 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Limited Additional Mechanisms for PKIX and SMIME WG of the IETF.

        Title           : Use of the HSS/LMS Hash-based Signature Algorithm in the Cryptographic Message Syntax (CMS)
        Author          : Russ Housley
	Filename        : draft-ietf-lamps-cms-hash-sig-06.txt
	Pages           : 14
	Date            : 2019-02-26

Abstract:
   This document specifies the conventions for using the the HSS/LMS
   hash-based signature algorithm with the Cryptographic Message Syntax
   (CMS).  In addition, the algorithm identifier and public key syntax
   are provided.  The HSS/LMS algorithm is one form of hash-based
   digital signature; it is described in [HASHSIG].

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-lamps-cms-hash-sig/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-lamps-cms-hash-sig-06
https://datatracker.ietf.org/doc/html/draft-ietf-lamps-cms-hash-sig-06

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-lamps-cms-hash-sig-06

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Russ Housley <[email-masked]>
Date: Tue, 26 Feb 2019 13:43:55 -0500

This removes the extraneous paragraph that was pointed out by Daniel.

I believe that all comments have been resolved, and the document is now ready to go to the IESG.

Russ

> On Feb 26, 2019, at 1:41 PM, [email-masked] wrote:
> 
>

---

From: Tim Hollebeek <[email-masked]>
Date: Tue, 26 Feb 2019 21:06:26 +0000

I agree.

-Tim

> -----Original Message-----
> From: Spasm <[email-masked]> On Behalf Of Russ Housley
> Sent: Tuesday, February 26, 2019 1:44 PM
> To: SPASM <[email-masked]>
> Subject: Re: [lamps] I-D Action: draft-ietf-lamps-cms-hash-sig-06.txt
> 
> > This draft is a work item of the Limited Additional Mechanisms for PKIX
and
> SMIME WG of the IETF.
> >
> >        Title           : Use of the HSS/LMS Hash-based Signature
Algorithm in the
> Cryptographic Message Syntax (CMS)
> >        Author          : Russ Housley
> > Please note that it may take a couple of minutes from the time of
> > submission until the htmlized version and diff are available at
tools.ietf.org.
> _______________________________________________
> Spasm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/spasm

---

From: Jim Schaad <[email-masked]>
Date: Tue, 26 Feb 2019 17:25:15 -0800

I have a small change to request.  I am happy if you deal with it at a later
date as long as it does not get lost.

In the ASN.1 module, the SIGNATURE-ALGORITHM definition should have an empty
or absent HASHES field.  There are no hash functions which are to be applied
prior to given the input to the signing function.  This would match what I
did for EdDSA.

Jim

> Sent: Tuesday, February 26, 2019 10:44 AM
and
Algorithm in the
tools.ietf.org.

---

From: Russ Housley <[email-masked]>
Date: Wed, 27 Feb 2019 12:26:23 -0500

Jim:

You are correct.  I missed this when I made the last update.  I will make the change now in my edit buffer.  I'll post it along with any other changes that result from IETF Last Call.

Russ

> On Feb 26, 2019, at 8:25 PM, Jim Schaad <[email-masked]> wrote:
>