Subject: [lamps] New work item proposal

From: "Brockhaus, Hendrik" <[email-masked]>
Date: Thu, 7 Feb 2019 16:46:57 +0000

Hi Russ
 
Currently we make use of CMP (Certificate Management Protocol, RFC4210) in several industrial use cases. Due to the complexity of RFC4210 and RFC4211 we specified a concrete and more lightweight profile of CMP addressing the industrial use cases we see. Following standardization of CMP profiles by ETSI and UNISIG that already exist, we strive for standardization of this lightweight industrial CMP profile as well.
RFC4210 already has some profiles in Appendix D and E, but on the one hand they focus more on human end entities and on the other hand they do not address the communication of the RA validating and forwarding messages to the CA. As the focus of our CMP profile is on automating certificate management in a m2m and IoT environment, we are looking for a working group within IETF to present our approach to. From the charter of LAMPS we believe this WG fits best for our proposal as it is a limited update to an existing PKIX standards document.
 
Currently I am working on transferring our internal CMP profile document into the IETF draft format and hope to be able to distribute a first version showing our approach until IETF 104.
 
Steffen and I are interested in the discussion of our proposal on profiling CMP for a more lightweight use in industrial environments and like to ask for acceptance of our draft as a new work item of LAMPS at IETF 104. 
Is there already a meeting session of the LAMPS WG planned for IETF 104 in Prague?
 
- Hendrik

---

From: Russ Housley <[email-masked]>
Date: Thu, 7 Feb 2019 12:00:54 -0500

Hendrick:

We can put an item at the bottom of the agenda.  The WG must focus on the chartered work first.  It would be very helpful for you to post in individual Internet-Draft so that people can review it in advance of the meeting.

Russ

> On Feb 7, 2019, at 11:46 AM, Brockhaus, Hendrik <[email-masked]> wrote:
> 
> Hi Russ
>

---

From: "Brockhaus, Hendrik" <[email-masked]>
Date: Thu, 7 Feb 2019 17:11:16 +0000

Russ

Thanks for your swift response. Being at the bottom of the agenda is totally OK for me as newcomer :-)
I will circulate an individual Internet-Draft in advance to the meeting.

Hendrik

> -----Ursprüngliche Nachricht-----
> Von: Russ Housley <[email-masked]>
> Gesendet: Donnerstag, 7. Februar 2019 18:01
> An: Brockhaus, Hendrik (CT RDA ITS SEA-DE)
> <[email-masked]>
> Cc: [email-masked]; Fries, Steffen (CT RDA ITS)
> <[email-masked]>
> Betreff: Re: [lamps] New work item proposal
> 
> Hendrick:
> 
> We can put an item at the bottom of the agenda.  The WG must focus on the
> chartered work first.  It would be very helpful for you to post in individual
> Internet-Draft so that people can review it in advance of the meeting.
> 
> Russ
> 
> 
> > Currently we make use of CMP (Certificate Management Protocol,
> RFC4210) in several industrial use cases. Due to the complexity of RFC4210
> and RFC4211 we specified a concrete and more lightweight profile of CMP
> addressing the industrial use cases we see. Following standardization of CMP
> profiles by ETSI and UNISIG that already exist, we strive for standardization
> of this lightweight industrial CMP profile as well.
> > RFC4210 already has some profiles in Appendix D and E, but on the one
> hand they focus more on human end entities and on the other hand they do
> not address the communication of the RA validating and forwarding
> messages to the CA. As the focus of our CMP profile is on automating
> certificate management in a m2m and IoT environment, we are looking for a
> working group within IETF to present our approach to. From the charter of
> LAMPS we believe this WG fits best for our proposal as it is a limited update
> to an existing PKIX standards document.
> >
> > Currently I am working on transferring our internal CMP profile document
> into the IETF draft format and hope to be able to distribute a first version
> showing our approach until IETF 104.
> >
> > Steffen and I are interested in the discussion of our proposal on profiling
> CMP for a more lightweight use in industrial environments and like to ask for
> acceptance of our draft as a new work item of LAMPS at IETF 104.