Subject: [lamps] Clarifications for ECC SPKI (aka RFC 5480)

From: Sean Turner <[email-masked]>
Date: Sat, 6 Jul 2019 17:55:47 -0400

Hi!

Back in March I asked how the keyEncipherment and dataEncipherment bits should be interpreted:
https://mailarchive.ietf.org/arch/msg/spasm/b38SFOeko1OT2uN4n52YxAy2B0Y
Tadahiko Ito and I have spun a draft that updates 5480 to clarify RFC 5480’s stance on these two bits.  In short (and this draft is very short), this draft aims to prohibit the use of these two bits with id-ecPublicKey as well as id-ecDH and id-ecMQV.  Please let us know what you think.

Oh and I forgot to include this in the draft, but there is a github repo:
https://github.com/seanturner/draft-turner-5480-ku-clarifications

spt

---

From: Russ Housley <[email-masked]>
Date: Sun, 7 Jul 2019 11:01:56 -0400

Sean:

I would like to see this document published.

The Abstract says:

   This document corrects this omission, but updating Section 3 of {{RFC5480}} to include semantics for these two key usages.

However, the document really makes it clear that these must not be set for key agreement algorithms.

Russ

> On Jul 6, 2019, at 5:55 PM, Sean Turner <[email-masked]> wrote:
> 
> Hi!
> 
> _______________________________________________
> Spasm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/spasm

---

From: Michael Richardson <[email-masked]>
Date: Sun, 07 Jul 2019 18:22:38 -0400

> Tadahiko Ito and I have spun a draft that updates 5480 to clarify RFC
    > 5480’s stance on these two bits.  In short (and this draft is very
    > short), this draft aims to prohibit the use of these two bits with
    > id-ecPublicKey as well as id-ecDH and id-ecMQV.  Please let us know
    > what you think.

So, would this mean not doing ECIES?

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Sean Turner <[email-masked]>
Date: Sun, 7 Jul 2019 21:22:21 -0400

In my haste to not do this at the last minute, I forgot to include a link to the I-D :)
https://datatracker.ietf.org/doc/draft-turner-5480-ku-clarifications/

Russ - can you clarify your comment? That sentence is in the Introduction.

spt

> On Jul 7, 2019, at 11:01, Russ Housley <[email-masked]> wrote:
> 
> Sean:
>

---

From: Russ Housley <[email-masked]>
Date: Mon, 8 Jul 2019 10:04:09 -0400

OLD:

This document corrects this omission, but updating Section 3
of [RFC5480] to include semantics for these two key usages.

NEW:

This document corrects this omission, by updating Section 3
of [RFC5480] to make it clear that neither keyEncipherment
nor the  dataEncipherment key usage bits are set for key
agreement algorithms.

> On Jul 7, 2019, at 9:22 PM, Sean Turner <[email-masked]> wrote:
>

---

From: Ryan Sleevi <[email-masked]>
Date: Mon, 8 Jul 2019 11:48:08 -0400

Thanks for the two of you in writing this update. As this is an area that
has caused some ambiguity for CAs that participate in Google and Mozilla's
CA programs, I appreciate the proposed clarifications and agree with the
text, so it would be great to see this document adopted and published.

On Sun, Jul 7, 2019 at 9:22 PM Sean Turner <[email-masked]> wrote:

> >   This document corrects this omission, but updating Section 3 of
> {{RFC5480}} to include semantics for these two key usages.
> >
> 5480’s stance on these two bits.  In short (and this draft is very short),
> this draft aims to prohibit the use of these two bits with id-ecPublicKey
> as well as id-ecDH and id-ecMQV.  Please let us know what you think.
> >>

---

From: "Salz, Rich" <[email-masked]>
Date: Mon, 8 Jul 2019 17:27:08 +0000

> Please let us know what you think.
  
Ship it.

---

From: Sean Turner <[email-masked]>
Date: Wed, 10 Jul 2019 19:37:37 -0400

This change is included in this PR:
https://github.com/seanturner/draft-turner-5480-ku-clarifications/pull/2
I will merge and spin a new version once the submission window reopens.

spt

> On Jul 8, 2019, at 10:04, Russ Housley <[email-masked]> wrote:
> 
> OLD:
>