Subject: [lamps] Request to add the CMP activities to the LAMPS charter

From: "Brockhaus, Hendrik" <[email-masked]>
Date: Thu, 25 Jul 2019 15:54:22 +0000

Russ, Tim

As discussed during the LAMPS WG session I presented both drafts on the CMP activities (Lightweight CMP Profile and CMP Updates) and the recharter proposal. It was agreed that a rechartering is needed to follow up on these drafts in the WG.

I want to ask the WG to forward this recharter text onwards to the IESG.
"As certificate management gets increasingly important in many environments, it needs to be tailored to the specific needs. CMP as existing protocol offers a vast range of options. As it is already being applied in different industrial environments it needs to be enhanced to more efficiently support of these use cases, crypto agility and specific communication relations on the one hand and profiled to the necessary functionality on the other hand to ease application and to better facilitate interoperable implementation."

Hendrik

---

From: Russ Housley <[email-masked]>
Date: Thu, 25 Jul 2019 12:55:23 -0400

Hendrik:

Thanks for renewing the discussion.  A quick scan of this thread in my email folders does not show a list of proposed milestones.  Please propose some.

Russ

> On Jul 25, 2019, at 11:54 AM, Brockhaus, Hendrik <[email-masked]> wrote:
> 
> Russ, Tim
>  
> “As certificate management gets increasingly important in many environments, it needs to be tailored to the specific needs. CMP as existing protocol offers a vast range of options. As it is already being applied in different industrial environments it needs to be enhanced to more efficiently support of these use cases, crypto agility and specific communication relations on the one hand and profiled to the necessary functionality on the other hand to ease application and to better facilitate interoperable implementation.”
>  
> Hendrik

---

From: "Brockhaus, Hendrik" <[email-masked]>
Date: Fri, 26 Jul 2019 09:04:47 +0000

Russ

I would like to complete both drafts until March 2020 so that the review could be completed until October 2020.
Therefore I propose October 2020 as milestone for RFC release of both documents.

Hendrik

Von: Russ Housley <[email-masked]>
Gesendet: Donnerstag, 25. Juli 2019 18:55
An: Brockhaus, Hendrik (CT RDA CST SEA-DE) <[email-masked]>
Cc: [email-masked]; Tim Hollebeek <[email-masked]>; Fries, Steffen (CT RDA CST) <[email-masked]>
Betreff: Re: Request to add the CMP activities to the LAMPS charter

Hendrik:

Russ

On Jul 25, 2019, at 11:54 AM, Brockhaus, Hendrik <[email-masked]<mailto:[email-masked]>> wrote:

Russ, Tim

Hendrik

---

From: Russ Housley <[email-masked]>
Date: Fri, 26 Jul 2019 13:45:23 -0400

I am just trying to simplify the language and provide a little bit of flexibility.  Please review the proposed text and milestones.

Russ

= = = = = = = 

8. As certificate management gets increasingly important in many
environments, it needs to be tailored to the specific needs. CMP is an
existing protocol offers a vast range of certificate management options,
and CMP is already being used in different industrial environments. The
LAMPS WG will develop a "lightweight" profile of CMP to more efficiently
support of these use cases and better facilitate interoperable
implementation, while preserving cryptographic algorithm agility.

March 2020 - WG adoption of Internet-Drafts for CMP

October 2020 - Forward CMP drafts to IESG for publication on the standards-track 

> On Jul 26, 2019, at 5:04 AM, Brockhaus, Hendrik <[email-masked]> wrote:
>

---

From: "Brockhaus, Hendrik" <[email-masked]>
Date: Mon, 29 Jul 2019 11:59:06 +0000

Just for clarity I would like to add the updates to CMP to the charter text as it is currently not covered by the general charter introduction.

New text:
Necessary updates and clarifications to CMP will be specified in a
separate document.

Hendrik

Von: Spasm <[email-masked]> Im Auftrag von Russ Housley
Gesendet: Freitag, 26. Juli 2019 19:45
An: [email-masked]
Betreff: Re: [lamps] Request to add the CMP activities to the LAMPS charter

Russ

= = = = = = =

On Jul 26, 2019, at 5:04 AM, Brockhaus, Hendrik <[email-masked]<mailto:[email-masked]>> wrote: