Subject: Re: [lamps] rfc7030-est clarifications and LAMPS charter

From: Sean Turner <[email-masked]>
Date: Mon, 5 Aug 2019 07:58:07 -0400

I think you have two choices:

1) Fix the  text
2) Fix the text and include a module

In either case fixing the text is* :

* This is basically what Russ suggested, but I do not think the name of the set should imply that the only attributes that can be used are defined in 7030.  Any attribute can be included so I changed “AttributesDefinedInRFC7030” to “CsrAttrSet”.

OLD:

CsrAttrs ::= SEQUENCE SIZE (0..MAX) OF AttrOrOID

   AttrOrOID ::= CHOICE (oid OBJECT IDENTIFIER, attribute Attribute }

   Attribute { ATTRIBUTE:IOSet } ::= SEQUENCE {
        type   ATTRIBUTE.&id({IOSet}),
        values SET SIZE(1..MAX) OF ATTRIBUTE.&Type({IOSet}{@type}) }

NEW:

CsrAttrs ::= SEQUENCE SIZE (0..MAX) OF AttrOrOID

   AttrOrOID ::= CHOICE {
       oid OBJECT IDENTIFIER,
       attribute Attribute {{AttrSet}}  }

   Attribute { ATTRIBUTE:IOSet } ::= SEQUENCE {
        type   ATTRIBUTE.&id({IOSet}),
        values SET SIZE(1..MAX) OF ATTRIBUTE.&Type({IOSet}{@type}) }

  AttrSet ATTRIBUTE ::= { CsrAttrSet }

  CsrAttrSet ATTRIBUTE ::= {
       aa-asymmDecryptKeyID,     -- see Section 4.4.1.2.
       … }

spt

> On Jul 31, 2019, at 16:48, Michael Richardson <[email-masked]> wrote:
> 
> Signed PGP part
> 
> Benjamin Kaduk <[email-masked]> wrote:
>>> Thinking about this some more, I think that the best way to resolve
>>> this errata is to provide an appendix with an ASN.1 module.  Here is
>>> my suggestion:
> 
>> That feels somewhat heavyweight for an erratum.  What are the pros/cons
>> of errata vs. small updating RFC?
> 
> The intention is to have a small updating RFC.
> 
> -- 
> ]               Never tell me the odds!                 | ipv6 mesh networks [
> ]   Michael Richardson, Sandelman Software Works        |    IoT architect   [
> ]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [
> 
> 
>

---

From: Russ Housley <[email-masked]>
Date: Mon, 5 Aug 2019 10:01:59 -0400

Sure.  That name change works for me.  I think adding the module can only improve interoperability.

Russ

> On Aug 5, 2019, at 7:58 AM, Sean Turner <[email-masked]> wrote:
> 
> _______________________________________________
> Spasm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/spasm

---

From: Sean Turner <[email-masked]>
Date: Mon, 5 Aug 2019 10:28:33 -0400

It sure couldn’t hurt. 

spt

> On Aug 5, 2019, at 10:01, Russ Housley <[email-masked]> wrote:
>