Subject: Re: [lamps] Proposed charter update regarding clarifications

From: Tim Hollebeek <[email-masked]>
Date: Wed, 14 Aug 2019 15:59:10 +0000

I’m not in favor of having to bother the AD for a re-charter for every minor clarification.  It is not a productive use of anyone’s time.

-Tim

From: Spasm <[email-masked]> On Behalf Of Ryan Sleevi
Sent: Saturday, July 27, 2019 12:20 PM
To: Stephen Farrell <[email-masked]>
Cc: LAMPS WG <[email-masked]>; Russ Housley <[email-masked]>
Subject: Re: [lamps] Proposed charter update regarding clarifications

On Sat, Jul 27, 2019 at 12:03 PM Stephen Farrell <[email-masked] <mailto:[email-masked]> > wrote:

On 27/07/2019 12:40, Russ Housley wrote:
> At the meeting in Montreal, we suggested a charter update to allow clarifications.  I suggest:
> 
> OLD:
> 
> In addition, the LAMPS WG may investigate other updates to documents
> produced by the PKIX and S/MIME WGs, but the LAMPS WG shall not adopt
> any of these potential work items without rechartering.
> 
> NEW:
> 
> In addition, the LAMPS WG may investigate other updates to documents
> produced by the PKIX and S/MIME WG. The LAMPS WG may produce
> clarifications where needed, but the LAMPS WG shall not adopt
> anything beyond clarifications without rechartering.
> 
> Thoughts?

Seems like another step on the road to re-creating PKIX
which at the end produced pointless paper. IMO nothing
should be done in this WG unless there's evidence the
work will be implemented and deployed.

S.

While I share the general sentiment, there is at least one clarification which has clear signs of deployment if there is IETF consensus on the text - 

https://tools.ietf.org/id/draft-turner-5480-ku-clarifications-00.html

For example, 

https://github.com/zmap/zlint/pull/293 is used by the majority of the publicly trusted CAs, directly or indirectly, and would actively enforce such text.

I too appreciate a narrowed scope, and wouldn’t be too miffed if any/every clarification was a matter for rechartering, and the WG only looked at chartering with this in scope.

---

From: "Salz, Rich" <[email-masked]>
Date: Wed, 14 Aug 2019 16:03:15 +0000

>I’m not in favor of having to bother the AD for a re-charter for every minor clarification.  It is not a productive use of anyone’s time.

I understand the motivation – nobody wants a zombie WG that shambles along forever without dying – but I think the concern is no longer warranted; we’re not scared of PKIX-Redux any more.

---

From: Stephen Farrell <[email-masked]>
Date: Wed, 14 Aug 2019 17:46:52 +0100

Hiya,

On 14/08/2019 17:03, Salz, Rich wrote:
> we’re not scared of PKIX-Redux any more.

At least one of us is. (Meaning me:-)

I do think the "who's gonna really implement
and will it get deployed" questions are still
needed in this space. I say that as someone
who has sinned in the past in exactly the
way I'd like to see us avoid repeating.

Cheers,
S

---

From: Russ Housley <[email-masked]>
Date: Tue, 20 Aug 2019 14:26:52 -0400

No many people have spoken.  I am assuming that is because many people take time off in August.  Right now roughly as many people support this addition as oppose it.  Please speak your mind.

Russ

> On Jul 27, 2019, at 7:40 AM, Russ Housley <[email-masked]> wrote:
> 
> Russ

---

From: "Salz, Rich" <[email-masked]>
Date: Tue, 20 Aug 2019 18:49:31 +0000

I am okay with the NEW text.  I am also not bothered too much by the OLD text.

---

From: Michael Richardson <[email-masked]>
Date: Tue, 20 Aug 2019 15:37:16 -0400

Russ Housley <[email-masked]> wrote:
    > No many people have spoken.  I am assuming that is because many people
    > take time off in August.  Right now roughly as many people support this
    > addition as oppose it.  Please speak your mind.

I'm in favour.