Subject: Re: [lamps] rfc7030-est clarifications of ASN.1

From: Jim Schaad <[email-masked]>
Date: Wed, 7 Aug 2019 20:22:48 -0700

Michael,

If you tried to learn it back that far, I don't think that it was even part
of the language at that point in time.  

Just a quick note on the module that Russ provided.  The import for the CMS
module is incorrect.  It should be:

     FROM CryptographicMessageSyntax-2010  -- [RFC6268]
       { iso(1) member-body(2) us(840) rsadsi(113549)
         pkcs(1) pkcs-9(9) smime(16) modules(0)
          id-mod-cms-2009(58) }

jim

-----Original Message-----
From: Spasm <[email-masked]> On Behalf Of Michael Richardson
Sent: Wednesday, July 31, 2019 6:25 PM
To: Russ Housley <[email-masked]>
Cc: LAMPS WG <[email-masked]>
Subject: Re: [lamps] rfc7030-est clarifications of ASN.1

Russ Housley <[email-masked]> wrote:
    >> I think this is not real ASN.1 syntax, but rather an indication for
me
    >> to insert more stuff?  Or is this something real that I don't
    >> understand.

    > No, this is real ASN.1 syntax.

okay.
It's something I once tried to learn, back in 1995, and I got as far as the
trivial stuff, but that was all.

I will incorporate your module into the clarifications document.

--
Michael Richardson <[email-masked]>, Sandelman Software Works  -=
IPv6 IoT consulting =-

---

From: Russ Housley <[email-masked]>
Date: Thu, 8 Aug 2019 10:28:35 -0400

Tanks Jim.  Yes, RFC 6268 obsoletes the module that I referenced.

Russ

> On Aug 7, 2019, at 11:22 PM, Jim Schaad <[email-masked]> wrote:
> 
> 
> Michael,
>