Subject: [lamps] Alexey Melnikov's Discuss on draft-ietf-lamps-cms-shakes-15: (with DISCUSS)

From: Alexey Melnikov via Datatracker <[email-masked]>
Date: Fri, 02 Aug 2019 23:55:28 -0700

Alexey Melnikov has entered the following ballot position for
draft-ietf-lamps-cms-shakes-15: Discuss

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-lamps-cms-shakes/

----------------------------------------------------------------------
DISCUSS:
----------------------------------------------------------------------

This is a fine document, but I have one quick question:

Values TBD1..TBD4 are not listed in the IANA Considerations section. Should they be?

---

From: Roman Danyliw <[email-masked]>
Date: Thu, 8 Aug 2019 04:50:33 +0000

> -----Original Message-----
> From: iesg [mailto:[email-masked]] On Behalf Of Alexey Melnikov via
> Datatracker
> Sent: Saturday, August 3, 2019 2:55 AM
> To: The IESG <[email-masked]>
> Cc: [email-masked]; [email-masked];
> [email-masked]; [email-masked]
> Subject: Alexey Melnikov's Discuss on draft-ietf-lamps-cms-shakes-15: (with
> DISCUSS)
> 
> When responding, please keep the subject line intact and reply to all email
> addresses included in the To and CC lines. (Feel free to cut this introductory
> paragraph, however.)
> 
> 

I don't think so.  This document and draft-ietf-lamps-pkix-shakes both need the same OIDs (but have no other dependence).  This latter draft is with the RFC Editor and does register these OIDs.  The current text, "[I-D.ietf-lamps-pkix-shake] [ EDNOTE: Update reference with the RFC when it is ready ]", was intended to guide the editor to replace TBD1-4 the OIDs when ietf-lamps-pkix-shake got published.  However, in re-reading the text now, the EDNOTE should actually read "Updated the TBD1-2 reference when the RFC is published".

Make sense?

Roman

---

From: "Alexey Melnikov" <[email-masked]>
Date: Thu, 08 Aug 2019 13:30:34 +0100

Hi Roman,

On Thu, Aug 8, 2019, at 5:50 AM, Roman Danyliw wrote:
> I don't think so.  This document and draft-ietf-lamps-pkix-shakes both 
> need the same OIDs (but have no other dependence).  This latter draft 
> is with the RFC Editor and does register these OIDs.

Ok, I understand now.

>  The current text, 
> "[I-D.ietf-lamps-pkix-shake] [ EDNOTE: Update reference with the RFC 
> when it is ready ]", was intended to guide the editor to replace TBD1-4 
> the OIDs when ietf-lamps-pkix-shake got published.  However, in 
> re-reading the text now, the EDNOTE should actually read "Updated the 
> TBD1-2 reference when the RFC is published".

There are 2 places TBD1-2 and TBD3-4. But yes, something like that.

I read the current text as just an instruction to change the draft name to the corresponding RFC number, so clarifying it would be great.

> Make sense?

Best Regards,
Alexey

---

From: Roman Danyliw <[email-masked]>
Date: Thu, 8 Aug 2019 12:36:44 +0000

Hi!

> From: Alexey Melnikov [mailto:[email-masked]]
> Sent: Thursday, August 8, 2019 8:31 AM
> To: Roman Danyliw <[email-masked]>; The IESG <[email-masked]>
> Cc: [email-masked]; [email-masked]; SPASM
> <[email-masked]>; Russ Housley <[email-masked]>
> Subject: Re: Alexey Melnikov's Discuss on draft-ietf-lamps-cms-shakes-15:
> (with DISCUSS)
> 
> Hi Roman,
> 
> > > From: iesg [mailto:[email-masked]] On Behalf Of Alexey
> > > Melnikov via Datatracker
> > > When responding, please keep the subject line intact and reply to
> > > all email addresses included in the To and CC lines. (Feel free to
> > > cut this introductory paragraph, however.)
> > >
> > >
> > > Please refer to
> > > https://www.ietf.org/iesg/statement/discuss-criteria.html
> > when it is ready ]", was intended to guide the editor to replace
> > TBD1-4 the OIDs when ietf-lamps-pkix-shake got published.  However, in
> I read the current text as just an instruction to change the draft name to the
> corresponding RFC number, so clarifying it would be great.

Exactly.  There are two places where this update needs to be made.

Thanks,
Roman

---

From: "Panos Kampanakis (pkampana)" <[email-masked]>
Date: Thu, 8 Aug 2019 14:56:46 +0000

Hi Alexey,

> I read the current text as just an instruction to change the draft name to the corresponding RFC number, so clarifying it would be great.

ACK. I will update the endnote to say "Update the TBD1-2 reference when the RFC is published" with any comments that come next. The EDNOTE serves as a reminder and since Roman will make sure the PKIX-SHAKEs RFC gets published first we will be all right. 

Panos

-----Original Message-----
From: Spasm <[email-masked]> On Behalf Of Alexey Melnikov
Sent: Thursday, August 08, 2019 8:31 AM
To: Roman D. Danyliw <[email-masked]>; The IESG <[email-masked]>
Cc: [email-masked]; [email-masked]; SPASM <[email-masked]>; Russ Housley <[email-masked]>
Subject: Re: [lamps] Alexey Melnikov's Discuss on draft-ietf-lamps-cms-shakes-15: (with DISCUSS)

Hi Roman,

Ok, I understand now.

Best Regards,
Alexey

_______________________________________________
Spasm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/spasm