Subject: [lamps] Adam Roach's Comment on draft-ietf-lamps-cms-mix-with-psk-06

From: Russ Housley <[email-masked]>
Date: Wed, 21 Aug 2019 16:57:29 -0400

Adam:

I was looking for something else and I stumbled across your COMMENT on draft-ietf-lamps-cms-mix-with-psk-06.

> Thanks for the work on this document. It seems like a useful tool
> to add to the crypto toolkit, and it does a good job of explaining
> exactly how to apply the described technique. I have one minor
> comment.
> 
> §7:
> 
> I don't generally have a deep understanding of the math behind
> encryption, and I didn't take the time to really align the technique
> in this document with the bit of crypto that I do understand, so
> forgive me if this is a naive observation: I was somewhat surprised
> to see no text in here regarding the advisability (or lack thereof)
> regarding re-use of PSKs across different sessions.

I suggest this additional sentence to Section 2 to address your comment:

   A PSK is expected to be used with many messages, with a
   lifetime of weeks or months.

Russ

---

From: Adam Roach <[email-masked]>
Date: Wed, 21 Aug 2019 16:31:50 -0500

>     lifetime of weeks or months.

Yep, that sounds good to me. Thanks!

/a