Subject: [Speechsc] speechsc as a first-level protocol

From: "Eric Burger" <[email-masked]>
Date: Thu, 8 May 2003 14:21:17 -0400

Is there consensus on raising speechsc to being a first-level protocol?  That is, it will NOT be embedded in SIP, RTSP, or :-) SNMP?

Does anyone strongly object?

Would anyone be really upset if it isn't?

Is there value to it being a first-level protocol inside an existing protocol?  That is, use the session establishment and proxy infrastructure of SIP or RTSP and have speechsc-specific primitives as protocol extensions.

> -----Original Message-----
> From: Brian Eberman [mailto:[email-masked]]
> Sent: Mon, May 05, 2003 3:13 PM
> To: Eric Burger; IETF SPEECHSC (E-mail)
> Subject: RE: [Speechsc] Administrative Fiat
> 
> 
> Eric,
> 
> Seems to be a bit of a consensus here. What are the next steps to be
> completed?
> 
> -Brian E.
> 
> Director Product Management and Services
> SpeechWorks International
> 695 Atlantic Avenue
> Boston, MA 02111
> 617 428 4444
> 
> 
> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]]On Behalf
> Of Rajiv Dharmadhikari
> Sent: Friday, April 25, 2003 12:51 PM
> To: [email-masked]; Eric Burger; IETF SPEECHSC (E-mail)
> Subject: RE: [Speechsc] Administrative Fiat
> 
> 
> Brian,
> 
> Can you resend the final draft of the protocl evaluation 
> analysis to the
> initial team? What is left to be completed? Let's get it out 
> of the way.. I
> am willing do complete my part since I don't know BEEP, COBOL 
> and CORBA :-)
> 
> Thanks,
> 
> -Rajiv
> 
> -----Original Message-----
> From: Brian Wyld [mailto:[email-masked]]
> Sent: Friday, April 25, 2003 1:46 AM
> To: 'Eric Burger'; 'IETF SPEECHSC (E-mail)'
> Subject: RE: [Speechsc] Administrative Fiat
> 
> 
> Eric,
> 
> Sounds good to me...... although I believe there is still a 
> significant base
> of COBOL applications that may be critical to address.......
> 
> Or, I contra-propose:
> 1. the protocol will be RTSP extended to include the current 
> MRCP messages
> 'natively', with addition of specific  messages for SR/SI, 
> and to define the
> 'call session' mapping to the MRCP requests.
> 
> 2. there will be a web services binding....
> 
> (sorry to be serious here)
> 
> Brian
> 
> [Brian Wyld] [[email-masked]]
> [Directeur General R&D]
> [Eloquant SA] [+33 476 77 46 92] [www.eloquant.com]
> [advanced solutions for telecoms and IT services]
> 
> > -----Message d'origine-----
> > De : [email-masked]
> > [mailto:[email-masked]]De la part
> > de Eric Burger
> > Envoyé : Thursday, April 24, 2003 17:03
> > À : IETF SPEECHSC (E-mail)
> > Objet : [Speechsc] Administrative Fiat
> >
> >
> > Date: 1 April 2003
> > [everything associated with speechsc seems to go out late]
> >
> > Since there has been no progress on the protocol analysis
> > document, I have made the following decisions:
> >
> > 1. We need a new protocol.
> >
> > 2. Since no one seems to care, the protocol will be based on
> > BEEP and CORBA.
> >
> > 3. To ensure that people use the protocol, we will publish an
> > ADA binding.
> >
> > Unless I hear otherwise, this is the direction we will go.
> >
> > --
> > - Eric
> >
> >
> > P.S.  If I don't hear otherwise, we can consider the work of
> > the work group complete.
> >
> > _______________________________________________
> > Speechsc mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/speechsc
> >
> 
> _______________________________________________
> Speechsc mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/speechsc
> _______________________________________________
> Speechsc mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/speechsc
> 

_______________________________________________
Speechsc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speechsc

---

From: "karlmutc" <[email-masked]>
Date: Thu, 8 May 2003 11:47:35 -0700

> Is there value to it being a first-level protocol inside an existing
protocol?

Yes technically.

However, pragmatically, the difficulty for users/consumers is
getting a usable implementation from the open/free source
arena that is free from vendor drag.  This requires forethought
about how current open source efforts might fit.  Ok so I'm
putting the cart before the horse but its worth some thought
given the complexity of existing VoIP implementations which are
available. And where complexity could be a real barrier to adoption.

Thanks
Karl

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf
Of Eric Burger
Sent: Thursday, May 08, 2003 11:21 AM
To: Brian Eberman; IETF SPEECHSC (E-mail)
Subject: [Speechsc] speechsc as a first-level protocol

Is there consensus on raising speechsc to being a first-level protocol?
That is, it will NOT be embedded in SIP, RTSP, or :-) SNMP?

Is there value to it being a first-level protocol inside an existing
protocol?  That is, use the session establishment and proxy infrastructure
of SIP or RTSP and have speechsc-specific primitives as protocol extensions.

---

From: "Brian Wyld" <[email-masked]>
Date: Fri, 9 May 2003 17:58:18 +0200

Sounds good to me IFF we mean by this not neccessarily reinventing the whole
thing, but doing a pick-n-mix from current protocols.....

Brian

 (eg, stick the SETUP and TEARDOWN messages from RTSP into MRCP draft, add
MRCPSESSIONSTART/MRCPSESSIONEND messages to identify call start/end context
and move onto thez virgin territory of SV/SI....)

> Envoyé : Thursday, May 08, 2003 20:21
> À : Brian Eberman; IETF SPEECHSC (E-mail)
> Objet : [Speechsc] speechsc as a first-level protocol
>
>
> Is there consensus on raising speechsc to being a first-level
> protocol?  That is, it will NOT be embedded in SIP, RTSP, or :-) SNMP?
>
> Is there value to it being a first-level protocol inside an
> existing protocol?  That is, use the session establishment
> and proxy infrastructure of SIP or RTSP and have
> speechsc-specific primitives as protocol extensions.
>

---

From: Sarvi Shanmugham <[email-masked]>
Date: Fri, 09 May 2003 09:49:13 -0700

Hi Brian,
       Great. I am half way through a proposal trying to do exactly 
that. Since there was not much activity, I thought a proposal document 
would drive some discussion. So after consulting with Eric, I have been 
writing a proposal, doing exactly that.

As part 1, I have taken out all RTSP tunnelling and related aspects from 
the currentt MRCP specification, this is done.  As Part to 2, I am 
adding/advocating SIP based INVITE/BYE extensions a choice to create and 
manage the session.

I will hopefully have this proposal done by the beginning of the week 
after next.

Sarvi

---

From: "Brian Wyld" <[email-masked]>
Date: Fri, 9 May 2003 18:51:25 +0200

Hi,

Great! However, I would REALLY like to see separation of the media
setup/teardown function and the concept of 'mrcp' session (which could be
mapped onto a call nicely).

My experience with MRCP so far is that this can be a prickly issue (for
those ASR vendors who have strong licensing view about ports and calls!!!)

Brian

  -----Message d'origine-----
  De : Sarvi Shanmugham [mailto:[email-masked]]
  Envoyé : Friday, May 09, 2003 18:49
  À : [email-masked]
  Cc : 'Eric Burger'; 'Brian Eberman'; 'IETF SPEECHSC (E-mail)'
  Objet : Re: [Speechsc] speechsc as a first-level protocol

  Hi Brian,
         Great. I am half way through a proposal trying to do exactly that.
Since there was not much activity, I thought a proposal document would drive
some discussion. So after consulting with Eric, I have been writing a
proposal, doing exactly that.

  Sarvi

  Brian Wyld wrote:

Brian

-----Original Message-----
From: Brian Eberman [mailto:[email-masked]]
Sent: Mon, May 05, 2003 3:13 PM
To: Eric Burger; IETF SPEECHSC (E-mail)
Subject: RE: [Speechsc] Administrative Fiat

Eric,

-Brian E.

-----Original Message-----

Brian,

Thanks,

-Rajiv

-----Original Message-----
From: Brian Wyld [mailto:[email-masked]]
Sent: Friday, April 25, 2003 1:46 AM
To: 'Eric Burger'; 'IETF SPEECHSC (E-mail)'
Subject: RE: [Speechsc] Administrative Fiat

Eric,

Or, I contra-propose:

Brian

-----Message d'origine-----

Date: 1 April 2003

--
- Eric

---

From: Sarvi Shanmugham <[email-masked]>
Date: Fri, 09 May 2003 10:10:53 -0700

Absolutely. This will only be an initial proposal.
We need to work out ways of differentiating/separating  the session to 
the the Media server and the call that is being treated and figure how 
to share the media  session and use it for different calls.

Sarvi

Brian Wyld wrote:

> setup/teardown function and the concept of 'mrcp' session (which could 
> be mapped onto a call nicely).
>  
> My experience with MRCP so far is that this can be a prickly issue 
> (for those ASR vendors who have strong licensing view about ports and 
> calls!!!)
>  
> Brian
>  
>
>  
>
>            Great. I am half way through a proposal trying to do
>     exactly that. Since there was not much activity, I thought a
>     proposal document would drive some discussion. So after consulting
>     with Eric, I have been writing a proposal, doing exactly that.
>
>     As part 1, I have taken out all RTSP tunnelling and related
>     aspects from the currentt MRCP specification, this is done.  As
>     Part to 2, I am adding/advocating SIP based INVITE/BYE extensions
>     a choice to create and manage the session.
>
>     I will hopefully have this proposal done by the beginning of the
>     week after next.
>
>     Sarvi
>
>
>     Brian Wyld wrote:
>

---

From: "Neil Deason" <[email-masked]>
Date: Fri, 9 May 2003 11:40:29 -0700

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Sarvi Shanmugham
Sent: 09 May 2003 09:49
To: [email-masked]
Cc: 'Eric Burger'; 'Brian Eberman'; 'IETF SPEECHSC (E-mail)'
Subject: Re: [Speechsc] speechsc as a first-level protocol

Hi Brian,

manage the session 
 
I am glad to see this part being included. I think this is the proper
relationship between speechsc and SIP.
 
FYI I wrote a somewhat rough and ready draft on SDP usage for SOAP
sessions:

http://www.ietf.org/internet-drafts/draft-deason-mmusic-sdp-soap-00.txt
 
If I can be of any help contributing to work on SIP/SDP for 'speechsc'
sessions please ask.
 
Cheers,
Neil.