Subject: RE: [Speechsc] Name for the Speechsc protocol

From: "Rajiv Dharmadhikari" <[email-masked]>
Date: Tue, 29 Jul 2003 14:19:57 -0700

"MRCP" name is already gaining traction with customers, VoiceXML platform vendors and developer community. The new protocol proposed as part of SPEECHSC is reusing the original MRCP resource control primitives except for modifcations in session establishment. So, it is an evolution from the original MRCP. Therefore, I will support the protocol to be called as "MRCP Version 2". In any case, "SPEECHSC" is awkward to pronounce:-)

-Rajiv

-----Original Message-----
From: David R. Oran [mailto:[email-masked]]
Sent: Tuesday, July 29, 2003 8:15 AM
To: [email-masked]
Subject: [Speechsc] Name for the Speechsc protocol

Now that we have a candidate protocol document for SPEECHSC, we get the fun 
task of cooking up a name. In the absence of better suggestions, the 
default would in fact be "SPEECHSC".

I would like to suggest an alternative for the consideration of the working 
group. This is based on a conversation I had with one of our ADs (Allison) 
during a break at the IETF meeting.

There are some advantages to calling the protocol "MRCP Version 2". One is 
that there is some market visibility for MRCP and it's easier to re-use the 
name than socialize a new name. The second is that while the IESG is 
willing to publish MRCP (version 1) as an informational RFC, we definitely 
don't want a dual-track in the market as we've seen with MGCP and MEGACO, 
and instead clearly position the new protocol as superseding and 
obsolescing MRCP version 1. The easiest way to do this is to simply call it 
version 2.

One counter-argument to this logic is that that the protocol we are working 
on is not backwards compatible with the existing deployed MRCP. Such 
backward compatibility is often expected of a protocol with the same name 
and a higher version number. This is not cast on stone tablets however.

Opinions and alternatives welcome. Please post to the list. I would like to 
see if we can get consensus on a name in time for the authors to post the 
first WG-item draft of the protocol, so we only have one name change.

Thanks, Dave.

------------------------
David R. Oran
Cisco Systems
7 Ladyslipper Lane
Acton, MA 01720
Office: +1 978 264 2048
VoIP: +1 408 571 4576
Email: [email-masked]

_______________________________________________
Speechsc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speechsc

_______________________________________________
Speechsc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speechsc

---

From: "Brian Wyld" <[email-masked]>
Date: Wed, 30 Jul 2003 09:41:56 +0200

MRCPv2 gets my vote also....

Given that MRCPv1 (as we should now call it) is really being used and
required, maybe we need a requirement on v2 that there is some kind of
"compatibility mode" or mapping (so one can have a v1<->v2 proxy) defined?

Brian

[Brian Wyld] [[email-masked]]
[Directeur General R&D]
[Eloquant SA] [+33 476 77 46 92] [www.eloquant.com]
[advanced solutions for telecoms and IT services]

> -----Message d'origine-----
> De : [email-masked] [mailto:[email-masked]]De
> la part de Rajiv Dharmadhikari
> Envoye : Tuesday, July 29, 2003 23:20
> A : David R. Oran; [email-masked]
> Objet : RE: [Speechsc] Name for the Speechsc protocol
>
>
> "MRCP" name is already gaining traction with customers, VoiceXML
> platform vendors and developer community. The new protocol
> proposed as part of SPEECHSC is reusing the original MRCP
> resource control primitives except for modifcations in session
> establishment. So, it is an evolution from the original MRCP.
> Therefore, I will support the protocol to be called as "MRCP
> Version 2". In any case, "SPEECHSC" is awkward to pronounce:-)
>
> -Rajiv
>