Subject: RE: [Speechsc] Name for the Speechsc protocol

From: "Eric Burger" <[email-masked]>
Date: Tue, 29 Jul 2003 16:43:48 -0400

I also had some private conversations in Vienna.  Here are some takeaways:

1. MRCP is gaining some traction -- vendors are a bit hesitant about supporting the SPEECHSC effort because of bad experiences in the MGCP/MEGACO split.

2. Vendors like the idea that the protocol formerly known as SPEECHSC (t.p.f.k.a.s) uses most of the syntax, grammar, and machinery of MRCP.  Said differently, the migration from MRCP to t.p.f.k.a.s. is mostly about cutting out code, not writing entirely new code.

3. Calling t.p.f.k.a.s. MRCPv2 gives implementers a clue that we are talking about evolution, not revolution.  Investments made today in MRCP will not be lost on MRCPv2.

4. Calling t.p.f.k.a.s. MRCPv2 signals to users that there is a migration path from MRCP to "the next thing."  Part of the very slow adoption of H.248.1 over MGCP is they are different beasts.  Users tended to like one or the other, and have no plans for migration.  In our case, it makes sense to hint that a migration from MRCP (informational, not a standard) to MRCPv2 (standards track) is just part of the normal evolution of the protocol.

Thus my vote (chair hat off) is also MRCPv2.

> -----Original Message-----
> From: David R. Oran [mailto:[email-masked]]
> Sent: Tue, July 29, 2003 11:15 AM
> To: [email-masked]
> Subject: [Speechsc] Name for the Speechsc protocol
> 
> 
> Now that we have a candidate protocol document for SPEECHSC, 
> we get the fun 
> task of cooking up a name. In the absence of better suggestions, the 
> default would in fact be "SPEECHSC".
> 
> I would like to suggest an alternative for the consideration 
> of the working 
> group. This is based on a conversation I had with one of our 
> ADs (Allison) 
> during a break at the IETF meeting.
> 
> There are some advantages to calling the protocol "MRCP 
> Version 2". One is 
> that there is some market visibility for MRCP and it's easier 
> to re-use the 
> name than socialize a new name. The second is that while the IESG is 
> willing to publish MRCP (version 1) as an informational RFC, 
> we definitely 
> don't want a dual-track in the market as we've seen with MGCP 
> and MEGACO, 
> and instead clearly position the new protocol as superseding and 
> obsolescing MRCP version 1. The easiest way to do this is to 
> simply call it 
> version 2.
> 
> One counter-argument to this logic is that that the protocol 
> we are working 
> on is not backwards compatible with the existing deployed MRCP. Such 
> backward compatibility is often expected of a protocol with 
> the same name 
> and a higher version number. This is not cast on stone 
> tablets however.
> 
> Opinions and alternatives welcome. Please post to the list. I 
> would like to 
> see if we can get consensus on a name in time for the authors 
> to post the 
> first WG-item draft of the protocol, so we only have one name change.
> 
> Thanks, Dave.
> 
> ------------------------
> David R. Oran
> Cisco Systems
> 7 Ladyslipper Lane
> Acton, MA 01720
> Office: +1 978 264 2048
> VoIP: +1 408 571 4576
> Email: [email-masked]
> 
> _______________________________________________
> Speechsc mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/speechsc
> 
> 

_______________________________________________
Speechsc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speechsc

---

From: Brian Marquette <[email-masked]>
Date: Tue, 29 Jul 2003 21:24:52 -0600

Eric,

You make excellent points.

In our experience the industry has come to recognize the term MRCP and
understand the basic semantics of the protocol. Choosing any other name
would cause a certain amount of confusion among customers. 

Also using MRCPv2 implies that the basics of the protocol are consistent. 

So count us among those supporting the name MRCPv2.

brian

-----Original Message-----
From: Eric Burger [mailto:[email-masked]] 
Sent: Tuesday, July 29, 2003 2:44 PM
To: [email-masked]
Subject: RE: [Speechsc] Name for the Speechsc protocol

1. MRCP is gaining some traction -- vendors are a bit hesitant about
supporting the SPEECHSC effort because of bad experiences in the MGCP/MEGACO
split.

2. Vendors like the idea that the protocol formerly known as SPEECHSC
(t.p.f.k.a.s) uses most of the syntax, grammar, and machinery of MRCP.  Said
differently, the migration from MRCP to t.p.f.k.a.s. is mostly about cutting
out code, not writing entirely new code.

3. Calling t.p.f.k.a.s. MRCPv2 gives implementers a clue that we are talking
about evolution, not revolution.  Investments made today in MRCP will not be
lost on MRCPv2.

4. Calling t.p.f.k.a.s. MRCPv2 signals to users that there is a migration
path from MRCP to "the next thing."  Part of the very slow adoption of
H.248.1 over MGCP is they are different beasts.  Users tended to like one or
the other, and have no plans for migration.  In our case, it makes sense to
hint that a migration from MRCP (informational, not a standard) to MRCPv2
(standards track) is just part of the normal evolution of the protocol.

> [email-masked] https://www1.ietf.org/mailman/listinfo/speechsc
> 
> 

_______________________________________________
Speechsc mailing list
[email-masked] https://www1.ietf.org/mailman/listinfo/speechsc

---

From: "Pierre Forgues" <[email-masked]>
Date: Wed, 30 Jul 2003 07:09:22 -0400

I would agree to calling it MRCPv2 as well, but I would steer clear of backward compatibility being necessary.  I like Brian's idea of documenting the compatibility issues should one want to write a proxy.  /Pierre

> From: Brian Wyld [mailto:[email-masked]]
> Sent: Wednesday, July 30, 2003 3:42 AM
> To: Rajiv Dharmadhikari; David R. Oran; [email-masked]
> MRCPv2 gets my vote also....
> 
> Given that MRCPv1 (as we should now call it) is really being used and
> required, maybe we need a requirement on v2 that there is some kind of
> "compatibility mode" or mapping (so one can have a v1<->v2 
> proxy) defined?
> 
> Brian
> 
> [Brian Wyld] [[email-masked]]
> [Directeur General R&D]
> [Eloquant SA] [+33 476 77 46 92] [www.eloquant.com]
> [advanced solutions for telecoms and IT services]
> 
> > -----Message d'origine-----
> > De : [email-masked] [mailto:[email-masked]]De
> > la part de Rajiv Dharmadhikari
> > Envoye : Tuesday, July 29, 2003 23:20
> > A : David R. Oran; [email-masked]
> > Objet : RE: [Speechsc] Name for the Speechsc protocol
> >
> >
> > "MRCP" name is already gaining traction with customers, VoiceXML
> > platform vendors and developer community. The new protocol
> > proposed as part of SPEECHSC is reusing the original MRCP
> > resource control primitives except for modifcations in session
> > establishment. So, it is an evolution from the original MRCP.
> > Therefore, I will support the protocol to be called as "MRCP
> > Version 2". In any case, "SPEECHSC" is awkward to pronounce:-)
> >
> > -Rajiv
> >
> > Sent: Tuesday, July 29, 2003 8:15 AM
> > To: [email-masked]
> > Now that we have a candidate protocol document for SPEECHSC, we
> > get the fun
> > I would like to suggest an alternative for the consideration of
> > the working
> > group. This is based on a conversation I had with one of our ADs
> > (Allison)
> > There are some advantages to calling the protocol "MRCP Version
> > 2". One is
> > that there is some market visibility for MRCP and it's easier to
> > re-use the
> > willing to publish MRCP (version 1) as an informational RFC, we
> > definitely
> > don't want a dual-track in the market as we've seen with 
> MGCP and MEGACO,
> > One counter-argument to this logic is that that the protocol we
> > are working
> > see if we can get consensus on a name in time for the 
> authors to post the

---

From: "Eric Burger" <[email-masked]>
Date: Wed, 30 Jul 2003 14:35:22 -0400

If we want to go this route (describing compatibility), I would suggest putting that into a separate document, for now.

Clearly, it will have to wait until the bulk of the work on the new protocol is done.

> From: Pierre Forgues [mailto:[email-masked]]
> Sent: Wed, July 30, 2003 7:09 AM
> To: [email-masked]; Rajiv Dharmadhikari; David R. 
> Oran; [email-masked]
> I would agree to calling it MRCPv2 as well, but I would steer 
> clear of backward compatibility being necessary.  I like 
> Brian's idea of documenting the compatibility issues should 
> one want to write a proxy.  /Pierre
>